aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2017-02-03 15:05:38 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2017-02-03 15:05:38 +0000
commit804e74c1a99db5d834b4cefcc7fff80e47e3742d (patch)
treecfe898313234770a5fcd6f532ca6657de627abb9
parente522a38a964a7dcbde3d53acbd25b32bb407a2ba (diff)
downloadports-804e74c1a99db5d834b4cefcc7fff80e47e3742d.tar.gz
ports-804e74c1a99db5d834b4cefcc7fff80e47e3742d.zip
Notes
-rw-r--r--lang/gcc49/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index a495c8902cc9..c0a176bbf625 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -28,12 +28,11 @@ CONFLICTS= gcc-4.9.*
CPE_VENDOR= gnu
CPE_VERSION= ${GCC_VERSION}
-# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
-# of executables and directories once installed.
-DISTVERSION= ${PORTVERSION}
-GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
+# GCC_VERSION and SUFFIX relate to names of executables and directories
+# once installed.
+GCC_VERSION= ${PORTVERSION}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-ONLY_FOR_ARCHS= amd64 armv6 armv6hf i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= amd64 armv6 i386 powerpc powerpc64 sparc64
USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:bzip2
USE_BINUTILS= yes
USE_PERL5= build
@@ -68,8 +67,8 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
CONFIGURE_ENV+= UNAME_m="powerpc64"
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
-# We have to override the sys.mk -O CFLAGS since it breaks libgomp building.
+.if ${ARCH} == "armv6"
+# Override sys.mk including -O in CFLAGS which breaks libgomp building.
CFLAGS:= ${CFLAGS:S/-O/-O2/g}
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
@@ -119,7 +118,7 @@ INFO= gcc${SUFFIX}/cpp \
#.if ${ARCH} == "i386" || ${ARCH} == "amd64"
INFO+= gcc${SUFFIX}/libquadmath
#.endif
-.if ${ARCH} == "i386" || ${ARCH} == "amd64" || ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+.if ${ARCH} == "i386" || ${ARCH} == "amd64" || ${ARCH} == "armv6"
INFO+= gcc${SUFFIX}/libitm
.endif