aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-14 15:39:55 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-14 15:39:55 +0000
commit83c866582685f3a2e746dff88754f482f188b3cb (patch)
tree878c1dcfbc68dfde699df6e17203f23ef47f64be
parent20e947a006da27244f9f9d19a4dc6aa28d27f9d9 (diff)
downloadports-83c866582685f3a2e746dff88754f482f188b3cb.tar.gz
ports-83c866582685f3a2e746dff88754f482f188b3cb.zip
Notes
-rw-r--r--net-mgmt/flowd/Makefile4
-rw-r--r--net-mgmt/icinga/Makefile3
-rw-r--r--net-mgmt/ipplan/Makefile3
-rw-r--r--net-mgmt/mrtg/Makefile2
-rw-r--r--net-mgmt/nagios-check_hp_bladechassis/Makefile3
-rw-r--r--net-mgmt/nedi/Makefile2
-rw-r--r--net-mgmt/ourmon/Makefile2
-rw-r--r--net-mgmt/p5-FusionInventory-Agent/Makefile4
-rw-r--r--net-mgmt/pandorafms_server/Makefile3
-rw-r--r--net-mgmt/rancid/Makefile3
-rw-r--r--net-mgmt/smokeping/Makefile3
-rw-r--r--www/amphetadesk/Makefile2
-rw-r--r--www/cacheboy16/Makefile2
-rw-r--r--www/chromium/Makefile4
-rw-r--r--www/mod_perl2/Makefile4
-rw-r--r--www/p5-Template-Provider-FromDATA/Makefile3
-rw-r--r--www/p5-WWW-TinySong/Makefile3
-rw-r--r--www/privoxy/Makefile5
-rw-r--r--www/squid33/Makefile2
19 files changed, 31 insertions, 26 deletions
diff --git a/net-mgmt/flowd/Makefile b/net-mgmt/flowd/Makefile
index ea6ba726bdfc..547dd312c214 100644
--- a/net-mgmt/flowd/Makefile
+++ b/net-mgmt/flowd/Makefile
@@ -17,9 +17,9 @@ OPTIONS_DEFAULT=PERL
PERL_DESC= Install flowd perl module
PYTHON_DESC= Install flowd Python support
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
-USE_GMAKE= yes
USE_RC_SUBR= flowd
MAN8= flowd.8 flowd-reader.8
MAN5= flowd.conf.5
@@ -31,7 +31,7 @@ GROUPS= ${FLOWD_USER}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
PLIST_SUB+= PERL=""
MAN3= Flowd.3
.else
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index 72e808b39b9d..9ebe22d3f3f8 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -90,7 +90,8 @@ APACHE_DESC= Depend on Apache and install webconfig
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMBEDDED_PERL}
-USE_PERL5_BUILD= yes
+USES+= perl5
+USE_PERL5= build
CONFIGURE_ARGS+= --enable-embedded-perl \
--with-perlcache
PLIST_SUB+= EMBEDDED_PERL=""
diff --git a/net-mgmt/ipplan/Makefile b/net-mgmt/ipplan/Makefile
index ca10e75ebd26..212889a7a81f 100644
--- a/net-mgmt/ipplan/Makefile
+++ b/net-mgmt/ipplan/Makefile
@@ -15,7 +15,8 @@ COMMENT= IP address management and tracking
RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_PHP= gettext pcre xml zlib
NO_BUILD= yes
diff --git a/net-mgmt/mrtg/Makefile b/net-mgmt/mrtg/Makefile
index 2e5008ad7822..9779effb4866 100644
--- a/net-mgmt/mrtg/Makefile
+++ b/net-mgmt/mrtg/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
USERS= mrtg
GROUPS= mrtg
-USE_PERL5= YES
+USES= perl5
MAKE_ENV+= PERL=${PERL}
MRTG_RUNDIR?= /var/run/mrtg
diff --git a/net-mgmt/nagios-check_hp_bladechassis/Makefile b/net-mgmt/nagios-check_hp_bladechassis/Makefile
index 02801c514c67..cdaaf5d9f13d 100644
--- a/net-mgmt/nagios-check_hp_bladechassis/Makefile
+++ b/net-mgmt/nagios-check_hp_bladechassis/Makefile
@@ -19,8 +19,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
-USE_PERL5_RUN= yes
MAN8= check_hp_bladechassis.8
PLIST_FILES= libexec/nagios/check_hp_bladechassis
PLIST_DIRSTRY= libexec/nagios/
diff --git a/net-mgmt/nedi/Makefile b/net-mgmt/nedi/Makefile
index 02ef269c43fc..03e30e7adffe 100644
--- a/net-mgmt/nedi/Makefile
+++ b/net-mgmt/nedi/Makefile
@@ -17,8 +17,8 @@ RUN_DEPENDS= p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= perl5
NO_BUILD= yes
-USE_PERL5= yes
OPTIONS_DEFINE= GD
GD_DESC= Use GD
diff --git a/net-mgmt/ourmon/Makefile b/net-mgmt/ourmon/Makefile
index c56f923f3443..b88341bd5bfa 100644
--- a/net-mgmt/ourmon/Makefile
+++ b/net-mgmt/ourmon/Makefile
@@ -20,8 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap \
RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
WRKSRC= ${WRKDIR}/mrourmon
+USES= perl5
USE_APACHE_RUN= 22+
-USE_PERL5= yes
NO_BUILD= yes
NO_INSTALL_MANPAGES= yes
IS_INTERACTIVE= yes
diff --git a/net-mgmt/p5-FusionInventory-Agent/Makefile b/net-mgmt/p5-FusionInventory-Agent/Makefile
index ba2b1f41e757..750b33a0959c 100644
--- a/net-mgmt/p5-FusionInventory-Agent/Makefile
+++ b/net-mgmt/p5-FusionInventory-Agent/Makefile
@@ -38,8 +38,8 @@ ZLIB_DESC= Zlib compression
DMIDECODE_DESC= Dmidecode hardware information
PCIUTILS_DESC= Pciutils hardware information
-PERL_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= configure
MAN1= fusioninventory-agent.1 \
fusioninventory-injector.1
diff --git a/net-mgmt/pandorafms_server/Makefile b/net-mgmt/pandorafms_server/Makefile
index c70e889866b7..1c75e4523c1d 100644
--- a/net-mgmt/pandorafms_server/Makefile
+++ b/net-mgmt/pandorafms_server/Makefile
@@ -42,7 +42,8 @@ PGSQL_DESC= Use PostgreSQL backend (experimental)
ORACLE_DESC= Use Oracle backend (experimental)
EXTRAS_DESC= Extra dependencies for util scripts
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
SUB_LIST+= PERL="${PERL}"
MAN1= pandora_server.1
diff --git a/net-mgmt/rancid/Makefile b/net-mgmt/rancid/Makefile
index 8ea730fc2640..1f46a90ea11c 100644
--- a/net-mgmt/rancid/Makefile
+++ b/net-mgmt/rancid/Makefile
@@ -13,9 +13,8 @@ BUILD_DEPENDS= expect:${PORTSDIR}/lang/expect-devel
RUN_DEPENDS= expect:${PORTSDIR}/lang/expect-devel \
p5-LockFile-Simple>=0:${PORTSDIR}/devel/p5-LockFile-Simple
-USE_PERL5= yes
+USES= gmake perl5
SUB_FILES= pkg-message
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/var/${PORTNAME}/ \
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index ec5a5fa11359..b48bfe070735 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -21,8 +21,7 @@ BUILD_DEPENDS= p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ENV+= PERL=${PERL} PERL5LIB=${PREFIX}/smokeping/lib
CONFIGURE_ARGS+= \
diff --git a/www/amphetadesk/Makefile b/www/amphetadesk/Makefile
index 460cba0c0f37..0aba764d578a 100644
--- a/www/amphetadesk/Makefile
+++ b/www/amphetadesk/Makefile
@@ -25,7 +25,7 @@ LICENSE_NAME= The Clarified Artistic License
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_FILE= ${WRKSRC}/docs/LICENSE
-USE_PERL5= yes
+USE= perl5
USE_RC_SUBR= ${PORTNAME}
NO_BUILD= yes
diff --git a/www/cacheboy16/Makefile b/www/cacheboy16/Makefile
index b00cde95c4be..c6b97064724a 100644
--- a/www/cacheboy16/Makefile
+++ b/www/cacheboy16/Makefile
@@ -14,8 +14,8 @@ COMMENT= HTTP Caching Proxy (Squid Derivative) - Development Release
CONFLICTS= squid-[0-9]* cacheboy*
LATEST_LINK= cacheboy16
+USES= perl5
GNU_CONFIGURE= yes
-USE_PERL5= yes
USE_RC_SUBR= squid
SQUID_UID?= squid
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 2b5d12e9fb1f..24d116bc2a1b 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -47,8 +47,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/a
ONLY_FOR_ARCHS= i386 amd64
USE_XZ= yes
-USES= bison desktop-file-utils pkgconfig
-USE_PERL5_BUILD= yes
+USES= bison desktop-file-utils pkgconfig perl5
+USE_PERL5= build
USE_PYTHON_BUILD= 2.6-2.7
USE_XORG= scrnsaverproto x11 xproto xscrnsaver xtst
USE_GNOME= glib20 gtk20 dconf libxslt
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index ef8db1c0245c..22c9e4be5e82 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -19,8 +19,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
SUB_FILES= pkg-message
SUB_LIST= APACHEMODDIR=${APACHEMODDIR}
USE_APACHE= 22+
-PERL_CONFIGURE= yes
-GMAKE= yes
+USES= gmake perl
+USE_PERL5= configure
USE_CSTD= gnu89
MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
diff --git a/www/p5-Template-Provider-FromDATA/Makefile b/www/p5-Template-Provider-FromDATA/Makefile
index f8e4c04c3a3b..249edc80e9f9 100644
--- a/www/p5-Template-Provider-FromDATA/Makefile
+++ b/www/p5-Template-Provider-FromDATA/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Template-Toolkit>=2.15:${PORTSDIR}/www/p5-Template-Toolkit \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Provider::FromDATA.3
diff --git a/www/p5-WWW-TinySong/Makefile b/www/p5-WWW-TinySong/Makefile
index 4d3ca7a1c1be..f98fad62eaf4 100644
--- a/www/p5-WWW-TinySong/Makefile
+++ b/www/p5-WWW-TinySong/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::TinySong.3
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 8663c78e55c7..dc2f26921597 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= autoconf
USE_RC_SUBR= privoxy
@@ -79,7 +79,8 @@ CONFIGURE_ARGS+= --disable-toggle
.endif
.if ${PORT_OPTIONS:MPRIVOXY_TOOLS}
-USE_PERL5_RUN= yes
+USES+= perl5
+USE_PERL5= run
RUN_DEPENDS+= curl:${PORTSDIR}/ftp/curl
PLIST_SUB+= PRIVOXY_TOOLS=""
.else
diff --git a/www/squid33/Makefile b/www/squid33/Makefile
index e3013aad8122..89d4ff51419d 100644
--- a/www/squid33/Makefile
+++ b/www/squid33/Makefile
@@ -88,9 +88,9 @@ LATEST_LINK= squid33
SQUID_STABLE_VER= 8
CONFLICTS_INSTALL= squid-2.[0-9].* squid-3.[!3].* cacheboy-[0-9]* lusca-head-[0-9]*
+USES= perl5
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_PERL5= yes
USE_RC_SUBR= squid
USERS= squid