aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2010-05-05 05:09:37 +0000
committerCy Schubert <cy@FreeBSD.org>2010-05-05 05:09:37 +0000
commit8a63072c03e5f085f0b91e8a8140a1a9c4368679 (patch)
tree5abf49ed7445324fa4acf07b83d84e697a1b67c7
parent0040fcc0b6abbfab42703c4628a3b07cc8ddd30a (diff)
downloadports-8a63072c03e5f085f0b91e8a8140a1a9c4368679.tar.gz
ports-8a63072c03e5f085f0b91e8a8140a1a9c4368679.zip
Notes
-rw-r--r--security/pam_krb5/Makefile24
-rw-r--r--security/pam_krb5/distinfo6
-rw-r--r--security/pam_krb5/files/patch-configure11
-rw-r--r--security/pam_krb5/files/patch-pam_krb5afs.c10
-rw-r--r--security/pam_krb5/pkg-descr2
-rw-r--r--security/pam_krb5/pkg-plist4
6 files changed, 11 insertions, 46 deletions
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index 1b0f57862e01..aa5248c967f4 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -6,30 +6,21 @@
#
PORTNAME= pam_krb5
-PORTVERSION= 1.3.r7
-PORTREVISION= 3
+PORTVERSION= 4.2
CATEGORIES= security
-MASTER_SITES= SF/pam-krb5/${PORTNAME}/${PORTNAME}-1.3-rc7
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
+MASTER_SITES= http://archives.eyrie.org/software/kerberos/
+DISTNAME= pam-krb5-${PORTVERSION:S/.r/-rc/}
MAINTAINER= cy@FreeBSD.org
COMMENT= A Pluggable Authentication Module for Kerberos 5
-MAN5= pam_krb5.5 pam_krb5afs.5
-MAN8= pam_krb5.8 pam_krb5afs.8
+MAN5= pam_krb5.5
USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-IGNORE= FreeBSD 5.x and above already ships with its own version of pam_krb5
-
-.if defined(PACKAGE_BUILDING)
-KRB5_IMPL= mit
-.endif
-
.if defined(KRB5_IMPL) && ${KRB5_IMPL} == heimdal
-LIB_DEPENDS= krb5.21:${PORTSDIR}/security/heimdal
.if defined(HEIMDAL_HOME)
KRB5_DIR?= ${HEIMDAL_HOME}
.endif
@@ -43,15 +34,10 @@ IGNORE= You must define KRB5_IMPL to be \"mit\" or \"heimdal\"
.endif
MANDIR= ${MANPREFIX}/man
-PREFIX= /usr
-MANPREFIX= /usr/share
MANDIR= ${PREFIX}/share/man
KRB5_DIR?= ${LOCALBASE}
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
-CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}" \
- --with-pamdir="${PREFIX}/lib" \
- --with-man-sect=8 \
- --without-krbafs
+CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
post-install:
cd ${WRKSRC} && ${GMAKE} install-man
diff --git a/security/pam_krb5/distinfo b/security/pam_krb5/distinfo
index aa4d32d06d9c..657170fd32e9 100644
--- a/security/pam_krb5/distinfo
+++ b/security/pam_krb5/distinfo
@@ -1,3 +1,3 @@
-MD5 (pam_krb5-1.3-rc7.tar.gz) = 2c7c8974604e5c325bb2e62d0066cdce
-SHA256 (pam_krb5-1.3-rc7.tar.gz) = 18da8d59a0cc50a5ff2887457cd3d87906fe1807b3cf94b5952c05998c0086f1
-SIZE (pam_krb5-1.3-rc7.tar.gz) = 318609
+MD5 (pam-krb5-4.2.tar.gz) = fa8d83531ee084c97fc7beb873a9fa5d
+SHA256 (pam-krb5-4.2.tar.gz) = fb05896f72c2766b3a45df4def80b4dde71b2276abe32390f3c8d2d648f31f28
+SIZE (pam-krb5-4.2.tar.gz) = 390614
diff --git a/security/pam_krb5/files/patch-configure b/security/pam_krb5/files/patch-configure
deleted file mode 100644
index 3b3d21cf4293..000000000000
--- a/security/pam_krb5/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Mar 17 09:31:46 2003
-+++ configure Wed Jan 21 15:26:38 2004
-@@ -11043,7 +11043,7 @@
- # Check whether --with-krbafs or --without-krbafs was given.
- if test "${with_krbafs+set}" = set; then
- withval="$with_krbafs"
-- if test x$withval != xyes ; then
-+ if test x$withval != xyes -a x$withval != xno; then
- KRBAFS=$withval
- CPPFLAGS="-I$withval/include $CPPFLAGS"
- CFLAGS="-I$withval/include $CFLAGS"
diff --git a/security/pam_krb5/files/patch-pam_krb5afs.c b/security/pam_krb5/files/patch-pam_krb5afs.c
deleted file mode 100644
index 545fdded8fec..000000000000
--- a/security/pam_krb5/files/patch-pam_krb5afs.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- pam_krb5afs.c.orig Mon Mar 10 15:37:00 2003
-+++ pam_krb5afs.c Wed Jan 21 15:19:16 2004
-@@ -108,7 +108,6 @@
- #define MODULE_RET_NAME MODULE_NAME "_ret_stash"
-
- #define PAM_SM_AUTH
--#define PAM_SM_ACCT_MGMT
- #define PAM_SM_SESSION
- #define PAM_SM_PASSWORD
-
diff --git a/security/pam_krb5/pkg-descr b/security/pam_krb5/pkg-descr
index 89603de2f45b..8da78163668b 100644
--- a/security/pam_krb5/pkg-descr
+++ b/security/pam_krb5/pkg-descr
@@ -1,4 +1,4 @@
A Pluggable Authentication Module for Kerberos 5, which can
be compiled for either Heimdal or MIT Kerberos.
-WWW: http://www.fcusack.com/
+WWW: http://www.eyrie.org/~eagle/software/pam-krb5/
diff --git a/security/pam_krb5/pkg-plist b/security/pam_krb5/pkg-plist
index 25d2429ddd31..f7f615e95778 100644
--- a/security/pam_krb5/pkg-plist
+++ b/security/pam_krb5/pkg-plist
@@ -1,2 +1,2 @@
-lib/pam_krb5.so
-lib/pam_krb5.la
+lib/security/pam_krb5.so
+lib/security/pam_krb5.la