aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-09 18:41:28 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-09 18:41:28 +0000
commit8c4b2dfb3991d726f0852a2bc73a4a4e34036d03 (patch)
tree2624226d520ba4a0e89f9768bbdb8aa9bfc0ee25
parent8c82bff238a047f344f03df0ed20e344b1c42611 (diff)
downloadports-8c4b2dfb3991d726f0852a2bc73a4a4e34036d03.tar.gz
ports-8c4b2dfb3991d726f0852a2bc73a4a4e34036d03.zip
Notes
-rw-r--r--net/tcptraceroute/Makefile22
-rw-r--r--net/tcptraceroute/distinfo4
-rw-r--r--net/tcptraceroute/files/patch-Makefile36
-rw-r--r--net/tcptraceroute/files/patch-configure73
-rw-r--r--net/tcptraceroute/files/patch-tcptraceroute.c26
-rw-r--r--net/tcptraceroute/pkg-descr25
-rw-r--r--net/tcptraceroute/pkg-plist6
7 files changed, 102 insertions, 90 deletions
diff --git a/net/tcptraceroute/Makefile b/net/tcptraceroute/Makefile
index a3f6f99c12c8..3cc200a35ad8 100644
--- a/net/tcptraceroute/Makefile
+++ b/net/tcptraceroute/Makefile
@@ -2,23 +2,27 @@
# $FreeBSD$
PORTNAME= tcptraceroute
-PORTVERSION= 1.4
-PORTREVISION= 2
+PORTVERSION= 1.5beta7
CATEGORIES= net
-MASTER_SITES= http://michael.toren.net/code/tcptraceroute/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Traceroute implementation using TCP packets
LICENSE= GPLv2
-DEPRECATED= Depends on expired net/libnet10
-EXPIRATION_DATE= 2014-09-30
+LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-BUILD_DEPENDS= ${LOCALBASE}/bin/libnet10-config:${PORTSDIR}/net/libnet10
+OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e 's|libnet-config|libnet10-config|' ${WRKSRC}/Makefile
+GNU_CONFIGURE= yes
+USES= gmake
+
+PORTDOCS= *
+
+USE_GITHUB= yes
+GH_ACCOUNT= mct
+GH_COMMIT= 1ec970e
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>
diff --git a/net/tcptraceroute/distinfo b/net/tcptraceroute/distinfo
index a89e43051c6a..c05672dd327e 100644
--- a/net/tcptraceroute/distinfo
+++ b/net/tcptraceroute/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tcptraceroute-1.4.tar.gz) = 1ef6c4736b55f47d3a2bb26b999cbb409953a112f637bcbec4106da2a0937bde
-SIZE (tcptraceroute-1.4.tar.gz) = 31918
+SHA256 (tcptraceroute-1.5beta7.tar.gz) = 3b27b7c67e2eb00ef800c83e496f1198b992f038de5d3d13aa530ee3b22c77bb
+SIZE (tcptraceroute-1.5beta7.tar.gz) = 119068
diff --git a/net/tcptraceroute/files/patch-Makefile b/net/tcptraceroute/files/patch-Makefile
deleted file mode 100644
index 3edd31ed9068..000000000000
--- a/net/tcptraceroute/files/patch-Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
---- Makefile.orig Mon May 20 03:11:38 2002
-+++ Makefile Tue Aug 20 01:49:27 2002
-@@ -3,20 +3,27 @@
- # tcptraceroute -- A traceroute implementation using TCP packets
- # Copyright (c) 2001, 2002 Michael C. Toren <mct@toren.net>
-
--CC = gcc
--CFLAGS = -O2 -Wall
--DESTDIR=/usr/local/bin
-+CC?= cc
-+CFLAGS?= -O -pipe -Wall
-+LNETINC= `libnet-config --cflags`
-+LNETLIB= `libnet-config --libs`
-+
-+BINDIR= ${PREFIX}/sbin
-+MANDIR= ${PREFIX}/man
-+
-+all: tcptraceroute
-
- tcptraceroute: tcptraceroute.c
-- $(CC) $(CFLAGS) `libnet-config --defines` \
-+ $(CC) $(CFLAGS) `libnet-config --defines` $(LNETINC) \
- -o tcptraceroute tcptraceroute.c \
-- `libnet-config --libs` -lpcap
-+ $(LNETLIB) -lpcap
-
- static:
- $(MAKE) tcptraceroute CFLAGS="$(CFLAGS) -static"
-
- install: tcptraceroute
-- install -D tcptraceroute $(DESTDIR)/tcptraceroute
-+ install -c -s tcptraceroute $(DESTDIR)$(BINDIR)/tcptraceroute
-+ install -c -m 444 tcptraceroute.8 $(DESTDIR)$(MANDIR)/man8/tcptraceroute.8
-
- distrib: clean changelog man
-
diff --git a/net/tcptraceroute/files/patch-configure b/net/tcptraceroute/files/patch-configure
new file mode 100644
index 000000000000..c37e709d1063
--- /dev/null
+++ b/net/tcptraceroute/files/patch-configure
@@ -0,0 +1,73 @@
+--- configure.orig 2006-03-28 13:00:00.000000000 +0800
++++ configure 2014-09-10 00:44:22.750008451 +0800
+@@ -3713,37 +3713,39 @@
+
+ fi;
+
+-LIBNET_CONFIG="libnet-config" # relative, using $PATH
+-
+-# Check whether --with-libnet or --without-libnet was given.
+-if test "${with_libnet+set}" = set; then
+- withval="$with_libnet"
+-
+- LIBNETCC=""
+- LIBNETLD=""
+-
+- test -x "$withval/bin/libnet-config" && LIBNET_CONFIG="$withval/bin/libnet-config"
+- test -x "$withval/libnet-config" && LIBNET_CONFIG="$withval/libnet-config"
+-
+- test -f "$withval/libnet.h" && LIBNETCC="$LIBNETCC -I$withval"
+- test -f "$withval/include/libnet.h" && LIBNETCC="$LIBNETCC -I$withval/include"
+-
+- test -f "$withval/libnet.a" && LIBNETLD="$LIBNETLD -L$withval"
+- test -f "$withval/lib/libnet.a" && LIBNETLD="$LIBNETLD -L$withval/lib"
+-
+- if test -z "$LIBNETCC" -o -z "$LIBNETLD"
+- then
+- { { echo "$as_me:$LINENO: error: No valid libnet library found in $withval" >&5
+-echo "$as_me: error: No valid libnet library found in $withval" >&2;}
+- { (exit 1); exit 1; }; }
+- else
+- CPPFLAGS="$CPPFLAGS $LIBNETCC"
+- LDFLAGS="$LDFLAGS $LIBNETLD"
+- { echo "$as_me:$LINENO: using libnet in $withval" >&5
+-echo "$as_me: using libnet in $withval" >&6;}
+- fi
+-
+-fi;
++LIBNET_CONFIG="libnet11-config" # relative, using $PATH
++CPPFLAGS="$CPPFLAGS $(${LIBNET_CONFIG} --cflags)"
++LDFLAGS="$LDFLAGS $(${LIBNET_CONFIG} --libs)"
++
++## Check whether --with-libnet or --without-libnet was given.
++#if test "${with_libnet+set}" = set; then
++# withval="$with_libnet"
++#
++# LIBNETCC=""
++# LIBNETLD=""
++#
++# test -x "$withval/bin/libnet-config" && LIBNET_CONFIG="$withval/bin/libnet-config"
++# test -x "$withval/libnet-config" && LIBNET_CONFIG="$withval/libnet-config"
++#
++# test -f "$withval/libnet.h" && LIBNETCC="$LIBNETCC -I$withval"
++# test -f "$withval/include/libnet.h" && LIBNETCC="$LIBNETCC -I$withval/include"
++#
++# test -f "$withval/libnet.a" && LIBNETLD="$LIBNETLD -L$withval"
++# test -f "$withval/lib/libnet.a" && LIBNETLD="$LIBNETLD -L$withval/lib"
++#
++# if test -z "$LIBNETCC" -o -z "$LIBNETLD"
++# then
++# { { echo "$as_me:$LINENO: error: No valid libnet library found in $withval" >&5
++#echo "$as_me: error: No valid libnet library found in $withval" >&2;}
++# { (exit 1); exit 1; }; }
++# else
++# CPPFLAGS="$CPPFLAGS $LIBNETCC"
++# LDFLAGS="$LDFLAGS $LIBNETLD"
++# { echo "$as_me:$LINENO: using libnet in $withval" >&5
++#echo "$as_me: using libnet in $withval" >&6;}
++# fi
++#
++#fi;
+
+
+ echo "$as_me:$LINENO: checking for pcap_open_live in -lpcap" >&5
diff --git a/net/tcptraceroute/files/patch-tcptraceroute.c b/net/tcptraceroute/files/patch-tcptraceroute.c
deleted file mode 100644
index 28f15e1b7051..000000000000
--- a/net/tcptraceroute/files/patch-tcptraceroute.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- tcptraceroute.c.orig Tue Oct 7 16:04:50 2003
-+++ tcptraceroute.c Tue Oct 7 16:05:22 2003
-@@ -391,9 +391,9 @@
- void usage(void)
- {
- printf("\n%s\n%s\n", VERSION, BANNER);
-- fatal("Usage: %s [-nNFSAE] [-i <interface>] [-f <first ttl>]
-- [-l <packet length>] [-q <number of queries>] [-t <tos>]
-- [-m <max ttl>] [-pP] <source port>] [-s <source address>]
-+ fatal("Usage: %s [-nNFSAE] [-i <interface>] [-f <first ttl>] \
-+ [-l <packet length>] [-q <number of queries>] [-t <tos>] \
-+ [-m <max ttl>] [-pP] <source port>] [-s <source address>] \
- [-w <wait time>] <host> [destination port] [packet length]\n\n", name);
- }
-
-@@ -1182,8 +1182,8 @@
- if (! (pcap = pcap_open_live(device, offset + SNAPLEN, 0, 10, errbuf)))
- fatal("pcap_open_live failed: %s", errbuf);
-
-- safe_snprintf(filter, TEXTSIZE, "
-- (tcp and src host %s and src port %d and dst host %s)
-+ safe_snprintf(filter, TEXTSIZE, " \
-+ (tcp and src host %s and src port %d and dst host %s) \
- or ((icmp[0] == 11 or icmp[0] == 3) and dst host %s)",
- iptos(dst_ip), dst_prt, iptos(src_ip), iptos(src_ip));
-
diff --git a/net/tcptraceroute/pkg-descr b/net/tcptraceroute/pkg-descr
index 46f41ba20522..e19cc9e077c9 100644
--- a/net/tcptraceroute/pkg-descr
+++ b/net/tcptraceroute/pkg-descr
@@ -1,18 +1,17 @@
tcptraceroute is a traceroute implementation using TCP packets.
-The more traditional traceroute(8) sends out either UDP or ICMP ECHO
-packets with a TTL of one, and increments the TTL until the destination
-has been reached. By printing the gateways that generate ICMP time
-exceeded messages along the way, it is able to determine the path
-packets are taking to reach the destination.
+The more traditional traceroute(8) sends out either UDP or ICMP ECHO packets
+with a TTL of one, and increments the TTL until the destination has been
+reached. By printing the gateways that generate ICMP time exceeded messages
+along the way, it is able to determine the path packets are taking to reach the
+destination.
-The problem is that with the widespread use of firewalls on the modern
-Internet, many of the packets that traceroute(8) sends out end up being
-filtered, making it impossible to completely trace the path to the
-destination. However, in many cases, these firewalls will permit inbound
-TCP packets to specific ports that hosts sitting behind the firewall are
-listening for connections on. By sending out TCP SYN packets instead of
-UDP or ICMP ECHO packets, tcptraceroute is able to bypass the most
-common firewall filters.
+The problem is that with the widespread use of firewalls on the modern Internet,
+many of the packets that traceroute(8) sends out end up being filtered, making
+it impossible to completely trace the path to the destination. However, in many
+cases, these firewalls will permit inbound TCP packets to specific ports that
+hosts sitting behind the firewall are listening for connections on. By sending
+out TCP SYN packets instead of UDP or ICMP ECHO packets, tcptraceroute is able
+to bypass the most common firewall filters.
WWW: https://github.com/mct/tcptraceroute
diff --git a/net/tcptraceroute/pkg-plist b/net/tcptraceroute/pkg-plist
index d7390d954fe8..c3d0ebabb648 100644
--- a/net/tcptraceroute/pkg-plist
+++ b/net/tcptraceroute/pkg-plist
@@ -1,4 +1,2 @@
-man/man8/tcptraceroute.8.gz
-@mode 4555
-sbin/tcptraceroute
-@mode
+@(root,wheel,4555) bin/tcptraceroute
+man/man1/tcptraceroute.1.gz