aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-28 03:03:46 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-28 03:03:46 +0000
commit8ccc6a7f5c84637cc3b93225b548bbd8addf7e5c (patch)
tree264de3d975c1835a884aa3b7d69cb6433f2880a9
parent58f1d4449bcc5cf84fe5da0cd06cfcbf053c8664 (diff)
downloadports-8ccc6a7f5c84637cc3b93225b548bbd8addf7e5c.tar.gz
ports-8ccc6a7f5c84637cc3b93225b548bbd8addf7e5c.zip
Notes
-rw-r--r--audio/musescore/Makefile40
-rw-r--r--audio/zynaddsubfx/Makefile78
-rw-r--r--audio/zynaddsubfx/pkg-plist48
-rw-r--r--games/glob2/Makefile100
-rw-r--r--games/glob2/files/patch-SConstruct19
-rw-r--r--games/glob2/files/patch-data__SConscript9
-rw-r--r--games/glob2/files/patch-src_VoiceRecorder.cpp11
-rw-r--r--games/glob2/files/patch-src__ConfigFiles.h (renamed from games/glob2/files/patch-src_ConfigFiles.h)4
-rw-r--r--games/glob2/files/pkg-message.in18
-rw-r--r--games/glob2/pkg-message7
-rw-r--r--games/glob2/pkg-plist24
11 files changed, 189 insertions, 169 deletions
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index 8259ca246e70..e1e7915a2369 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -3,8 +3,9 @@
PORTNAME= musescore
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= SF/mscore/mscore/MuseScore-${PORTVERSION}
+MASTER_SITES= SF/mscore/mscore/MuseScore-${PORTVERSION}/
DISTNAME= mscore-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -13,14 +14,10 @@ COMMENT= Free music composition & notation software
LICENSE= GPLv2
BUILD_DEPENDS= qtscriptgenerator>0:${PORTSDIR}/devel/qtscriptgenerator
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
RUN_DEPENDS= qtscriptgenerator>0:${PORTSDIR}/devel/qtscriptgenerator
-OPTIONS_DEFINE= JACK PORTAUDIO
-OPTIONS_DEFAULT=PORTAUDIO
-
USE_BZIP2= yes
-NO_STAGE= yes
USES= cmake:outsource
USE_QT4= corelib designer gui network script scripttools svg webkit xml \
linguist_build moc_build qmake_build rcc_build uic_build
@@ -31,22 +28,21 @@ MAKE_JOBS_UNSAFE= yes
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION}
-.include <bsd.port.options.mk>
+PORTDOCS= ChangeLog NEWS README README.scripts
+
+OPTIONS_DEFINE= DOCS JACK PORTAUDIO
+OPTIONS_DEFAULT=PORTAUDIO
+
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
-CMAKE_ARGS+= -DBUILD_JACK:BOOL=ON
-.else
-CMAKE_ARGS+= -DBUILD_JACK:BOOL=OFF
-.endif
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CMAKE_ON= -DBUILD_JACK:BOOL=ON
+JACK_CMAKE_OFF= -DBUILD_JACK:BOOL=OFF
-.if ${PORT_OPTIONS:MPORTAUDIO}
-BUILD_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
-RUN_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
-CMAKE_ARGS+= -DBUILD_PORTAUDIO:BOOL=ON
-.else
-CMAKE_ARGS+= -DBUILD_PORTAUDIO:BOOL=OFF
-.endif
+PORTAUDIO_BUILD_DEPENDS=portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_RUN_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_CMAKE_ON= -DBUILD_PORTAUDIO:BOOL=ON
+PORTAUDIO_CMAKE_OFF= -DBUILD_PORTAUDIO:BOOL=OFF
post-patch:
@${FIND} ${WRKSRC} -name "CMakeLists.txt" -print0 | ${XARGS} -0 \
@@ -58,4 +54,8 @@ post-patch:
@${ECHO_CMD} >> ${WRKSRC}/mscore/mscore/${file}
.endfor
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/mscore/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index 1e433aec9abb..0f109eb5fa93 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zynaddsubfx
PORTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF
DISTNAME= ZynAddSubFX-${PORTVERSION}
@@ -15,8 +16,11 @@ LICENSE= GPLv2
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
mxml:${PORTSDIR}/textproc/mxml
-OPTIONS_DEFINE= GUI LASH LO JACK PORTAUDIO DOCS EXAMPLES
-OPTIONS_DEFAULT= GUI
+USE_BZIP2= yes
+USES= cmake pkgconfig
+
+OPTIONS_DEFINE= DOCS EXAMPLES GUI LASH LO JACK PORTAUDIO
+OPTIONS_DEFAULT= GUI PORTAUDIO
OPTIONS_RADIO= AUDIO
OPTIONS_RADIO_AUDIO= ALSAMIDI DSSI
OPTIONS_SUB= yes
@@ -25,32 +29,50 @@ ALSAMIDI_DESC= MIDI input through ALSA
DSSI_DESC= DSSI Plugin
LO_DESC= Open Sound Control support via LibLO
+ALSAMIDI_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
ALSAMIDI_CMAKE_OFF= -DAlsaEnable:BOOL=OFF
-ALSAMIDI_LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib
+
+DSSI_LIB_DEPENDS= libdssialsacompat.so:${PORTSDIR}/audio/libdssialsacompat
DSSI_BUILD_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
+DSSI_RUN_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
DSSI_CFLAGS= -I${LOCALBASE}/include/dssi
DSSI_CMAKE_OFF= -DDssiEnable:BOOL=OFF
-DSSI_LIB_DEPENDS= dssialsacompat:${PORTSDIR}/audio/libdssialsacompat
-DSSI_RUN_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
-GUI_CMAKE_OFF= -DGuiModule:STRING=OFF
-GUI_LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
+
+GUI_LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
GUI_ON= -DGuiModule:STRING=fltk
-JACK_CMAKE_OFF= -DJackEnable:BOOL=OFF
-JACK_LIB_DEPENDS= jack:${PORTSDIR}/audio/jack
-LASH_CMAKE_OFF= -DLashEnabe:BOOL=OFF
-LASH_LIB_DEPENDS= lash:${PORTSDIR}/audio/lash
+GUI_CMAKE_OFF= -DGuiModule:STRING=OFF
+
+LO_LIB_DEPENDS= liblo.so:${PORTSDIR}/audio/liblo
LO_CMAKE_OFF= -DLibloEnable:BOOL=OFF
-LO_LIB_DEPENDS= lo:${PORTSDIR}/audio/liblo
-PORTAUDIO_BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
+
+LASH_LIB_DEPENDS= liblash.so:${PORTSDIR}/audio/lash
+LASH_CMAKE_OFF= -DLashEnabe:BOOL=OFF
+
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CMAKE_OFF= -DJackEnable:BOOL=OFF
+
+PORTAUDIO_BUILD_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_RUN_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2
PORTAUDIO_CFLAGS= -I${LOCALBASE}/include/portaudio2
PORTAUDIO_CMAKE_OFF= -DPaEnabe:BOOL=OFF
PORTAUDIO_LDFLAGS= ${LOCALBASE}/lib/portaudio2/libportaudio.so
-PORTAUDIO_RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
-USE_BZIP2= yes
-USES= cmake pkgconfig
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS.txt ChangeLog FAQ.txt HISTORY.txt README.txt
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= adsynth.txt controller.txt envelope.txt filter.txt intro.txt \
+ lfo.txt mididefaults.txt nrpn.txt saving.txt zynaddsubfx.txt
+
+DOCSRCDIR3= ${WRKSRC}/doc/images
+DOCSDIR3= ${DOCSDIR}/doc/images
+DOC_FILES3= *.png *.jpg
+
+PORTEXAMPLES= *
-.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
@@ -72,19 +94,23 @@ post-patch:
/-g #/d ; \
/pthread/d ; \
s|lib64|lib|' ${WRKSRC}/src/CMakeLists.txt
- @${REINPLACE_CMD} -e \
- 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src/Misc/Config.cpp
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src/Misc/Config.cpp
+ @${REINPLACE_CMD} -e 's|portaudio.h|portaudio2/portaudio.h|' ${WRKSRC}/src/Nio/PaEngine.h
+
post-install:
${MKDIR} ${STAGEDIR}${DATADIR}/banks
(cd ${WRKDIR}/${DISTNAME}/instruments/banks \
&& ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/banks)
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in AUTHORS.txt FAQ.txt HISTORY.txt README.txt
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
-.endfor
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKDIR}/${DISTNAME}/instruments/examples \
- && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR})
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR3}
+ ${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
+
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/instruments/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.post.mk>
diff --git a/audio/zynaddsubfx/pkg-plist b/audio/zynaddsubfx/pkg-plist
index cb2066ab590b..057f49add14f 100644
--- a/audio/zynaddsubfx/pkg-plist
+++ b/audio/zynaddsubfx/pkg-plist
@@ -451,52 +451,6 @@ bin/zynaddsubfx
%%DATADIR%%/banks/SynthPiano/0069-Synth Piano 3 det.xiz
%%DATADIR%%/banks/SynthPiano/0070-Synth Piano 4.xiz
%%DATADIR%%/banks/SynthPiano/0071-Synth Piano 5.xiz
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
-%%PORTDOCS%%%%DOCSDIR%%/HISTORY.txt
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/0km.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio 3.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio 4.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio 5.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio 6.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio Dist 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio Dist 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio Flange 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Arpeggio Flange 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Choir Reeds.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Choir Strings SynthBrass.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Dist Guitar Strings 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Dist Guitar Strings 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Drop.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Fantasy 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Fantasy 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Glass Choir.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HighPass Saw Strings.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Ice Rhodes Strings.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/JI12.xsz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Legatto 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Legatto 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Legatto Strings.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Octave Strings.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Organ Choir Strings.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Saw.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Space 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Space 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Split_keyboard.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/String Reverb.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Strings Reeds 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Strings Reeds 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Struck String Big Reverb 1.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Struck String Big Reverb 2.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Supersaw.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Synth Bells Choir Reverb.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Synth Piano Reverb.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Synth.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bent_synth.xmz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/photons.xmz
@dirrm %%DATADIR%%/banks/SynthPiano
@dirrm %%DATADIR%%/banks/Synth
@dirrm %%DATADIR%%/banks/Strings
@@ -519,5 +473,3 @@ bin/zynaddsubfx
@dirrm %%DATADIR%%/banks/Arpeggios
@dirrm %%DATADIR%%/banks
@dirrm %%DATADIR%%
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index 5762d124b891..6ddb52c205d4 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -1,44 +1,60 @@
# Created by: thierry@pompo.net
# $FreeBSD$
-PORTNAME= glob2
-PORTVERSION= 0.9.4.4
-PORTREVISION= 5
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION:R}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Globulation 2 - a free and innovative strategy game
-
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- speex.1:${PORTSDIR}/audio/speex \
- fribidi.3:${PORTSDIR}/converters/fribidi \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- freetype.9:${PORTSDIR}/print/freetype2
+PORTNAME= glob2
+PORTVERSION= 0.9.4.4
+PORTREVISION= 6
+CATEGORIES= games
+MASTER_SITES= SAVANNAH/${PORTNAME}/${PORTVERSION:R}/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Globulation 2, free and innovative strategy game
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libspeex.so:${PORTSDIR}/audio/speex \
+ libfribidi.so:${PORTSDIR}/converters/fribidi \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libfreetype.so:${PORTSDIR}/print/freetype2
# Should work with portaudio v19_20071207
# Can be built with portaudio2 but does not run cleanly
-#LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
-
-USE_SDL= image net sdl ttf
-USE_GL= gl
-USE_GMAKE= yes
-USE_SCONS= yes
-#SCONS_ARGS= --portaudio=true
-INSTALLS_ICONS= yes
-SCONS_BUILDENV= ${SCONS_ENV}
-#CFLAGS+= ${PTHREAD_CFLAGS} -I. `pkg-config --cflags portaudio-2.0` -I${LOCALBASE}/include
-CFLAGS+= ${PTHREAD_CFLAGS} -I. -I${LOCALBASE}/include
-#LINKFLAGS= ${PTHREAD_LIBS} `pkg-config --libs portaudio-2.0` -L${LOCALBASE}/lib
-LINKFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-
-LICENSE= GPLv3
-
-NO_STAGE= yes
-post-install:
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+#LIB_DEPENDS+= libportaudio.so:${PORTSDIR}/audio/portaudio2
+
+USES= gmake
+USE_SDL= image net sdl ttf
+USE_GL= gl
+USE_SCONS= yes
+#SCONS_ARGS+= --portaudio=true
+#SCONS_BUILDENV= ${SCONS_ENV}
+SCONS_ARGS= CXXFLAGS+=" -g -pg" INSTALLDIR="${STAGEDIR}${PREFIX}/share"
+CFLAGS+= -Wno-return-type
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 16x16 24x24 32x32 48x48 64x64 128x128
+
+#CFLAGS+= ${PTHREAD_CFLAGS} -I. `pkg-config --cflags portaudio-2.0` -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS} -I. -I${LOCALBASE}/include
+#LINKFLAGS= ${PTHREAD_LIBS} `pkg-config --libs portaudio-2.0` -L${LOCALBASE}/lib
+LINKFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/bin|${STAGEDIR}${PREFIX}/bin|' \
+ ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} -e 's|portaudio.h|portaudio2/portaudio.h|' ${WRKSRC}/src/VoiceRecorder.cpp
+ @${REINPLACE_CMD} -e 's|^Icon.*|Icon=${PORTNAME}|' \
+ ${WRKSRC}/data/${PORTNAME}.desktop
+
+.for s in 16 24 32 48 64 128
+ @cd ${WRKSRC}/data/icons && \
+ ${MV} glob2-icon-${s}x${s}.png ${PORTNAME}_${s}x${s}.png
+.endfor
manual-regression-test:
# Don't enable these tests on pointyhat, they take too long.
@@ -48,4 +64,16 @@ manual-regression-test:
(cd ${WRKSRC}/src && ./glob2 -test-games-nox)
.endif
+post-install:
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${INSTALL_DATA} ${WRKSRC}/data/icons/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/games/glob2/files/patch-SConstruct b/games/glob2/files/patch-SConstruct
index a4c34367362b..4844c9663b40 100644
--- a/games/glob2/files/patch-SConstruct
+++ b/games/glob2/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig 2009-08-30 19:23:30.000000000 +0000
-+++ SConstruct 2013-01-28 16:42:04.024490217 +0000
+--- ./SConstruct.orig 2009-08-30 21:23:30.000000000 +0200
++++ ./SConstruct 2013-10-28 02:21:28.000000000 +0100
@@ -14,6 +14,7 @@
def establish_options(env):
@@ -8,6 +8,21 @@
opts.Add("CXXFLAGS", "Manually add to the CXXFLAGS", "-g")
opts.Add("LINKFLAGS", "Manually add to the LINKFLAGS", "-g")
if isDarwinPlatform:
+@@ -22,10 +23,10 @@
+ opts.Add("INSTALLDIR", "Installation Directory", "/usr/local/share")
+ opts.Add("BINDIR", "Binary Installation Directory", "/usr/local/bin")
+ opts.Add("DATADIR", "Directory where data will be put, set to the same as INSTALLDIR", "/usr/local/share")
+- opts.Add(BoolOption("release", "Build for release", 0))
+- opts.Add(BoolOption("profile", "Build with profiling on", 0))
+- opts.Add(BoolOption("mingw", "Build with mingw enabled if not auto-detected", 0))
+- opts.Add(BoolOption("server", "Build only the YOG server, excluding the game and any GUI/sound components", 0))
++ opts.Add(BoolVariable("release", "Build for release", 0))
++ opts.Add(BoolVariable("profile", "Build with profiling on", 0))
++ opts.Add(BoolVariable("mingw", "Build with mingw enabled if not auto-detected", 0))
++ opts.Add(BoolVariable("server", "Build only the YOG server, excluding the game and any GUI/sound components", 0))
+ opts.Add("font", "Build the game using an alternative font placed in the data/font folder", "sans.ttf")
+ Help(opts.GenerateHelpText(env))
+ opts.Update(env)
@@ -111,14 +112,17 @@
missing.append("zlib")
diff --git a/games/glob2/files/patch-data__SConscript b/games/glob2/files/patch-data__SConscript
new file mode 100644
index 000000000000..3959d9adf2c6
--- /dev/null
+++ b/games/glob2/files/patch-data__SConscript
@@ -0,0 +1,9 @@
+--- ./data/SConscript.orig 2009-06-14 12:11:30.000000000 +0200
++++ ./data/SConscript 2013-10-28 01:26:26.000000000 +0100
+@@ -19,6 +19,5 @@
+ SConscript("fonts/SConscript")
+ SConscript("gfx/SConscript")
+ SConscript("gui/SConscript")
+-SConscript("icons/SConscript")
+ SConscript("zik/SConscript")
+
diff --git a/games/glob2/files/patch-src_VoiceRecorder.cpp b/games/glob2/files/patch-src_VoiceRecorder.cpp
deleted file mode 100644
index 9c49c581ad36..000000000000
--- a/games/glob2/files/patch-src_VoiceRecorder.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/VoiceRecorder.cpp.orig 2009-01-06 17:24:57.000000000 +0100
-+++ ./src/VoiceRecorder.cpp 2009-03-01 18:33:04.000000000 +0100
-@@ -36,7 +36,7 @@
- #define SPEEX_FRAME_SIZE 160
-
- #ifdef HAVE_PORTAUDIO
-- #include "portaudio.h"
-+ #include <portaudio2/portaudio.h>
- #else
- #ifdef WIN32
- // Windows audio input include
diff --git a/games/glob2/files/patch-src_ConfigFiles.h b/games/glob2/files/patch-src__ConfigFiles.h
index 738e1de58fc7..8f1c30ca2069 100644
--- a/games/glob2/files/patch-src_ConfigFiles.h
+++ b/games/glob2/files/patch-src__ConfigFiles.h
@@ -1,5 +1,5 @@
---- src/ConfigFiles.h.orig Sat Sep 9 16:07:13 2006
-+++ src/ConfigFiles.h Sun Apr 8 18:55:00 2007
+--- ./src/ConfigFiles.h.orig 2009-06-14 12:11:34.000000000 +0200
++++ ./src/ConfigFiles.h 2013-10-28 01:26:26.000000000 +0100
@@ -178,7 +178,11 @@
else
{
diff --git a/games/glob2/files/pkg-message.in b/games/glob2/files/pkg-message.in
new file mode 100644
index 000000000000..9bb8211100a3
--- /dev/null
+++ b/games/glob2/files/pkg-message.in
@@ -0,0 +1,18 @@
+===============================================================================
+
+Globulation 2 has been installed.
+
+You can try to launch it typing
+
+ glob2
+
+Anyway, it will not always work, so it is suggested that you type
+
+ glob2 --help
+
+and read about command lines arguments.
+
+Try to use -G option if you have problems with dri and glx (OpenGL),
+or -m if you have problems with sound, or -C to disable custom cursor.
+
+===============================================================================
diff --git a/games/glob2/pkg-message b/games/glob2/pkg-message
deleted file mode 100644
index e443149d28f2..000000000000
--- a/games/glob2/pkg-message
+++ /dev/null
@@ -1,7 +0,0 @@
-Installation successful: now you can try to launch it typing "glob2".
-
-Anyway, it will not always work, so it is suggested that you type
-"glob2 --help" and read about command lines arguments.
-
-Try to use -G option if you have problems with dri and glx (OpenGL),
-or -m if you have problems with sound, or -C to disable custom cursor.
diff --git a/games/glob2/pkg-plist b/games/glob2/pkg-plist
index 754d1af7931e..2b44fdae01c9 100644
--- a/games/glob2/pkg-plist
+++ b/games/glob2/pkg-plist
@@ -1737,23 +1737,13 @@ share/applications/glob2.desktop
%%DATADIR%%/scripts/tutorial_part2.sgsl
%%DATADIR%%/scripts/tutorial_part3.sgsl
%%DATADIR%%/scripts/tutorial_part4.sgsl
-share/icons/hicolor/128x128/apps/glob2-icon-128x128.png
-share/icons/hicolor/16x16/apps/glob2-icon-16x16.png
-share/icons/hicolor/24x24/apps/glob2-icon-24x24.png
-share/icons/hicolor/32x32/apps/glob2-icon-32x32.png
-share/icons/hicolor/48x48/apps/glob2-icon-48x48.png
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
+share/icons/hicolor/128x128/apps/glob2.png
+share/icons/hicolor/16x16/apps/glob2.png
+share/icons/hicolor/24x24/apps/glob2.png
+share/icons/hicolor/32x32/apps/glob2.png
+share/icons/hicolor/48x48/apps/glob2.png
+share/icons/hicolor/64x64/apps/glob2.png
+share/pixmaps/glob2.png
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%/data/zik