aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2020-09-18 04:50:56 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2020-09-18 04:50:56 +0000
commit8d29214ebea5ae31ba7920939e11b77373ee414b (patch)
treed7c8e1a8da253e5f5f53f1d1abad745051d259b0
parent889d5f43d92e01e78a05d8f042818d5c653c5868 (diff)
downloadports-8d29214ebea5ae31ba7920939e11b77373ee414b.tar.gz
ports-8d29214ebea5ae31ba7920939e11b77373ee414b.zip
MFH: r541372 r543678 r543682 r545547 r545560 r547570 r548046 r548047 r548707 r548802
www/node: Update 14.4.0 -> 14.5.0 https://nodejs.org/en/blog/release/v14.5.0/ Refresh patches with `make makepatch`, and adapt them to the changes from upstream due to the V8 upgrade. Sponsored by: Miles AS www/node10: Update 10.21.0 -> 10.22.0 https://nodejs.org/en/blog/release/v10.22.0/ Sponsored by: Miles AS www/node: Update 14.6.0 -> 14.6.0_1 Bump PORTREVISION after updating the minimum version requirements for libuv, libnghttp2, and libcares. The previous change for www/node erroneously mentioned the most recent www/node10 update. The correct changelog should have read: www/node: Update 14.5.0 -> 14.6.0 https://nodejs.org/en/blog/release/v14.6.0/ Sponsored by: Miles AS www/node: Update 14.6.0_1 -> 14.7.0 https://nodejs.org/en/blog/release/v14.7.0/ Sponsored by: Miles AS www/node: Update 14.7.0 -> 14.8.0 https://nodejs.org/en/blog/release/v14.8.0/ Sponsored by: Miles AS www/node: Update 14.8.0 -> 14.9.0 https://nodejs.org/en/blog/release/v14.9.0/ Sponsored by: Miles AS www/node: Update 14.9.0 -> 14.10.0 https://nodejs.org/en/blog/release/v14.10.0/ While here, refresh patches with `make makepatch`. Sponsored by: Miles AS www/node: add dependency on archivers/brotli ... instead of building the version bundled with Node.js. Bump PORTREVISION due to the new dependency. Sponsored by: Miles AS www/node: Update 14.10.0_1 -> 14.10.1 https://nodejs.org/en/blog/release/v14.10.1/ Sponsored by: Miles AS www/node: Update 14.10.1 -> 14.11.0 https://nodejs.org/en/blog/release/v14.11.0/ This is a security release. See https://nodejs.org/en/blog/vulnerability/september-2020-security-releases/ Security: 4ca5894c-f7f1-11ea-8ff8-0022489ad614 Sponsored by: Miles AS Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=548876
-rw-r--r--www/node/Makefile15
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi4
-rw-r--r--www/node/files/patch-deps_openssl_openssl__no__asm.gypi4
-rw-r--r--www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc6
-rw-r--r--www/node/files/patch-deps_v8_src_codegen_ppc_constants-ppc.h18
-rw-r--r--www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc4
-rw-r--r--www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc7
-rw-r--r--www/node/files/patch-deps_v8_src_libsampler_sampler.cc4
-rw-r--r--www/node/pkg-plist40
10 files changed, 76 insertions, 32 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 7e484f32b6cc..e1fac4e95172 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 14.4.0
+PORTVERSION= 14.11.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -38,7 +38,7 @@ BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl --openssl-use-def-ca-store
BUNDLED_SSL_RUN_DEPENDS_OFF= ca_root_nss>=0:security/ca_root_nss
NLS_CONFIGURE_ON= --with-intl=system-icu
-NLS_BUILD_DEPENDS= icu>=66.1:devel/icu
+NLS_BUILD_DEPENDS= icu>=67.1:devel/icu
NLS_LIB_DEPENDS= libicui18n.so:devel/icu
DTRACE_CONFIGURE_ON= --with-dtrace
@@ -52,6 +52,7 @@ CONFLICTS_INSTALL= node[68]-[0-9]* node10-[0-9]* node12-[0-9]*
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
+ --shared-brotli \
--shared-cares \
--shared-libuv \
--shared-nghttp2 \
@@ -68,11 +69,13 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
CXX.host=${CXX} CXXFLAGS.host="${CXXFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
-BUILD_DEPENDS+= c-ares>=1.15.0:dns/c-ares\
- libuv>=1.37.0:devel/libuv \
- libnghttp2>=1.40.0:www/libnghttp2 \
+BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
+ c-ares>=1.16.0:dns/c-ares \
+ libuv>=1.39.0:devel/libuv \
+ libnghttp2>=1.41.0:www/libnghttp2 \
objdump:devel/binutils
-LIB_DEPENDS+= libcares.so:dns/c-ares\
+LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
+ libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2
diff --git a/www/node/distinfo b/www/node/distinfo
index cf3dbf5b1d6e..ebca4dadd27f 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1591883644
-SHA256 (node-v14.4.0.tar.gz) = 5769ce6cf619e3f38dab9d64eab204722665b8b0f5bd2568ac171e2edc6db7f7
-SIZE (node-v14.4.0.tar.gz) = 61658009
+TIMESTAMP = 1600242162
+SHA256 (node-v14.11.0.tar.gz) = c07669ddbd708d0dfc4ccb63a7ced7ad1fd7d1b59ced50cf05f22f0b96e45463
+SIZE (node-v14.11.0.tar.gz) = 63018833
diff --git a/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi b/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
index 05e4929605d2..8966d6b4ba0d 100644
--- a/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
+++ b/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
@@ -1,4 +1,4 @@
---- deps/openssl/openssl-cl_no_asm.gypi.orig 2019-08-06 20:46:23 UTC
+--- deps/openssl/openssl-cl_no_asm.gypi.orig 2020-09-08 12:17:10 UTC
+++ deps/openssl/openssl-cl_no_asm.gypi
@@ -1,4 +1,5 @@
{
@@ -6,7 +6,7 @@
'conditions': [
['target_arch=="ppc" and OS=="aix"', {
'includes': ['config/archs/aix-gcc/no-asm/openssl-cl.gypi'],
-@@ -45,7 +46,7 @@
+@@ -47,7 +48,7 @@
'includes': ['config/archs/linux64-mips64/no-asm/openssl-cl.gypi'],
}, {
# Other architectures don't use assembly
diff --git a/www/node/files/patch-deps_openssl_openssl__no__asm.gypi b/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
index ec3448f01954..1fef0c4ca71f 100644
--- a/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
+++ b/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
@@ -1,6 +1,6 @@
---- deps/openssl/openssl_no_asm.gypi.orig 2019-08-06 20:46:23 UTC
+--- deps/openssl/openssl_no_asm.gypi.orig 2020-09-08 12:17:11 UTC
+++ deps/openssl/openssl_no_asm.gypi
-@@ -46,7 +46,7 @@
+@@ -48,7 +48,7 @@
'includes': ['config/archs/linux64-mips64/no-asm/openssl.gypi'],
}, {
# Other architectures don't use assembly
diff --git a/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc b/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
index d1f61a84b37b..c504d7134dd4 100644
--- a/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
+++ b/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/base/platform/platform-freebsd.cc.orig 2020-01-07 22:07:49 UTC
+--- deps/v8/src/base/platform/platform-freebsd.cc.orig 2020-06-30 17:49:16 UTC
+++ deps/v8/src/base/platform/platform-freebsd.cc
-@@ -81,8 +81,8 @@ std::vector<OS::SharedLibraryAddress> OS::GetSharedLib
+@@ -82,8 +82,8 @@ std::vector<OS::SharedLibraryAddress> OS::GetSharedLib
lib_name = std::string(path);
}
result.push_back(SharedLibraryAddress(
@@ -11,7 +11,7 @@
}
start += ssize;
-@@ -93,6 +93,48 @@ std::vector<OS::SharedLibraryAddress> OS::GetSharedLib
+@@ -94,6 +94,48 @@ std::vector<OS::SharedLibraryAddress> OS::GetSharedLib
}
void OS::SignalCodeMovingGC() {}
diff --git a/www/node/files/patch-deps_v8_src_codegen_ppc_constants-ppc.h b/www/node/files/patch-deps_v8_src_codegen_ppc_constants-ppc.h
index 044fd3a292f3..449278ef9271 100644
--- a/www/node/files/patch-deps_v8_src_codegen_ppc_constants-ppc.h
+++ b/www/node/files/patch-deps_v8_src_codegen_ppc_constants-ppc.h
@@ -1,18 +1,18 @@
---- deps/v8/src/codegen/ppc/constants-ppc.h.orig 2019-09-09 16:27:17 UTC
+--- deps/v8/src/codegen/ppc/constants-ppc.h.orig 2020-06-30 17:49:17 UTC
+++ deps/v8/src/codegen/ppc/constants-ppc.h
-@@ -34,7 +34,7 @@
- #define ABI_PASSES_HANDLES_IN_REGS 0
+@@ -36,7 +36,7 @@
#endif
--#if !V8_HOST_ARCH_PPC || !V8_TARGET_ARCH_PPC64 || V8_TARGET_LITTLE_ENDIAN || \
-+#if !V8_HOST_ARCH_PPC || !V8_TARGET_ARCH_PPC64 || \
- (defined(_CALL_ELF) && _CALL_ELF == 2)
+ #if !(V8_HOST_ARCH_PPC || V8_HOST_ARCH_PPC64) || !V8_TARGET_ARCH_PPC64 || \
+- V8_TARGET_LITTLE_ENDIAN || (defined(_CALL_ELF) && _CALL_ELF == 2)
++ (defined(_CALL_ELF) && _CALL_ELF == 2)
#define ABI_RETURNS_OBJECT_PAIRS_IN_REGS 1
#else
-@@ -43,7 +43,7 @@
+ #define ABI_RETURNS_OBJECT_PAIRS_IN_REGS 0
+@@ -44,7 +44,7 @@
- #if !V8_HOST_ARCH_PPC || \
- (V8_TARGET_ARCH_PPC64 && \
+ #if !(V8_HOST_ARCH_PPC || V8_HOST_ARCH_PPC64) || \
+ (V8_TARGET_ARCH_PPC64 && \
- (V8_TARGET_LITTLE_ENDIAN || (defined(_CALL_ELF) && _CALL_ELF == 2)))
+ (defined(_CALL_ELF) && _CALL_ELF == 2))
#define ABI_CALL_VIA_IP 1
diff --git a/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc b/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
index dddaebe14ea2..b8985dcef76d 100644
--- a/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
+++ b/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/compiler/backend/instruction-selector.cc.orig 2020-04-21 11:38:50 UTC
+--- deps/v8/src/compiler/backend/instruction-selector.cc.orig 2020-07-20 22:18:45 UTC
+++ deps/v8/src/compiler/backend/instruction-selector.cc
-@@ -2783,7 +2783,7 @@ void InstructionSelector::VisitCall(Node* node, BasicB
+@@ -2808,7 +2808,7 @@ void InstructionSelector::VisitCall(Node* node, BasicB
switch (call_descriptor->kind()) {
case CallDescriptor::kCallAddress: {
int misc_field = static_cast<int>(call_descriptor->ParameterCount());
diff --git a/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc b/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc
index f7bbf62593f7..a69dfeecd00f 100644
--- a/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc
+++ b/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc
@@ -1,9 +1,10 @@
---- deps/v8/src/compiler/backend/ppc/code-generator-ppc.cc.orig 2020-04-21 11:38:50 UTC
+--- deps/v8/src/compiler/backend/ppc/code-generator-ppc.cc.orig 2020-07-20 22:18:45 UTC
+++ deps/v8/src/compiler/backend/ppc/code-generator-ppc.cc
-@@ -1032,7 +1032,7 @@ CodeGenerator::CodeGenResult CodeGenerator::AssembleAr
+@@ -1038,8 +1038,7 @@ CodeGenerator::CodeGenResult CodeGenerator::AssembleAr
bool isWasmCapiFunction =
linkage()->GetIncomingDescriptor()->IsWasmCapiFunction();
- int offset = 9 * kInstrSize;
+ int offset = (FLAG_enable_embedded_constant_pool ? 20 : 23) * kInstrSize;
+-
-#if defined(_AIX)
+#if defined(_AIX) || (V8_TARGET_ARCH_PPC_BE && (!defined(_CALL_ELF) || _CALL_ELF == 1))
// AIX/PPC64BE Linux uses a function descriptor
diff --git a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
index c9ffd9c7cb17..74fce64be593 100644
--- a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
+++ b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/libsampler/sampler.cc.orig 2020-04-21 11:38:50 UTC
+--- deps/v8/src/libsampler/sampler.cc.orig 2020-06-30 17:49:17 UTC
+++ deps/v8/src/libsampler/sampler.cc
-@@ -480,6 +480,10 @@ void SignalHandler::FillRegisterState(void* context, R
+@@ -482,6 +482,10 @@ void SignalHandler::FillRegisterState(void* context, R
state->pc = reinterpret_cast<void*>(mcontext.__gregs[_REG_PC]);
state->sp = reinterpret_cast<void*>(mcontext.__gregs[_REG_SP]);
state->fp = reinterpret_cast<void*>(mcontext.__gregs[_REG_FP]);
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index f120f7ab0081..99dd57c03721 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -1,6 +1,30 @@
bin/node
include/node/common.gypi
include/node/config.gypi
+include/node/cppgc/allocation.h
+include/node/cppgc/common.h
+include/node/cppgc/custom-space.h
+include/node/cppgc/garbage-collected.h
+include/node/cppgc/heap.h
+include/node/cppgc/internal/accessors.h
+include/node/cppgc/internal/api-constants.h
+include/node/cppgc/internal/compiler-specific.h
+include/node/cppgc/internal/finalizer-trait.h
+include/node/cppgc/internal/gc-info.h
+include/node/cppgc/internal/logging.h
+include/node/cppgc/internal/persistent-node.h
+include/node/cppgc/internal/pointer-policies.h
+include/node/cppgc/internal/prefinalizer-handler.h
+include/node/cppgc/liveness-broker.h
+include/node/cppgc/macros.h
+include/node/cppgc/member.h
+include/node/cppgc/persistent.h
+include/node/cppgc/platform.h
+include/node/cppgc/prefinalizer.h
+include/node/cppgc/source-location.h
+include/node/cppgc/trace-trait.h
+include/node/cppgc/type-traits.h
+include/node/cppgc/visitor.h
include/node/js_native_api.h
include/node/js_native_api_types.h
include/node/libplatform/libplatform.h
@@ -122,6 +146,21 @@ include/node/node_version.h
%%BUNDLED_SSL%%include/node/openssl/archs/darwin-i386-cc/no-asm/crypto/include/internal/dso_conf.h
%%BUNDLED_SSL%%include/node/openssl/archs/darwin-i386-cc/no-asm/include/openssl/opensslconf.h
%%BUNDLED_SSL%%include/node/openssl/archs/darwin-i386-cc/no-asm/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm_avx2/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm_avx2/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm_avx2/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm_avx2/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/asm_avx2/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/no-asm/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/no-asm/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/no-asm/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/no-asm/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-arm64-cc/no-asm/include/progs.h
%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-x86_64-cc/asm/crypto/buildinf.h
%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-x86_64-cc/asm/crypto/include/internal/bn_conf.h
%%BUNDLED_SSL%%include/node/openssl/archs/darwin64-x86_64-cc/asm/crypto/include/internal/dso_conf.h
@@ -444,6 +483,7 @@ include/node/node_version.h
%%BUNDLED_SSL%%include/node/openssl/x509err.h
%%BUNDLED_SSL%%include/node/openssl/x509v3.h
%%BUNDLED_SSL%%include/node/openssl/x509v3err.h
+include/node/v8-fast-api-calls.h
include/node/v8-internal.h
include/node/v8-platform.h
include/node/v8-profiler.h