aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-10-04 21:29:10 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-10-04 21:29:10 +0000
commit91874587dc05432dca799ec25981432a15bb8c7e (patch)
tree58c8679b69c45ea5685264829a2cfaacbf28a757
parentcfc2ff29ce01d9eebd6cc641abd5385957e308a3 (diff)
downloadports-91874587dc05432dca799ec25981432a15bb8c7e.tar.gz
ports-91874587dc05432dca799ec25981432a15bb8c7e.zip
Notes
-rw-r--r--games/gnomesudoku/Makefile9
-rw-r--r--games/gnomesudoku/files/patch-setup.py11
-rw-r--r--games/gnomesudoku/files/patch-src__lib__gtk_goodies__image_extras.py8
3 files changed, 23 insertions, 5 deletions
diff --git a/games/gnomesudoku/Makefile b/games/gnomesudoku/Makefile
index f2c5b84eff1a..57184b9629f4 100644
--- a/games/gnomesudoku/Makefile
+++ b/games/gnomesudoku/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnomesudoku
PORTVERSION= 0.6.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games gnome
MASTER_SITES= SF/gnome-sudoku/gnome-sudoku/${PORTVERSION}
DISTNAME= gnome-sudoku-${PORTVERSION}
@@ -12,12 +12,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME Sudoku game
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric/Numeric.py:${PORTSDIR}/math/py-numeric \
- ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-USES= pathfix display
+USES= display pathfix python
USE_GNOME= gnomeprefix pygnome2 pygnomedesktop
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= gnome-sudoku
post-patch:
diff --git a/games/gnomesudoku/files/patch-setup.py b/games/gnomesudoku/files/patch-setup.py
new file mode 100644
index 000000000000..16e918486268
--- /dev/null
+++ b/games/gnomesudoku/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2014-10-04 20:26:24 UTC
++++ setup.py
+@@ -43,7 +43,7 @@
+ except ImportError:
+ sys.exit('Error: PyGTK-2.6 or newer is required.')
+ raise
+- mod_list = ['Image','gnomeprint','Numeric']
++ mod_list = ['PIL','gnomeprint','Numeric']
+ ok = 1
+ for m in mod_list:
+ try:
diff --git a/games/gnomesudoku/files/patch-src__lib__gtk_goodies__image_extras.py b/games/gnomesudoku/files/patch-src__lib__gtk_goodies__image_extras.py
new file mode 100644
index 000000000000..8f7a5105aaa5
--- /dev/null
+++ b/games/gnomesudoku/files/patch-src__lib__gtk_goodies__image_extras.py
@@ -0,0 +1,8 @@
+--- src/lib/gtk_goodies/image_extras.py.orig 2014-10-04 19:22:19 UTC
++++ src/lib/gtk_goodies/image_extras.py
+@@ -1,4 +1,4 @@
+-import Image,ImageOps
++from PIL import Image,ImageOps
+ import gtk
+ import string
+ import StringIO