aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-01-10 21:02:40 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-01-10 21:02:40 +0000
commit93ac30ca4a7e06c8fb9059468d0b5786000859ca (patch)
tree62662061880b8a5d6f1df25a915158f57bcaeebb
parent09a7d5e804df9b7d38fed323d0e2ffec9c9206f4 (diff)
downloadports-93ac30ca4a7e06c8fb9059468d0b5786000859ca.tar.gz
ports-93ac30ca4a7e06c8fb9059468d0b5786000859ca.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/reflex/Makefile35
-rw-r--r--textproc/reflex/distinfo2
-rw-r--r--textproc/reflex/pkg-descr7
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 145d6d99fdc3..a8598b0a8f72 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1171,6 +1171,7 @@
SUBDIR += redland-bindings-python
SUBDIR += refdb
SUBDIR += referrercop
+ SUBDIR += reflex
SUBDIR += replaceit
SUBDIR += resume
SUBDIR += resume-extensions
diff --git a/textproc/reflex/Makefile b/textproc/reflex/Makefile
new file mode 100644
index 000000000000..9f2205100e4f
--- /dev/null
+++ b/textproc/reflex/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: reflex
+# Date created: 10 January 2012
+# Whom: bf@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= reflex
+PORTVERSION= 20100906
+CATEGORIES= textproc
+MASTER_SITES= http://invisible-island.net/datafiles/release/ LOCAL/bf
+DISTNAME= reflex
+
+MAINTAINER= bf@FreeBSD.org
+COMMENT= Relocalizable fast lexical scanner
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= YACC="${YACC}"
+MAN1= reflex.1
+PLIST_FILES= bin/reflex bin/reflex++ include/reFlexLexer.h lib/librefl.a
+WRKSRC = ${WRKDIR}/reflex-${PORTVERSION}
+
+regression-test test: check
+
+.for t in check bigcheck
+${t}: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} ${t};
+
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/reflex/distinfo b/textproc/reflex/distinfo
new file mode 100644
index 000000000000..14c55262d8bb
--- /dev/null
+++ b/textproc/reflex/distinfo
@@ -0,0 +1,2 @@
+SHA256 (reflex.tar.gz) = 111daaf27268943b37ffe5fd4197c918d0f7854e4506957672a8da1f70360459
+SIZE (reflex.tar.gz) = 447507
diff --git a/textproc/reflex/pkg-descr b/textproc/reflex/pkg-descr
new file mode 100644
index 000000000000..235b1b6c0da2
--- /dev/null
+++ b/textproc/reflex/pkg-descr
@@ -0,0 +1,7 @@
+This is a variant of the Flex fast lexical scanner. Flex was written
+in the early 1990s by Verne Paxson. This version has been modified
+by Thomas Dickey, so that it conforms to ANSI C. It includes other
+improvements, but remains compatible with Paxson's 2.5.4 release
+(as well as POSIX lex). See the NEWS file for details.
+
+WWW: http://invisible-island.net/reflex/reflex.html