aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-21 22:21:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-21 22:21:21 +0000
commit964bc1beaa10b63aa8f288bf3c2e9a944a1585a5 (patch)
treea998d9c3718ce4b01c979925a09a423a84a6f701
parent280dc881fa9f737b73be791c2f6d949d9e97c149 (diff)
downloadports-964bc1beaa10b63aa8f288bf3c2e9a944a1585a5.tar.gz
ports-964bc1beaa10b63aa8f288bf3c2e9a944a1585a5.zip
MFH: r549527
audio/csound: Broken on 11 i386 Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549533
-rw-r--r--audio/csound/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 6ff17132b1d2..74f2bdb0ed9d 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -156,6 +156,12 @@ WIIMOTE_DESC= Build the Wiimote opcodes
WIIMOTE_CMAKE_BOOL= BUILD_WIIMOTE_OPCODES
WIIMOTE_BROKEN= Need to port wiiuse: https://github.com/rpavlik/wiiuse
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BROKEN_FreeBSD_11= libcsound64.so.6.0: undefined reference to `__atomic_store_8' / undefined reference to `__atomic_load_8'
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/local|${LOCALBASE}|' \
@@ -185,4 +191,4 @@ post-install:
post-install-FLTK-on:
@${LN} -sf libCsoundAC.so.6.0 ${STAGEDIR}${PREFIX}/lib/libCsoundAC.so.6
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>