aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-06-02 13:42:09 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-06-02 13:42:09 +0000
commit9af76baced11e222a9ebffd9fcf8f1463fcd4b4d (patch)
tree35288173f46286c36e212ea9d1c619948d0d3153
parent551a15f1e3fe2491d5c5f2c4e8541066592b0e10 (diff)
downloadports-9af76baced11e222a9ebffd9fcf8f1463fcd4b4d.tar.gz
ports-9af76baced11e222a9ebffd9fcf8f1463fcd4b4d.zip
Notes
-rw-r--r--www/mod_dtcl/Makefile3
-rw-r--r--www/mod_dtcl/distinfo2
-rw-r--r--www/mod_dtcl/files/Makefile.bsd7
-rw-r--r--www/mod_dtcl/files/patch-cast10
-rw-r--r--www/mod_dtcl/files/patch-tmp50
-rw-r--r--www/mod_dtcl/pkg-plist1
6 files changed, 66 insertions, 7 deletions
diff --git a/www/mod_dtcl/Makefile b/www/mod_dtcl/Makefile
index e191738568c5..5f0c770ada28 100644
--- a/www/mod_dtcl/Makefile
+++ b/www/mod_dtcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_dtcl
-PORTVERSION= 0.8.12
+PORTVERSION= 0.10.1
CATEGORIES= www tcl83
MASTER_SITES= http://tcl.apache.org/mod_dtcl/download/
@@ -23,7 +23,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/libmod_dtcl.so.1* \
${PREFIX}/libexec/apache/mod_dtcl.so
${PREFIX}/sbin/apxs -e -A -n dtcl ${PREFIX}/libexec/apache/mod_dtcl.so
- ${MKDIR} ${PREFIX}/share/mod_dtcl
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/mod_dtcl
${INSTALL_DATA} ${WRKSRC}/docs/*.?tml ${WRKSRC}/docs/*.gif \
diff --git a/www/mod_dtcl/distinfo b/www/mod_dtcl/distinfo
index 8abe9c8e3ca3..e333565398ac 100644
--- a/www/mod_dtcl/distinfo
+++ b/www/mod_dtcl/distinfo
@@ -1 +1 @@
-MD5 (mod_dtcl-0.8.12.tar.gz) = ee71c3a6e2b60554fb22b988ab2a5cc1
+MD5 (mod_dtcl-0.10.1.tar.gz) = 3e9575f3044e43158ed9c7e71dc240fb
diff --git a/www/mod_dtcl/files/Makefile.bsd b/www/mod_dtcl/files/Makefile.bsd
index eec33906d5a3..7017ba283ab9 100644
--- a/www/mod_dtcl/files/Makefile.bsd
+++ b/www/mod_dtcl/files/Makefile.bsd
@@ -9,9 +9,7 @@ DTCL_VERSION!= cat ${.CURDIR}/VERSION
CC!= ${PREFIX}/sbin/apxs -q CC
CFLAGS!= ${PREFIX}/sbin/apxs -q CFLAGS CFLAGS_SHLIB
-CFLAGS+= -Wall -DSTATUS -DNO_DBM_REWRITEMAP ${INCLUDES}
-CFLAGS+= -DDEBUG_SCRIPT_DIR="\"${PREFIX}/share/mod_dtcl/\""
-CFLAGS+= -DDTCL_VERSION="\"${DTCL_VERSION}\""
+CFLAGS+= ${INCLUDES} -DDTCL_VERSION="\"${DTCL_VERSION}\""
LIB= mod_dtcl
SHLIB_MAJOR=1
@@ -24,6 +22,9 @@ NOPROFILE= True # to avoid building profiled library
INTERNALLIB= True # to avoid building a static version
SRCS= mod_dtcl.c
+SRCS+= apache_cookie.c apache_multipart_buffer.c apache_request.c \
+ tcl_commands.c
+
NOMAN= True # don't bother with the man-page here, let the port handle it
all: ${SHLIB_NAME}
diff --git a/www/mod_dtcl/files/patch-cast b/www/mod_dtcl/files/patch-cast
new file mode 100644
index 000000000000..e00056db617d
--- /dev/null
+++ b/www/mod_dtcl/files/patch-cast
@@ -0,0 +1,10 @@
+--- mod_dtcl.c Tue May 1 11:56:01 2001
++++ mod_dtcl.c Fri Jun 1 20:29:10 2001
+@@ -792 +792,6 @@
+- chan = Tcl_MakeFileChannel((ClientData *)fileno(upload->fp), TCL_READABLE);
++ union {
++ ClientData handle;
++ int fd;
++ } handle;
++ handle.fd = fileno(upload->fp);
++ chan = Tcl_MakeFileChannel(handle.handle, TCL_READABLE);
diff --git a/www/mod_dtcl/files/patch-tmp b/www/mod_dtcl/files/patch-tmp
new file mode 100644
index 000000000000..f78b92eb2645
--- /dev/null
+++ b/www/mod_dtcl/files/patch-tmp
@@ -0,0 +1,50 @@
+--- apache_request.c Mon Mar 19 12:36:42 2001
++++ apache_request.c Fri Jun 1 20:36:57 2001
+@@ -328,20 +328,34 @@
+ request_rec *r = req->r;
+ FILE *fp;
+- char prefix[] = "apreq";
+- char *name;
+- int fd, tries = 100;
+-
+- while (--tries > 0) {
+- if ( (name = tempnam(req->temp_dir, prefix)) == NULL ) continue;
+- fd = ap_popenf(r->pool, name, O_CREAT|O_EXCL|O_RDWR, 0600);
+- if ( fd >= 0 )
+- break; /* success */
+- else
++#define PREFIX "apreq"
++ char *name = NULL;
++ int fd = -1;
++ char *dirs[5], **dir;
++
++ dirs[0] = getenv("TMPDIR"); dirs[1] = req->temp_dir;
++ dirs[2] = P_tmpdir; dirs[3] = "/tmp"; dirs[4] = NULL;
++
++ /*
++ * Look for the non-NULL directory. The order
++ * above is dictated by the tempnam(3) spec
++ */
++ for (dir = dirs; *dir == NULL; dir++) /* Nothing */;
++
++ /* Now, try to create the temporary file in on of the directories: */
++ for (fd = -1; fd == -1 && *dir; dir++) {
++ name = malloc(strlen(*dir) + sizeof PREFIX + 8);
++ if (!name) {
++ ap_log_rerror(REQ_ERROR, "[libapreq] could not allocate memory");
++ return(NULL);
++ }
++ sprintf(name, "%s/%s.XXXXXX", *dir, PREFIX);
++ fd = mkstemp(name);
++ if (fd == -1)
+ free(name);
+ }
+-
+- if ( tries == 0 || (fp = ap_pfdopen(r->pool, fd, "w+") ) == NULL ) {
++
++ if ( fd == -1 || (fp = ap_pfdopen(r->pool, fd, "w+") ) == NULL ) {
+ ap_log_rerror(REQ_ERROR,
+- "[libapreq] could not open temp file '%s'", name);
++ "[libapreq] could not open temp file '%s'", name);
+ if ( fd >= 0 ) { remove(name); free(name); }
+ return NULL;
diff --git a/www/mod_dtcl/pkg-plist b/www/mod_dtcl/pkg-plist
index 079b7a2cfeed..3d126647842f 100644
--- a/www/mod_dtcl/pkg-plist
+++ b/www/mod_dtcl/pkg-plist
@@ -1,7 +1,6 @@
libexec/apache/mod_dtcl.so
@exec %D/sbin/apxs -e -A -n dtcl %D/%F
@unexec %D/sbin/apxs -e -A -n dtcl %D/%F
-@dirrm share/mod_dtcl
%%PORTDOCS%%share/doc/mod_dtcl/asf_logo.gif
%%PORTDOCS%%share/doc/mod_dtcl/documentation.html
%%PORTDOCS%%share/doc/mod_dtcl/dtcl.gif