aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2009-01-08 17:36:31 +0000
committerErwin Lansing <erwin@FreeBSD.org>2009-01-08 17:36:31 +0000
commit9aff21ffbd0e1d31f0583f5dfbab9e300cfc2a19 (patch)
treef4a00ae24154a2625a53571f1e40f3297026e9c5
parent79e5899e87a5aef1cbdbec089b103b99a164ed1a (diff)
Mark BROKEN on HEAD after the import of strndup(3).
As OSVERSION was not bumped at the time, approximate with 800058. Submitted by: pointyhat
Notes
Notes: svn path=/head/; revision=225506
-rw-r--r--graphics/ophoto/Makefile8
-rw-r--r--lang/eperl/Makefile4
-rw-r--r--lang/p5-ePerl/Makefile8
-rw-r--r--mail/smfsav/Makefile8
-rw-r--r--net/httping/Makefile8
5 files changed, 32 insertions, 4 deletions
diff --git a/graphics/ophoto/Makefile b/graphics/ophoto/Makefile
index e88c30f149e8..2b6bc0e615e2 100644
--- a/graphics/ophoto/Makefile
+++ b/graphics/ophoto/Makefile
@@ -20,4 +20,10 @@ PLIST_FILES= bin/ophoto
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ophoto ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 2c2c97794ea2..77cf413847d5 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -36,6 +36,10 @@ MAN1= eperl.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
test:
@(cd ${WRKSRC}; ${MAKE} test)
diff --git a/lang/p5-ePerl/Makefile b/lang/p5-ePerl/Makefile
index 7074b139eb87..a2a121e35bd1 100644
--- a/lang/p5-ePerl/Makefile
+++ b/lang/p5-ePerl/Makefile
@@ -19,4 +19,10 @@ PERL_CONFIGURE= yes
MAN3= Parse::ePerl.3 Apache::ePerl.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/smfsav/Makefile b/mail/smfsav/Makefile
index 2104dc4bb085..bbfe0b1d53f8 100644
--- a/mail/smfsav/Makefile
+++ b/mail/smfsav/Makefile
@@ -56,4 +56,10 @@ post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 5f26b33c8827..7f5a1fc7edbf 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -22,4 +22,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800058
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>