aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-12-15 19:58:16 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-12-15 19:58:16 +0000
commit9cba5dcef6cd6ebe97e34ddb23ef27c4bf1fd2f4 (patch)
tree8c58f36d61f150baf873f5f88e7e9ac559ba5e89
parent3184bed09724fd91ec00ecb6d0244bbe4b9624d1 (diff)
downloadports-9cba5dcef6cd6ebe97e34ddb23ef27c4bf1fd2f4.tar.gz
ports-9cba5dcef6cd6ebe97e34ddb23ef27c4bf1fd2f4.zip
Notes
-rw-r--r--comms/fldigi/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index eec5584040a2..991b547c8787 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -11,18 +11,16 @@ COMMENT= Digital decoder for psk, cw, psk31, olivia
LICENSE= GPLv3
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconf \
- asciidoc:${PORTSDIR}/textproc/asciidoc\
+BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc\
docbook-xsl>=1.0:${PORTSDIR}/textproc/docbook-xsl\
xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libsamplerate.so:${PORTSDIR}/audio/libsamplerate\
+LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate\
libboost_system.so:${PORTSDIR}/devel/boost-libs\
libfltk.so:${PORTSDIR}/x11-toolkits/fltk
USE_CXXSTD= gnu++0x
GNU_CONFIGURE= yes
-USES= compiler:c++11-lib gmake perl5 pkgconfig shebangfix
+USES= compiler:c++11-lib execinfo gmake perl5 pkgconfig shebangfix
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
@@ -54,15 +52,7 @@ HAMLIB_LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Fails to install
-.endif
-.if ${PORT_OPTIONS:MFLARQ}
-MAN1+= flarq.1
-.endif
-PLIST_SUB+= XMLRPC=""
+BROKEN_sparc64= Fails to install
# Always need asciidoc for man pages
CONFIGURE_ARGS+=--with-asciidoc
@@ -76,11 +66,9 @@ post-configure:
# force rebuild of man pages
${RM} ${WRKSRC}/doc/*.1
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/guide.html ${STAGEDIR}${DOCSDIR}
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>