aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2007-12-11 21:35:31 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2007-12-11 21:35:31 +0000
commit9e4c36487fb368cfb5de260a7bdae098a5981225 (patch)
treebb481944075526d66bc38da61ef1f23b59cf8443
parentca111cc5bef80c56766cf6b0191f8efec999e052 (diff)
downloadports-9e4c36487fb368cfb5de260a7bdae098a5981225.tar.gz
ports-9e4c36487fb368cfb5de260a7bdae098a5981225.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/liba52-devel/Makefile99
-rw-r--r--audio/liba52-devel/distinfo3
-rw-r--r--audio/liba52-devel/files/Makefile23
-rw-r--r--audio/liba52-devel/files/liba52-devel.la28
-rw-r--r--audio/liba52-devel/files/patch-a52.h24
-rw-r--r--audio/liba52-devel/files/patch-a52_internal.h33
-rw-r--r--audio/liba52-devel/files/patch-imdct.c15
-rw-r--r--audio/liba52-devel/files/patch-resample.c38
-rw-r--r--audio/liba52-devel/pkg-descr24
-rw-r--r--audio/liba52-devel/pkg-plist9
12 files changed, 1 insertions, 297 deletions
diff --git a/MOVED b/MOVED
index 27452fd98ce2..20b30efb259a 100644
--- a/MOVED
+++ b/MOVED
@@ -3330,3 +3330,4 @@ dns/bind8||2007-12-03|EOL: Use dns/bind94 instead
dns/bind84||2007-12-03|EOL: Use dns/bind94 instead
mail/smc-milter||2007-12-03|Relies on BIND 8, which is EOL
net-p2p/xmule||2007-12-11|It is no longer developed
+audio/liba52-devel||2007-12-11|Does not work
diff --git a/audio/Makefile b/audio/Makefile
index d603f1dcb2b9..8ed3875a75c3 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -307,7 +307,6 @@
SUBDIR += last.fm
SUBDIR += laudio
SUBDIR += liba52
- SUBDIR += liba52-devel
SUBDIR += libadplug
SUBDIR += libaiff
SUBDIR += libamrnb
diff --git a/audio/liba52-devel/Makefile b/audio/liba52-devel/Makefile
deleted file mode 100644
index 1859bd05cb3f..000000000000
--- a/audio/liba52-devel/Makefile
+++ /dev/null
@@ -1,99 +0,0 @@
-# New ports collection makefile for: liba52-devel
-# Date created: Mon Oct 17 02:22:44 UTC 2005
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= liba52
-PORTVERSION= 0.7.4.${DISTFILE_DATE}
-PORTREVISION= 1
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= lioux
-PKGNAMESUFFIX= -devel
-DISTNAME= FFMpeg-${DISTFILE_DATE}
-
-MAINTAINER= multimedia@FreeBSD.org
-COMMENT= A free library for decoding ATSC A/52 streams, aka AC-3
-
-OPTIONS= DJBFFT "Adds support for fast djbfft fft library" ON \
- OPTIMIZED_CFLAGS "Enable extra performance optimizations" OFF
-
-USE_BZIP2= yes
-MAKE_ARGS= LIB_VERSION="${LIB_VERSION}" PREFIX="${PREFIX}"
-INSTALLS_SHLIB= yes
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/libavcodec/liba52
-
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
-
-DISTFILE_DATE= 2005112800
-LIB_VERSION= 0
-
-.if defined(NO_PROFILE)
-MAKE_ARGS+= NO_PROFILE=${NO_PROFILE}
-.else
-PLIST_FILES+= lib/liba52-devel_p.a
-.endif
-
-post-extract:
- @${CP} ${FILESDIR}/${MAKEFILE} ${BUILD_WRKSRC}
-
-post-configure:
- @${SED} -E \
- -e 's|/usr/local/|${PREFIX}/|' \
- -e 's|%%LIB_VERSION%%|${LIB_VERSION}|' \
- -e 's|%%DJBFFT%%|${DJBFFT_LIBRARY}|' \
- -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- -e 's|%%PREFIX%%|${PREFIX}|' \
- ${FILESDIR}/liba52-devel.la > \
- ${WRKDIR}/liba52-devel.la
-
-pre-install:
- @${MKDIR} ${PREFIX}/include/a52dec-devel
-
-post-install:
- @${INSTALL_DATA} ${WRKDIR}/liba52-devel.la \
- ${PREFIX}/lib
-
-.include <bsd.port.pre.mk>
-
-###
-## specific ARCH information
-###
-.if ${ARCH} == "ia64"
-BROKEN= does not build on ia64
-.endif
-.if ${ARCH} == "i386" || ${ARCH} == "ia64"
-CFLAGS+= -DARCH_X86
-. if ${ARCH} == "ia64" || ${ARCH} == "amd64"
-CFLAGS+= -DARCH_X86_64
-. endif
-.endif
-## sse hardware vector support
-.if (defined(MACHINE_CPU) && ${MACHINE_CPU:Msse} == "sse")
-CFLAGS+= -DHAVE_SSE
-.endif
-
-###
-## library dependency
-###
-.if !defined(WITHOUT_DJBFFT) && !defined(PACKAGE_BUILDING)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
-RUN_DEPENDS+= ${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
-
-CFLAGS+= -DLIBA52_DJBFFT -I${LOCALBASE}/include
-
-DJBFFT_LIBRARY= -ldjbfft
-.endif
-
-###
-## optimizations
-###
-.ifdef(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -ffast-math
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/audio/liba52-devel/distinfo b/audio/liba52-devel/distinfo
deleted file mode 100644
index 37ef8007af59..000000000000
--- a/audio/liba52-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (FFMpeg-2005112800.tar.bz2) = c3c960816c75f640a93662961ba7f15f
-SHA256 (FFMpeg-2005112800.tar.bz2) = 7754ca22c545a8ecf5f9bb47a7fed0cbf918718e415caf40eb12ee84ec1655e9
-SIZE (FFMpeg-2005112800.tar.bz2) = 1694390
diff --git a/audio/liba52-devel/files/Makefile b/audio/liba52-devel/files/Makefile
deleted file mode 100644
index d208bee95ec1..000000000000
--- a/audio/liba52-devel/files/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# $FreeBSD$
-
-LIB= a52-devel
-SHLIB_MAJOR= ${LIB_VERSION}
-SHLIB_MINOR= 0
-CFLAGS+= -I${.CURDIR}
-
-SRCS= bit_allocate.c bitstream.c crc.c downmix.c imdct.c parse.c \
- resample.c
-INCS= a52.h a52_internal.h a52_util.h mm_accel.h
-
-# idea taken from port security/libparanoia
-# hacks around <bsd.lib.mk>, which ignores PREFIX
-.if defined(PREFIX)
-DESTDIR= ${PREFIX}/
-.else
-DESTDIR= /usr/local/
-.endif
-INCSDIR= include/a52dec-devel/
-INCDIR= ${INCSDIR} # for pre-bsd.incs.mk API
-LIBDIR= lib/
-
-.include <bsd.lib.mk>
diff --git a/audio/liba52-devel/files/liba52-devel.la b/audio/liba52-devel/files/liba52-devel.la
deleted file mode 100644
index ce60406f98ed..000000000000
--- a/audio/liba52-devel/files/liba52-devel.la
+++ /dev/null
@@ -1,28 +0,0 @@
-# liba52-devel.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.3.5-freebsd-ports (1.385.2.206 2000/05/27 11:12:27)
-#
-# Please DO NOT delete this file!
-# It is necessary for linking the library.
-
-# The name that we can dlopen(3).
-dlname=''
-
-# Names of this library.
-library_names='liba52-devel.so.%%LIB_VERSION%% liba52-devel.so'
-
-# The name of the static archive.
-old_library='liba52-devel.a'
-
-# Libraries that this one depends upon.
-dependency_libs=' -L%%LOCALBASE%%/lib %%DJBFFT%% -lm'
-
-# Version information for liba52-devel.
-current=0
-age=0
-revision=0
-
-# Is this an already installed library?
-installed=yes
-
-# Directory that this library needs to be installed in:
-libdir='%%PREFIX%%/lib'
diff --git a/audio/liba52-devel/files/patch-a52.h b/audio/liba52-devel/files/patch-a52.h
deleted file mode 100644
index 71cb5e473745..000000000000
--- a/audio/liba52-devel/files/patch-a52.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- a52.h.orig Sun Dec 11 01:57:32 2005
-+++ a52.h Sun Dec 11 02:42:30 2005
-@@ -24,11 +24,7 @@
- #ifndef A52_H
- #define A52_H
-
--#include "../avcodec.h"
--
--#undef malloc
--#undef free
--#undef realloc
-+#include <inttypes.h>
-
- #if defined(LIBA52_FIXED)
- typedef int32_t sample_t;
-@@ -41,7 +37,7 @@
- typedef float level_t;
- #endif
-
--typedef struct a52_state_s a52_state_t;
-+#include "a52_internal.h"
-
- #define A52_CHANNEL 0
- #define A52_MONO 1
diff --git a/audio/liba52-devel/files/patch-a52_internal.h b/audio/liba52-devel/files/patch-a52_internal.h
deleted file mode 100644
index 095f6a60ad62..000000000000
--- a/audio/liba52-devel/files/patch-a52_internal.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- a52_internal.h.orig Sun Dec 11 01:58:58 2005
-+++ a52_internal.h Sun Dec 11 02:47:04 2005
-@@ -21,6 +21,15 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#ifndef __LIBA52__52_internal_h__
-+# define __LIBA52__52_internal_h__
-+
-+#include <inttypes.h>
-+
-+#ifndef NULL
-+# define NULL 0
-+#endif
-+
- typedef struct {
- uint8_t bai; /* fine SNR offset, fast gain */
- uint8_t deltbae; /* delta bit allocation exists */
-@@ -87,6 +96,8 @@
- int downmixed;
- };
-
-+typedef struct a52_state_s a52_state_t;
-+
- #define LEVEL_PLUS6DB 2.0
- #define LEVEL_PLUS3DB 1.4142135623730951
- #define LEVEL_3DB 0.7071067811865476
-@@ -160,3 +171,5 @@
- #define BIAS(x) (x)
-
- #endif
-+
-+#endif /* __LIBA52__52_internal_h__ */
diff --git a/audio/liba52-devel/files/patch-imdct.c b/audio/liba52-devel/files/patch-imdct.c
deleted file mode 100644
index 099acc3589a2..000000000000
--- a/audio/liba52-devel/files/patch-imdct.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- imdct.c.orig Sun Aug 24 10:57:20 2003
-+++ imdct.c Sun Dec 11 03:24:14 2005
-@@ -24,6 +24,12 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#include <math.h>
-+
-+#ifdef LIBA52_DJBFFT
-+#include <djbfft/fftc4.h>
-+#endif
-+
- #include "a52.h"
- #include "a52_internal.h"
- #include "mm_accel.h"
diff --git a/audio/liba52-devel/files/patch-resample.c b/audio/liba52-devel/files/patch-resample.c
deleted file mode 100644
index dc378c959535..000000000000
--- a/audio/liba52-devel/files/patch-resample.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- resample.c.orig Mon Nov 3 16:06:32 2003
-+++ resample.c Sun Dec 11 03:27:20 2005
-@@ -6,7 +6,6 @@
-
- #include "a52.h"
- #include "mm_accel.h"
--#include "config.h"
- #include "../libpostproc/mangle.h"
-
- int (* a52_resample) (float * _f, int16_t * s16)=NULL;
-@@ -14,6 +13,7 @@
- #include "resample_c.c"
-
- #ifdef ARCH_X86
-+#include "../../libavutil/common.h"
- #include "resample_mmx.c"
- #endif
-
-@@ -24,7 +24,6 @@
- if(mm_accel&MM_ACCEL_X86_MMX){
- tmp=a52_resample_MMX(flags,chans);
- if(tmp){
-- if(a52_resample==NULL) av_log(NULL, AV_LOG_INFO, "Using MMX optimized resampler\n");
- a52_resample=tmp;
- return tmp;
- }
-@@ -33,11 +32,9 @@
-
- tmp=a52_resample_C(flags,chans);
- if(tmp){
-- if(a52_resample==NULL) av_log(NULL, AV_LOG_INFO, "No accelerated resampler found\n");
- a52_resample=tmp;
- return tmp;
- }
-
-- av_log(NULL, AV_LOG_ERROR, "Unimplemented resampler for mode 0x%X -> %d channels conversion - Contact MPlayer developers!\n", flags, chans);
- return NULL;
- }
diff --git a/audio/liba52-devel/pkg-descr b/audio/liba52-devel/pkg-descr
deleted file mode 100644
index 1ae77193cc93..000000000000
--- a/audio/liba52-devel/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-[ from developer's site ]
-It is a free library for decoding ATSC A/52 streams, aka AC-3. The
-A/52 standard is used in a variety of applications, e.g., digital
-television and DVD. The main goals in liba52 development are:
-
-Portability - most of the code is written in C, and when we use
-platform-specific optimizations we always have a generic C routine
-to fall back on.
-
-Reuseability - we do not want liba52 to include any project-specific
-code, but it should still include enough features to be used by
-very diverse projects.
-
-Precision - We are trying to implement all of the A/52 standard,
-and to have a very precise output by doing all the calculations in
-floating point. We have a test suite that detects any deviation in
-the output when compared to previous versions. We do not have access
-to official A/52 test vectors though, so we have to use our judgement
-to ensure that such deviations are only introduced when we fix bugs!
-
-Speed - liba52 is really fast, on any modern PC it should take only
-a few percent of CPU time.
-
-WWW: http://www.mplayerhq.hu/
diff --git a/audio/liba52-devel/pkg-plist b/audio/liba52-devel/pkg-plist
deleted file mode 100644
index b529657fbc18..000000000000
--- a/audio/liba52-devel/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-include/a52dec-devel/a52.h
-include/a52dec-devel/a52_internal.h
-include/a52dec-devel/a52_util.h
-include/a52dec-devel/mm_accel.h
-lib/liba52-devel.a
-lib/liba52-devel.la
-lib/liba52-devel.so
-lib/liba52-devel.so.%%LIB_VERSION%%
-@dirrm include/a52dec-devel