aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-23 17:03:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-23 17:03:22 +0000
commita2cc225b1d45e9539765eb0479930e54a8bda984 (patch)
tree1aee357311a336c5fa8bd5c151bb6ee0145ebe29
parent6de023c4e884e6ad513f4ac3ca785289f96ca392 (diff)
downloadports-a2cc225b1d45e9539765eb0479930e54a8bda984.tar.gz
ports-a2cc225b1d45e9539765eb0479930e54a8bda984.zip
MFH: r549040 r549751
graphics/vv: Update 1.4.0-377 -> 1.4.0-383 graphics/vv: Fix build on some systems by adding the workaround for the bug in science/InsightToolkit Reported by: fallout Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549753
-rw-r--r--graphics/vv/Makefile14
-rw-r--r--graphics/vv/distinfo6
-rw-r--r--graphics/vv/files/patch-vv_vv.cxx11
3 files changed, 24 insertions, 7 deletions
diff --git a/graphics/vv/Makefile b/graphics/vv/Makefile
index 1d329cea4202..44f38b03d5f5 100644
--- a/graphics/vv/Makefile
+++ b/graphics/vv/Makefile
@@ -2,9 +2,9 @@
PORTNAME= vv
DISTVERSIONPREFIX= v
-DISTVERSION= 1.4.0-377
-DISTVERSIONSUFFIX= -g7c3a1ed4
-PORTREVISION= 3
+DISTVERSION= 1.4.0-383
+DISTVERSIONSUFFIX= -g7a783a8b
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
@@ -35,7 +35,13 @@ CMAKE_ARGS= -DVTK_DIR:PATH=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2
PLIST_FILES= bin/vv
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386A || ${ARCH} == amd64
+CXXFLAGS+= -msse2 # workaround for https://github.com/open-vv/vv/issues/83 & https://github.com/InsightSoftwareConsortium/ITK/issues/2011
+.endif
+
post-configure: # workaround for "error: unable to find library -lGTest::GTest", see https://github.com/open-vv/vv/issues/74
@${REINPLACE_CMD} -E 's/ -lGTest::(GTest|Main) / /g' ${BUILD_WRKSRC}/build.ninja
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/vv/distinfo b/graphics/vv/distinfo
index d00a374d4fff..a7748e6e693c 100644
--- a/graphics/vv/distinfo
+++ b/graphics/vv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578717444
-SHA256 (open-vv-vv-v1.4.0-377-g7c3a1ed4_GH0.tar.gz) = 70412e06200c2049a02b500ceadf46e039b18e4f3b45ca61ab3c9e0cca804707
-SIZE (open-vv-vv-v1.4.0-377-g7c3a1ed4_GH0.tar.gz) = 4860892
+TIMESTAMP = 1600492328
+SHA256 (open-vv-vv-v1.4.0-383-g7a783a8b_GH0.tar.gz) = dfa80f7036297e859bf5c6b18b2b187fc05dc50a17f0b074d909e96fa8c2acbb
+SIZE (open-vv-vv-v1.4.0-383-g7a783a8b_GH0.tar.gz) = 4860982
diff --git a/graphics/vv/files/patch-vv_vv.cxx b/graphics/vv/files/patch-vv_vv.cxx
new file mode 100644
index 000000000000..b3517f001de0
--- /dev/null
+++ b/graphics/vv/files/patch-vv_vv.cxx
@@ -0,0 +1,11 @@
+--- vv/vv.cxx.orig 2020-09-19 05:31:12 UTC
++++ vv/vv.cxx
+@@ -53,7 +53,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <errno.h>
+-#pragma comment(lib, "ws2_32.lib")
++//#pragma comment(lib, "ws2_32.lib")
+
+ typedef enum {O_BASE,O_OVERLAY,O_FUSION,O_VF,O_CONTOUR,O_LANDMARKS} OpenModeType;
+ typedef enum {P_NORMAL,P_SEQUENCE,P_WINDOW,P_LEVEL} ParseModeType;