aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-01-14 21:34:53 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-01-14 21:34:53 +0000
commita95d4c89e510a3ae6690e26549e4c763a81e929c (patch)
tree4b83b74c2d7130f651b2d0fa2585dd2f03f2e718
parentbcd0f52004e66a2a2e3c8c5858efb367c5b06ac1 (diff)
downloadports-a95d4c89e510a3ae6690e26549e4c763a81e929c.tar.gz
ports-a95d4c89e510a3ae6690e26549e4c763a81e929c.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_authnz_external24/Makefile29
-rw-r--r--www/mod_authnz_external24/distinfo2
-rw-r--r--www/mod_authnz_external24/pkg-descr11
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 63b5b25c7767..51402bfc5be6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -467,6 +467,7 @@
SUBDIR += mod_authn_sasl
SUBDIR += mod_authnz_crowd
SUBDIR += mod_authnz_external22
+ SUBDIR += mod_authnz_external24
SUBDIR += mod_authz_unixgroup
SUBDIR += mod_backtrace
SUBDIR += mod_bw
diff --git a/www/mod_authnz_external24/Makefile b/www/mod_authnz_external24/Makefile
new file mode 100644
index 000000000000..1a886e24aaf4
--- /dev/null
+++ b/www/mod_authnz_external24/Makefile
@@ -0,0 +1,29 @@
+# Created by: José García Juanino <jjuanino@gmail.com>
+# $FreeBSD$
+
+PORTNAME= mod_authnz_external
+PORTVERSION= 3.3.2
+CATEGORIES= www
+MASTER_SITES= GOOGLE_CODE
+PKGNAMESUFFIX= 24
+DIST_SUBDIR= apache24
+
+MAINTAINER= eugene@zhegan.in
+COMMENT= Allows users authentication based on external mechanisms on apache 2.4
+
+LICENSE= APACHE20
+
+USE_APACHE= 24
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+SHORTMODNAME= authnz_external
+PROJECTHOST= mod-auth-external
+
+PORTDOCS= AUTHENTICATORS INSTALL README \
+ CHANGES UPGRADE INSTALL.HARDCODE
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/mod_authnz_external24/distinfo b/www/mod_authnz_external24/distinfo
new file mode 100644
index 000000000000..abf292d1653f
--- /dev/null
+++ b/www/mod_authnz_external24/distinfo
@@ -0,0 +1,2 @@
+SHA256 (apache24/mod_authnz_external-3.3.2.tar.gz) = a16b31d81c20e024e7efe480fe98b48d5ce40d520b0a13ff38ab003cc527f1e8
+SIZE (apache24/mod_authnz_external-3.3.2.tar.gz) = 36160
diff --git a/www/mod_authnz_external24/pkg-descr b/www/mod_authnz_external24/pkg-descr
new file mode 100644
index 000000000000..e1485da45e2a
--- /dev/null
+++ b/www/mod_authnz_external24/pkg-descr
@@ -0,0 +1,11 @@
+Mod_authnz_external is an Apache module used for authentication. The Apache HTTP
+Daemon can be configured to require users to supply logins and passwords
+before accessing pages in some directories. Authentication is the process of
+checking if the password given is correct for a user. Apache has standard
+modules for authenticating out of several different kinds of databases.
+Mod_authnz_external is a flexible tool for creating authentication systems based
+on other databases.
+
+This port gives the same funcionality as mod_auth_external, but over apache 2.4.
+
+WWW: http://code.google.com/p/mod-auth-external/