aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-01-16 09:49:18 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-01-16 09:49:18 +0000
commitaaa6f8832f7ca42b1b17e754bb310d9321c6eef4 (patch)
treecd8e359b551d1b3ebeafdd872fa4f70985d8d1ad
parent1d1baf70fd29e39f94cd121004588288cf3bf5c9 (diff)
downloadports-aaa6f8832f7ca42b1b17e754bb310d9321c6eef4.tar.gz
ports-aaa6f8832f7ca42b1b17e754bb310d9321c6eef4.zip
Notes
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/telepathy-qt4/Makefile65
-rw-r--r--net-im/telepathy-qt4/distinfo3
-rw-r--r--net-im/telepathy-qt4/pkg-descr8
-rw-r--r--net-im/telepathy-qt4/pkg-plist195
5 files changed, 272 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 1644332bd1b2..f9b0c1ccc94d 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -156,6 +156,7 @@
SUBDIR += telepathy-mission-control
SUBDIR += telepathy-python
SUBDIR += telepathy-qt
+ SUBDIR += telepathy-qt4
SUBDIR += telepathy-salut
SUBDIR += tkabber
SUBDIR += tkabber-devel
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
new file mode 100644
index 000000000000..0c08ef79c58e
--- /dev/null
+++ b/net-im/telepathy-qt4/Makefile
@@ -0,0 +1,65 @@
+# New ports collection Makefile for: telepathy-qt4
+# Date created: 14 January 2010
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= telepathy-qt4
+PORTVERSION= 0.2.1
+CATEGORIES= net-im
+MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= High-level Qt 4 binding for Telepathy
+
+LIB_DEPENDS= telepathy-farsight.0:${PORTSDIR}/net-im/telepathy-farsight \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+
+USE_GNOME= pkgconfig
+USE_PYTHON_BUILD= 2.5+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib dbus network xml qtestlib \
+ moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README html
+
+PORTEXAMPLES= Makefile Makefile.am Makefile.in \
+ accounts call extensions file-transfer roster
+
+OPTIONS= TESTS "Run regression tests" off
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_TESTS)
+QT_COMPONENTS+= qtestlib_build
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -E -e 's:(^pkgconfigdir =).*:\1 ${PREFIX}/libdata/pkgconfig:' \
+ ${WRKSRC}/TelepathyQt4/Makefile.in
+
+pre-install:
+.ifndef(NOPORTDOCS)
+ cd ${WRKSRC} && ${CP} -R doc/html .
+.endif
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${DOCSDIR}
+.endfor
+.endif
+.ifndef(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${f} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/telepathy-qt4/distinfo b/net-im/telepathy-qt4/distinfo
new file mode 100644
index 000000000000..d500084add41
--- /dev/null
+++ b/net-im/telepathy-qt4/distinfo
@@ -0,0 +1,3 @@
+MD5 (telepathy-qt4-0.2.1.tar.gz) = 9eaaa055eb2503e5a362bd183f344ac7
+SHA256 (telepathy-qt4-0.2.1.tar.gz) = 982522c82fd296dc15cac92f7f32cb389e0e609fb0eb0e932b7b0bab551cbdef
+SIZE (telepathy-qt4-0.2.1.tar.gz) = 2653437
diff --git a/net-im/telepathy-qt4/pkg-descr b/net-im/telepathy-qt4/pkg-descr
new file mode 100644
index 000000000000..0f7d2f19c224
--- /dev/null
+++ b/net-im/telepathy-qt4/pkg-descr
@@ -0,0 +1,8 @@
+This is a library for Qt-based Telepathy clients.
+
+Telepathy is a D-Bus framework for unifying real time communication,
+including instant messaging, voice calls and video calls. It abstracts
+differences between protocols to provide a unified interface for
+applications.
+
+WWW: http://telepathy.freedesktop.org/wiki/Telepathy-Qt4
diff --git a/net-im/telepathy-qt4/pkg-plist b/net-im/telepathy-qt4/pkg-plist
new file mode 100644
index 000000000000..6f44b12d5110
--- /dev/null
+++ b/net-im/telepathy-qt4/pkg-plist
@@ -0,0 +1,195 @@
+include/telepathy-1.0/TelepathyQt4/AbstractClient
+include/telepathy-1.0/TelepathyQt4/AbstractClientApprover
+include/telepathy-1.0/TelepathyQt4/AbstractClientHandler
+include/telepathy-1.0/TelepathyQt4/AbstractClientObserver
+include/telepathy-1.0/TelepathyQt4/AbstractInterface
+include/telepathy-1.0/TelepathyQt4/Account
+include/telepathy-1.0/TelepathyQt4/AccountInterface
+include/telepathy-1.0/TelepathyQt4/AccountManager
+include/telepathy-1.0/TelepathyQt4/AccountManagerInterface
+include/telepathy-1.0/TelepathyQt4/CapabilitiesBase
+include/telepathy-1.0/TelepathyQt4/Channel
+include/telepathy-1.0/TelepathyQt4/ChannelDispatchOperation
+include/telepathy-1.0/TelepathyQt4/ChannelDispatchOperationInterface
+include/telepathy-1.0/TelepathyQt4/ChannelDispatcher
+include/telepathy-1.0/TelepathyQt4/ChannelDispatcherInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfaceCallStateInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfaceChatStateInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfaceDTMFInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfaceGroupInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfaceHoldInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfaceMediaSignallingInterface
+include/telepathy-1.0/TelepathyQt4/ChannelInterfacePasswordInterface
+include/telepathy-1.0/TelepathyQt4/ChannelRequest
+include/telepathy-1.0/TelepathyQt4/ChannelRequestInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeContactListInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeRoomListInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeStreamTubeInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeStreamedMediaInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeTextInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeTubeInterface
+include/telepathy-1.0/TelepathyQt4/ChannelTypeTubesInterface
+include/telepathy-1.0/TelepathyQt4/Client
+include/telepathy-1.0/TelepathyQt4/ClientApproverInterface
+include/telepathy-1.0/TelepathyQt4/ClientHandlerInterface
+include/telepathy-1.0/TelepathyQt4/ClientInterface
+include/telepathy-1.0/TelepathyQt4/ClientInterfaceRequestsInterface
+include/telepathy-1.0/TelepathyQt4/ClientObserverInterface
+include/telepathy-1.0/TelepathyQt4/ClientRegistrar
+include/telepathy-1.0/TelepathyQt4/Connection
+include/telepathy-1.0/TelepathyQt4/ConnectionCapabilities
+include/telepathy-1.0/TelepathyQt4/ConnectionInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfaceAliasingInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfaceAvatarsInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfaceCapabilitiesInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfaceContactsInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfacePresenceInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfaceRequestsInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionInterfaceSimplePresenceInterface
+include/telepathy-1.0/TelepathyQt4/ConnectionManager
+include/telepathy-1.0/TelepathyQt4/ConnectionManagerInterface
+include/telepathy-1.0/TelepathyQt4/Constants
+include/telepathy-1.0/TelepathyQt4/Contact
+include/telepathy-1.0/TelepathyQt4/ContactCapabilities
+include/telepathy-1.0/TelepathyQt4/ContactManager
+include/telepathy-1.0/TelepathyQt4/DBus
+include/telepathy-1.0/TelepathyQt4/DBusDaemonInterface
+include/telepathy-1.0/TelepathyQt4/DBusProxy
+include/telepathy-1.0/TelepathyQt4/Debug
+include/telepathy-1.0/TelepathyQt4/Farsight/Channel
+include/telepathy-1.0/TelepathyQt4/Farsight/channel.h
+include/telepathy-1.0/TelepathyQt4/Farsight/global.h
+include/telepathy-1.0/TelepathyQt4/Feature
+include/telepathy-1.0/TelepathyQt4/FileTransferChannel
+include/telepathy-1.0/TelepathyQt4/FileTransferChannelCreationProperties
+include/telepathy-1.0/TelepathyQt4/Global
+include/telepathy-1.0/TelepathyQt4/IncomingFileTransferChannel
+include/telepathy-1.0/TelepathyQt4/IntrospectableInterface
+include/telepathy-1.0/TelepathyQt4/KeyFile
+include/telepathy-1.0/TelepathyQt4/ManagerFile
+include/telepathy-1.0/TelepathyQt4/MediaSessionHandler
+include/telepathy-1.0/TelepathyQt4/MediaSessionHandlerInterface
+include/telepathy-1.0/TelepathyQt4/MediaStreamHandler
+include/telepathy-1.0/TelepathyQt4/MediaStreamHandlerInterface
+include/telepathy-1.0/TelepathyQt4/Message
+include/telepathy-1.0/TelepathyQt4/MethodInvocationContext
+include/telepathy-1.0/TelepathyQt4/OptionalInterfaceFactory
+include/telepathy-1.0/TelepathyQt4/OutgoingFileTransferChannel
+include/telepathy-1.0/TelepathyQt4/PeerInterface
+include/telepathy-1.0/TelepathyQt4/PendingAccount
+include/telepathy-1.0/TelepathyQt4/PendingChannel
+include/telepathy-1.0/TelepathyQt4/PendingChannelRequest
+include/telepathy-1.0/TelepathyQt4/PendingConnection
+include/telepathy-1.0/TelepathyQt4/PendingContactAttributes
+include/telepathy-1.0/TelepathyQt4/PendingContacts
+include/telepathy-1.0/TelepathyQt4/PendingFailure
+include/telepathy-1.0/TelepathyQt4/PendingHandles
+include/telepathy-1.0/TelepathyQt4/PendingOperation
+include/telepathy-1.0/TelepathyQt4/PendingReady
+include/telepathy-1.0/TelepathyQt4/PendingStringList
+include/telepathy-1.0/TelepathyQt4/PendingSuccess
+include/telepathy-1.0/TelepathyQt4/PendingVariant
+include/telepathy-1.0/TelepathyQt4/PendingVoid
+include/telepathy-1.0/TelepathyQt4/Properties
+include/telepathy-1.0/TelepathyQt4/PropertiesInterface
+include/telepathy-1.0/TelepathyQt4/PropertiesInterfaceInterface
+include/telepathy-1.0/TelepathyQt4/ReadinessHelper
+include/telepathy-1.0/TelepathyQt4/ReadyObject
+include/telepathy-1.0/TelepathyQt4/ReceivedMessage
+include/telepathy-1.0/TelepathyQt4/RefCounted
+include/telepathy-1.0/TelepathyQt4/ReferencedHandles
+include/telepathy-1.0/TelepathyQt4/ReferencedHandlesIterator
+include/telepathy-1.0/TelepathyQt4/RoomListChannel
+include/telepathy-1.0/TelepathyQt4/SharedPtr
+include/telepathy-1.0/TelepathyQt4/StatefulDBusProxy
+include/telepathy-1.0/TelepathyQt4/StatelessDBusProxy
+include/telepathy-1.0/TelepathyQt4/StreamedMediaChannel
+include/telepathy-1.0/TelepathyQt4/TextChannel
+include/telepathy-1.0/TelepathyQt4/Types
+include/telepathy-1.0/TelepathyQt4/WeakPtr
+include/telepathy-1.0/TelepathyQt4/_gen/cli-account-manager.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-account.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-channel-dispatch-operation.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-channel-dispatcher.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-channel-request.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-channel.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-client.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-connection-manager.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-connection.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-dbus.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-media-session-handler.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-media-stream-handler.h
+include/telepathy-1.0/TelepathyQt4/_gen/cli-properties.h
+include/telepathy-1.0/TelepathyQt4/_gen/constants.h
+include/telepathy-1.0/TelepathyQt4/_gen/types.h
+include/telepathy-1.0/TelepathyQt4/abstract-client.h
+include/telepathy-1.0/TelepathyQt4/abstract-interface.h
+include/telepathy-1.0/TelepathyQt4/account-manager.h
+include/telepathy-1.0/TelepathyQt4/account.h
+include/telepathy-1.0/TelepathyQt4/capabilities-base.h
+include/telepathy-1.0/TelepathyQt4/channel-dispatch-operation.h
+include/telepathy-1.0/TelepathyQt4/channel-dispatcher.h
+include/telepathy-1.0/TelepathyQt4/channel-request.h
+include/telepathy-1.0/TelepathyQt4/channel.h
+include/telepathy-1.0/TelepathyQt4/client-registrar.h
+include/telepathy-1.0/TelepathyQt4/client.h
+include/telepathy-1.0/TelepathyQt4/connection-capabilities.h
+include/telepathy-1.0/TelepathyQt4/connection-manager.h
+include/telepathy-1.0/TelepathyQt4/connection.h
+include/telepathy-1.0/TelepathyQt4/constants.h
+include/telepathy-1.0/TelepathyQt4/contact-capabilities.h
+include/telepathy-1.0/TelepathyQt4/contact-manager-internal.h
+include/telepathy-1.0/TelepathyQt4/contact-manager.h
+include/telepathy-1.0/TelepathyQt4/contact.h
+include/telepathy-1.0/TelepathyQt4/dbus-proxy.h
+include/telepathy-1.0/TelepathyQt4/dbus.h
+include/telepathy-1.0/TelepathyQt4/debug.h
+include/telepathy-1.0/TelepathyQt4/feature.h
+include/telepathy-1.0/TelepathyQt4/file-transfer-channel-creation-properties.h
+include/telepathy-1.0/TelepathyQt4/file-transfer-channel.h
+include/telepathy-1.0/TelepathyQt4/global.h
+include/telepathy-1.0/TelepathyQt4/incoming-file-transfer-channel.h
+include/telepathy-1.0/TelepathyQt4/key-file.h
+include/telepathy-1.0/TelepathyQt4/manager-file.h
+include/telepathy-1.0/TelepathyQt4/media-session-handler.h
+include/telepathy-1.0/TelepathyQt4/media-stream-handler.h
+include/telepathy-1.0/TelepathyQt4/message.h
+include/telepathy-1.0/TelepathyQt4/method-invocation-context.h
+include/telepathy-1.0/TelepathyQt4/optional-interface-factory.h
+include/telepathy-1.0/TelepathyQt4/outgoing-file-transfer-channel.h
+include/telepathy-1.0/TelepathyQt4/pending-account.h
+include/telepathy-1.0/TelepathyQt4/pending-channel-request.h
+include/telepathy-1.0/TelepathyQt4/pending-channel.h
+include/telepathy-1.0/TelepathyQt4/pending-connection.h
+include/telepathy-1.0/TelepathyQt4/pending-contact-attributes.h
+include/telepathy-1.0/TelepathyQt4/pending-contacts.h
+include/telepathy-1.0/TelepathyQt4/pending-handles.h
+include/telepathy-1.0/TelepathyQt4/pending-operation.h
+include/telepathy-1.0/TelepathyQt4/pending-ready.h
+include/telepathy-1.0/TelepathyQt4/pending-string-list.h
+include/telepathy-1.0/TelepathyQt4/pending-variant.h
+include/telepathy-1.0/TelepathyQt4/properties.h
+include/telepathy-1.0/TelepathyQt4/readiness-helper.h
+include/telepathy-1.0/TelepathyQt4/ready-object.h
+include/telepathy-1.0/TelepathyQt4/referenced-handles.h
+include/telepathy-1.0/TelepathyQt4/room-list-channel.h
+include/telepathy-1.0/TelepathyQt4/shared-ptr.h
+include/telepathy-1.0/TelepathyQt4/simple-pending-operations.h
+include/telepathy-1.0/TelepathyQt4/streamed-media-channel.h
+include/telepathy-1.0/TelepathyQt4/text-channel.h
+include/telepathy-1.0/TelepathyQt4/types.h
+lib/libtelepathy-qt4-farsight.a
+lib/libtelepathy-qt4-farsight.la
+lib/libtelepathy-qt4-farsight.so
+lib/libtelepathy-qt4-farsight.so.1
+lib/libtelepathy-qt4.a
+lib/libtelepathy-qt4.la
+lib/libtelepathy-qt4.so
+lib/libtelepathy-qt4.so.1
+libdata/pkgconfig/TelepathyQt4.pc
+libdata/pkgconfig/TelepathyQt4Farsight.pc
+@dirrm include/telepathy-1.0/TelepathyQt4/_gen
+@dirrm include/telepathy-1.0/TelepathyQt4/Farsight
+@dirrm include/telepathy-1.0/TelepathyQt4
+@dirrmtry include/telepathy-1.0