aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-03 22:34:38 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-03 22:34:38 +0000
commitab7af76236466760b00907dd7d1163ec76908769 (patch)
treef5afcb35df412f272b815ff64fb51e270a8c3f62
parente92033371a47daa5d2408cb448febc18c17d3bb0 (diff)
downloadports-ab7af76236466760b00907dd7d1163ec76908769.tar.gz
ports-ab7af76236466760b00907dd7d1163ec76908769.zip
MFH: r547488
net-mgmt/fastnetmon: unbreak on powerpc64, others non-x86 need testing LuaJIT is not available on powerpc64. Approved by: portmgr (fix build blanket)
Notes
Notes: svn path=/branches/2020Q3/; revision=547489
-rw-r--r--net-mgmt/fastnetmon/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-mgmt/fastnetmon/Makefile b/net-mgmt/fastnetmon/Makefile
index f3dc8f17a923..b165b313f0ac 100644
--- a/net-mgmt/fastnetmon/Makefile
+++ b/net-mgmt/fastnetmon/Makefile
@@ -15,16 +15,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_armv6= Does not build: invokes x86 assembler
BROKEN_armv7= Does not build: invokes x86 assembler
-BROKEN_powerpc64= Does not build
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp \
- libluajit-5.1.so:lang/luajit \
libmongoc-1.0.so:devel/mongo-c-driver \
libjson-c.so:devel/json-c \
libbson-1.0.so:devel/libbson
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= pavel-odintsov
@@ -46,6 +44,14 @@ CMAKE_ARGS+= -DDISABLE_PF_RING_SUPPORT=ON \
-DENABLE_NETMAP_SUPPORT=OFF
CMAKE_INSTALL_PREFIX= ${PREFIX}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64 || ${ARCH} == i386
+LIB_DEPENDS+= libluajit-5.1.so:lang/luajit
+.else
+CMAKE_ARGS+= -DENABLE_LUA_SUPPORT:BOOL=OFF
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|; \
@@ -65,4 +71,4 @@ post-install:
post-install-DOCS-on:
cd ${WRKSRC} && ${COPYTREE_SHARE} "README.md docs" ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>