aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-05-11 17:37:34 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-05-11 17:37:34 +0000
commitad7138b93009e2569fdf41ac7227177b24d96ee0 (patch)
tree13f9e8770d314c66ed434a0b61b6c8537f9c6be1
parentfe01c023ca828c7ba762725b2b213e4374d0fcff (diff)
downloadports-ad7138b93009e2569fdf41ac7227177b24d96ee0.tar.gz
ports-ad7138b93009e2569fdf41ac7227177b24d96ee0.zip
Notes
-rw-r--r--net/ethereal/Makefile10
-rw-r--r--net/wireshark/Makefile10
2 files changed, 14 insertions, 6 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index b559b42b8cb9..ba22f0bcaf54 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ethereal
PORTVERSION= 0.10.11
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
@@ -17,8 +18,11 @@ MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
MAINTAINER= marcus@FreeBSD.org
COMMENT?= A powerful network analyzer/capture tool
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
USE_PERL5_BUILD=yes
USE_BZIP2= yes
+USE_GNOME= gnometarget
WANT_GNOME= yes
CONFIGURE_ARGS+= --program-transform-name=""
INSTALLS_SHLIB= yes
@@ -43,14 +47,14 @@ USE_X_PREFIX= yes
MAN1+= ethereal.1
PLIST_SUB+= ETHEREAL=bin/ethereal
.if defined(WITHOUT_GTK2)
-USE_GNOME= gtk12
+USE_GNOME+= gtk12
CONFIGURE_ARGS+= --disable-gtk2
.else
-USE_GNOME= gtk20
+USE_GNOME+= gtk20
.endif
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
-USE_GNOME= glib12
+USE_GNOME+= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
--disable-gtktest \
--with-gtk-prefix=/nonexistent \
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index b559b42b8cb9..ba22f0bcaf54 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ethereal
PORTVERSION= 0.10.11
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
@@ -17,8 +18,11 @@ MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
MAINTAINER= marcus@FreeBSD.org
COMMENT?= A powerful network analyzer/capture tool
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
USE_PERL5_BUILD=yes
USE_BZIP2= yes
+USE_GNOME= gnometarget
WANT_GNOME= yes
CONFIGURE_ARGS+= --program-transform-name=""
INSTALLS_SHLIB= yes
@@ -43,14 +47,14 @@ USE_X_PREFIX= yes
MAN1+= ethereal.1
PLIST_SUB+= ETHEREAL=bin/ethereal
.if defined(WITHOUT_GTK2)
-USE_GNOME= gtk12
+USE_GNOME+= gtk12
CONFIGURE_ARGS+= --disable-gtk2
.else
-USE_GNOME= gtk20
+USE_GNOME+= gtk20
.endif
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
-USE_GNOME= glib12
+USE_GNOME+= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
--disable-gtktest \
--with-gtk-prefix=/nonexistent \