aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2020-09-30 07:49:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2020-09-30 07:49:07 +0000
commitb21d2ec899ed8f896fe064aec29747e312448425 (patch)
treee3887eac146b8e933983f3646e502bd44cfdbf08
parent562d7e4f0a7f7d8ddab0f590c664bf572b252003 (diff)
downloadports-b21d2ec899ed8f896fe064aec29747e312448425.tar.gz
ports-b21d2ec899ed8f896fe064aec29747e312448425.zip
MFH: r550465
dns/powerdns: update 4.3.0 -> 4.3.1 Improvements: - EL8 pkgs: Build mysql backend against mariadb-connector-c-devel - gpgsql: Reintroduce prepared statements - gsqlite3backend: add missing indexes - use real remote for supermaster createSlaveDomain() - Optimize IXFR-to-AXFR fallback path - Install bind SQL schema files as part of bindbackend - Do not send out of zone lookups to the backends Bug Fixes: - Raise an exception on invalid hex content in unknown records. - Handle the extra single-row result set of MySQL stored procedures PR: 249560 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer) Security: CVE-2020-17482 https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2020-05.html Relnotes: https://doc.powerdns.com/authoritative/changelog/4.3.html#change-4.3.1 Approved by: ports-secteam (blanket)
Notes
Notes: svn path=/branches/2020Q3/; revision=550653
-rw-r--r--dns/powerdns/Makefile23
-rw-r--r--dns/powerdns/distinfo6
-rw-r--r--dns/powerdns/pkg-descr19
-rw-r--r--dns/powerdns/pkg-plist2
4 files changed, 29 insertions, 21 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 37f5829dff48..0919ec5abed3 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= powerdns
-DISTVERSION= 4.3.0
-PORTREVISION= 2
+DISTVERSION= 4.3.1
CATEGORIES= dns
MASTER_SITES= https://downloads.powerdns.com/releases/
DISTNAME= pdns-${DISTVERSION}
@@ -38,11 +37,13 @@ SCRIPTS_ENV= CURDIR2="${.CURDIR}" DISTNAME="${DISTNAME}" MKDIR="${MKDIR}" \
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS EXAMPLES GEOIP IXFRDIST LMDB LUABACKEND \
- LUAJIT MYSQL OPENLDAP PGSQL PROTOBUF REMOTE \
- SQLITE3 TINYDNS TOOLS UNIXODBC
-OPTIONS_DEFAULT= LMDB MYSQL PGSQL SQLITE3
+ MYSQL OPENLDAP PGSQL PROTOBUF REMOTE SQLITE3 \
+ TINYDNS TOOLS UNIXODBC
+OPTIONS_DEFAULT= LMDB LUA MYSQL PGSQL SQLITE3
OPTIONS_GROUP= GEOIPOPT REMOTEOPT
OPTIONS_GROUP_REMOTEOPT= ZEROMQ
+OPTIONS_SINGLE= EXTLUA
+OPTIONS_SINGLE_EXTLUA= LUA LUAJIT LUAJITOR
OPTIONS_SUB= yes
@@ -51,7 +52,9 @@ GEOIP_DESC= GeoIP backend (GeoIP2 DB)
IXFRDIST_DESC= Build ixfrdist
LMDB_DESC= LMDB backend
LUABACKEND_DESC= Lua2 backend
-LUAJIT_DESC= Use LuaJIT instead of Lua
+LUAJITOR_DESC= Use lang/luajit-openresty
+LUAJIT_DESC= Use lang/luajit
+LUA_DESC= Use lang/lua
MYSQL_DESC= MySQL backend
OPENLDAP_DESC= OpenLDAP backend
PGSQL_DESC= PostgreSQL backend
@@ -76,10 +79,14 @@ LMDB_VARS= MODULES+=lmdb
LUABACKEND_VARS= MODULES+=lua2
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit-openresty
-LUAJIT_USES_OFF= lua
+LUAJITOR_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit-openresty
+LUAJITOR_CONFIGURE_ON= --with-lua=luajit
+
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit
LUAJIT_CONFIGURE_ON= --with-lua=luajit
+LUA_USES= lua
+
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
diff --git a/dns/powerdns/distinfo b/dns/powerdns/distinfo
index 4105b4864188..f5215f9d4e11 100644
--- a/dns/powerdns/distinfo
+++ b/dns/powerdns/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588788036
-SHA256 (pdns-4.3.0.tar.bz2) = 6be2e70f100df6f32cb431d5f57ca0aabde1fba6c11d947eccc86d44bdf95d08
-SIZE (pdns-4.3.0.tar.bz2) = 1211536
+TIMESTAMP = 1600815384
+SHA256 (pdns-4.3.1.tar.bz2) = d5146c04098ee94b9377ee491ebb3fd5eb061d7b24262f4a8e1a89f2ed3fc245
+SIZE (pdns-4.3.1.tar.bz2) = 1216876
diff --git a/dns/powerdns/pkg-descr b/dns/powerdns/pkg-descr
index 3c33d2a58921..8650b211c41a 100644
--- a/dns/powerdns/pkg-descr
+++ b/dns/powerdns/pkg-descr
@@ -1,16 +1,15 @@
The PowerDNS Authoritative Server is the only solution that enables
-authoritative DNS service from all major databases, including but
-not limited to MySQL, PostgreSQL, SQLite3, LDAP and plain text files.
+authoritative DNS service from all major databases, including but not limited
+to MySQL, PostgreSQL, SQLite3, LDAP and plain text files.
-DNS answers can also be fully scripted using a variety of (scripting)
-languages such as Lua, Java, Perl, Python, Ruby, C and C++. Such
-scripting can be used for dynamic redirection, (spam) filtering or
-real time intervention.
+DNS answers can also be fully scripted using a variety of (scripting) languages
+such as Lua, Java, Perl, Python, Ruby, C and C++. Such scripting can be used
+for dynamic redirection, (spam) filtering or real time intervention.
In addition, the PowerDNS Authoritative Server is the leading DNSSEC
-implementation, hosting the majority of all DNSSEC domains worldwide.
-The Authoritative Server hosts at least 30% of all domain names in
-Europe, and around 90% of all DNSSEC domains in Europe.
+implementation, hosting the majority of all DNSSEC domains worldwide. The
+Authoritative Server hosts at least 30% of all domain names in Europe, and
+around 90% of all DNSSEC domains in Europe.
* IPv4, UDP/TCP
* IPv6, UDP/TCP, 100% compliant
@@ -31,4 +30,4 @@ Europe, and around 90% of all DNSSEC domains in Europe.
* API for direct control (pdns_control, pdnssec)
- Local and remote access
-WWW: https://www.PowerDNS.com/auth.html
+WWW: https://www.powerdns.com/auth.html
diff --git a/dns/powerdns/pkg-plist b/dns/powerdns/pkg-plist
index a1c95264ef94..03c1ed3fc114 100644
--- a/dns/powerdns/pkg-plist
+++ b/dns/powerdns/pkg-plist
@@ -75,6 +75,8 @@ man/man1/zone2sql.1.gz
%%MYSQL%%%%PORTDOCS%%%%DOCSDIR%%/4.2.0_to_4.3.0_schema.mysql.sql
%%PGSQL%%%%PORTDOCS%%%%DOCSDIR%%/4.2.0_to_4.3.0_schema.pgsql.sql
%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/4.2.0_to_4.3.0_schema.sqlite3.sql
+%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/bind-dnssec.4.2.0_to_4.3.0_schema.sqlite3.sql
+%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/bind-dnssec.schema.sqlite3.sql
%%MYSQL%%%%PORTDOCS%%%%DOCSDIR%%/dnssec-3.x_to_3.4.0_schema.mysql.sql
%%PGSQL%%%%PORTDOCS%%%%DOCSDIR%%/dnssec-3.x_to_3.4.0_schema.pgsql.sql
%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/dnssec-3.x_to_3.4.0_schema.sqlite3.sql