aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-12-11 05:26:39 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-12-11 05:26:39 +0000
commitb6450d4ca70121f6e8fb4c91de9eae9b6c94cd43 (patch)
treef5a000db9f0e619637a2579179a2d471d62b1c7e
parentb1c17841e92850da1d98f87385f9013694ac5d6e (diff)
downloadports-b6450d4ca70121f6e8fb4c91de9eae9b6c94cd43.tar.gz
ports-b6450d4ca70121f6e8fb4c91de9eae9b6c94cd43.zip
Notes
-rw-r--r--databases/libmemcached/Makefile51
-rw-r--r--databases/libmemcached/distinfo4
-rw-r--r--databases/libmemcached/files/patch-bug124556238
-rw-r--r--databases/libmemcached/files/patch-bug140056029
-rw-r--r--databases/libmemcached/files/patch-libmemcached_assert.hpp13
-rw-r--r--databases/libmemcached/files/patch-libtest_lite.h13
-rw-r--r--databases/libmemcached/pkg-descr2
-rw-r--r--databases/libmemcached/pkg-plist9
-rw-r--r--databases/p5-Cache-Memcached-libmemcached/Makefile2
-rw-r--r--databases/pecl-memcached/Makefile2
-rw-r--r--databases/pgpool-II-33/Makefile1
-rw-r--r--databases/py-pylibmc/Makefile1
-rw-r--r--databases/rubygem-memcache/Makefile1
-rw-r--r--devel/gearmand-devel/Makefile2
-rw-r--r--devel/gearmand/Makefile2
-rw-r--r--devel/pecl-memoize/Makefile1
-rw-r--r--devel/php-memoize/Makefile2
-rw-r--r--ftp/proftpd/Makefile2
-rw-r--r--mail/opendkim/Makefile2
-rw-r--r--net-mgmt/collectd/Makefile2
-rw-r--r--net-mgmt/collectd5/Makefile2
-rw-r--r--net-mgmt/nagios-check_memcached_paranoid/Makefile2
-rw-r--r--net/yaz/Makefile1
-rw-r--r--security/razorback-dispatcher/Makefile2
-rw-r--r--www/mod_memcache_block/Makefile1
25 files changed, 160 insertions, 27 deletions
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index cd134bbd7aae..8e342cfac1c6 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -1,31 +1,60 @@
# $FreeBSD$
PORTNAME= libmemcached
-PORTVERSION= 1.0.7
-PORTREVISION= 4
+PORTVERSION= 1.0.18
CATEGORIES= databases
MASTER_SITES= http://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= C and C++ client library to the memcached server
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS?= libevent.so:${PORTSDIR}/devel/libevent2
+TEST_DEPENDS= memcached:${PORTSDIR}/databases/memcached
-USES= execinfo gmake pathfix pkgconfig perl5 libtool
-USE_PERL5= build
+USES= autoreconf execinfo gmake pathfix pkgconfig libtool
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-memcached
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lexecinfo"
-CXXFLAGS+= -D__STDC_CONSTANT_MACROS
+CONFIGURE_ARGS= --without-memcached \
+ --enable-libmemcachedprotocol
-OPTIONS_DEFINE= SASL
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+CXXFLAGS+= -D__STDC_CONSTANT_MACROS
+OPTIONS_DEFINE= DEBUG DTRACE MEMASLAP SASL
+OPTIONS_DEFAULT= MEMASLAP SASL MURMUR FNV64
+OPTIONS_GROUP= HASH
+OPTIONS_GROUP_HASH= FNV64 HSIEH MURMUR
+
+DTRACE_DESC= Enable DTrace support
+MEMASLAP_DESC= Load generation and benchmark tool
+FNV64_DESC= Enable fnv64 hashing
+HSIEH_DESC= Enable hsieh hashing
+MURMUR_DESC= Enable murmur hashing
+
+DEBUG_CONFIGURE_ENABLE= debug
+DTRACE_CONFIGURE_ENABLE= dtrace
+MEMASLAP_CONFIGURE_ENABLE= memaslap
+FNV64_CONFIGURE_ENABLE= fnv64_hash
+HSIEH_CONFIGURE_ENABLE= hsieh_hash
+MURMUR_CONFIGURE_ENABLE= murmur_hash
+
+SASL_CONFIGURE_ENABLE= sasl
SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+PATHFIX_MAKEFILEIN= include.am
+
post-patch:
- @${REINPLACE_CMD} -e 's|^pkgconfigdir.*|pkgconfigdir = $${PREFIX}/libdata/pkgconfig|' \
- -e '/^LDFLAGS *=/ s/$$/ $${LTLIBSASL2}/' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/support/include.am
+ @${REINPLACE_CMD} -e '/^LDFLAGS *=/ s/$$/ $${LTLIBSASL2}/' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so.*
+
+regression-test: build
+ @cd ${WRKSRC} && ${GMAKE} check
.include <bsd.port.mk>
diff --git a/databases/libmemcached/distinfo b/databases/libmemcached/distinfo
index 0232fedddf33..240b9b4527c6 100644
--- a/databases/libmemcached/distinfo
+++ b/databases/libmemcached/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libmemcached-1.0.7.tar.gz) = 3efa86c9733eaad55d7119cb16769424e2aa6c22b3392e8f973946fce6678d81
-SIZE (libmemcached-1.0.7.tar.gz) = 1077060
+SHA256 (libmemcached-1.0.18.tar.gz) = e22c0bb032fde08f53de9ffbc5a128233041d9f33b5de022c0978a2149885f82
+SIZE (libmemcached-1.0.18.tar.gz) = 1039649
diff --git a/databases/libmemcached/files/patch-bug1245562 b/databases/libmemcached/files/patch-bug1245562
new file mode 100644
index 000000000000..a0b146e5b72e
--- /dev/null
+++ b/databases/libmemcached/files/patch-bug1245562
@@ -0,0 +1,38 @@
+diff --git a/clients/memflush.cc b/clients/memflush.cc
+index 8bd0dbf..cdba743 100644
+--- clients/memflush.cc
++++ clients/memflush.cc
+@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
+ {
+ options_parse(argc, argv);
+
+- if (opt_servers == false)
++ if (opt_servers == NULL)
+ {
+ char *temp;
+
+@@ -48,7 +48,7 @@ int main(int argc, char *argv[])
+ opt_servers= strdup(temp);
+ }
+
+- if (opt_servers == false)
++ if (opt_servers == NULL)
+ {
+ std::cerr << "No Servers provided" << std::endl;
+ exit(EXIT_FAILURE);
+diff --git a/libmemcached-1.0/memcached.h b/libmemcached-1.0/memcached.h
+index bc16e73..dcee395 100644
+--- libmemcached-1.0/memcached.h
++++ libmemcached-1.0/memcached.h
+@@ -43,7 +43,11 @@
+ #endif
+
+ #ifdef __cplusplus
++#ifdef _LIBCPP_VERSION
+ # include <cinttypes>
++#else
++# include <tr1/cinttypes>
++#endif
+ # include <cstddef>
+ # include <cstdlib>
+ #else
diff --git a/databases/libmemcached/files/patch-bug1400560 b/databases/libmemcached/files/patch-bug1400560
new file mode 100644
index 000000000000..6dbab3180a3e
--- /dev/null
+++ b/databases/libmemcached/files/patch-bug1400560
@@ -0,0 +1,29 @@
+Fixed a bug that caused configure to disobey the enable/disable debug flag. The debug flag will default to disabled if not specified.
+diff -ru libmemcached-1.0.18-orig/m4/ax_debug.m4 libmemcached-1.0.18/m4/ax_debug.m4
+--- m4/ax_debug.m4 2014-11-05 14:43:53.720284916 -0600
++++ m4/ax_debug.m4 2014-11-19 14:23:19.512482198 -0600
+@@ -49,16 +49,18 @@
+ [AC_PREREQ([2.63])dnl
+ AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+- [Add debug code/turns off optimizations (yes|no) @<:@default=no@:>@])],
+- [ax_enable_debug=yes
++ [Add debug code/turns off optimizations (yes|no) @<:@default=no@:>@])])
++ AS_IF([test "x$enable_debug" = "xyes"], [
++ ax_enable_debug=yes
+ AC_DEFINE([DEBUG],[1],[Define to 1 to enable debugging code.])
+ AX_CHECK_LIBRARY([MCHECK],[mcheck.h],[mcheck],[AX_APPEND_LINK_FLAGS([-lmcheck])])
+ AX_ADD_AM_MACRO([--debug],[AM_YFLAGS])
+- AX_ADD_AM_MACRO([-D_GLIBCXX_DEBUG],[AM_CPPFLAGS])],
+- [ax_enable_debug=no
++ AX_ADD_AM_MACRO([-D_GLIBCXX_DEBUG],[AM_CPPFLAGS])
++ ], [
++ ax_enable_debug=no
+ AC_SUBST([MCHECK])
+- AC_DEFINE([DEBUG],[0],[Define to 1 to enable debugging code.])])
+-
++ AC_DEFINE([DEBUG],[0],[Define to 1 to enable debugging code.])
++ ])
+ AC_MSG_CHECKING([for debug])
+ AC_MSG_RESULT([$ax_enable_debug])
+ AM_CONDITIONAL([DEBUG],[test "x${ax_enable_debug}" = "xyes"])])
diff --git a/databases/libmemcached/files/patch-libmemcached_assert.hpp b/databases/libmemcached/files/patch-libmemcached_assert.hpp
new file mode 100644
index 000000000000..83a464c748e3
--- /dev/null
+++ b/databases/libmemcached/files/patch-libmemcached_assert.hpp
@@ -0,0 +1,13 @@
+--- libmemcached/assert.hpp.orig 2014-12-10 05:16:11 UTC
++++ libmemcached/assert.hpp
+@@ -51,8 +51,10 @@
+ # ifdef _WIN32
+ # include <malloc.h>
+ # else
++#ifdef HAVE_ALLOCA_H
+ # include <alloca.h>
+ # endif
++# endif
+
+ #ifdef __cplusplus
+ # include <cstdarg>
diff --git a/databases/libmemcached/files/patch-libtest_lite.h b/databases/libmemcached/files/patch-libtest_lite.h
new file mode 100644
index 000000000000..01a2641c3ea1
--- /dev/null
+++ b/databases/libmemcached/files/patch-libtest_lite.h
@@ -0,0 +1,13 @@
+--- libtest/lite.h.orig 2014-12-09 03:34:21 UTC
++++ libtest/lite.h
+@@ -54,8 +54,10 @@
+ #if defined(WIN32)
+ # include <malloc.h>
+ #else
++#ifdef HAVE_ALLOCA_H
+ # include <alloca.h>
+ #endif
++#endif
+
+ #ifndef __PRETTY_FUNCTION__
+ # define __PRETTY_FUNCTION__ __func__
diff --git a/databases/libmemcached/pkg-descr b/databases/libmemcached/pkg-descr
index 47bd9c83467c..60077900c936 100644
--- a/databases/libmemcached/pkg-descr
+++ b/databases/libmemcached/pkg-descr
@@ -20,4 +20,4 @@ memcp - Copy files to a memached server.
memstat - Dump the stats of your servers to standard output
memslap - Generate testing loads on a memcached cluster
-WWW: http://tangent.org/552/libmemcached.html
+WWW: http://libmemcached.org
diff --git a/databases/libmemcached/pkg-plist b/databases/libmemcached/pkg-plist
index 660d6e49d371..bade4cfa1585 100644
--- a/databases/libmemcached/pkg-plist
+++ b/databases/libmemcached/pkg-plist
@@ -103,8 +103,8 @@ lib/libhashkit.so.2
lib/libhashkit.so.2.0.0
lib/libmemcached.a
lib/libmemcached.so
-lib/libmemcached.so.10
-lib/libmemcached.so.10.0.0
+lib/libmemcached.so.11
+lib/libmemcached.so.11.0.0
lib/libmemcachedprotocol.a
lib/libmemcachedprotocol.so
lib/libmemcachedprotocol.so.0
@@ -120,10 +120,14 @@ man/man1/memcat.1.gz
man/man1/memcp.1.gz
man/man1/memdump.1.gz
man/man1/memerror.1.gz
+man/man1/memexist.1.gz
man/man1/memflush.1.gz
+man/man1/memparse.1.gz
+man/man1/memping.1.gz
man/man1/memrm.1.gz
man/man1/memslap.1.gz
man/man1/memstat.1.gz
+man/man1/memtouch.1.gz
man/man3/hashkit_clone.3.gz
man/man3/hashkit_crc32.3.gz
man/man3/hashkit_create.3.gz
@@ -227,3 +231,4 @@ man/man3/memcached_touch.3.gz
man/man3/memcached_touch_by_key.3.gz
man/man3/memcached_verbosity.3.gz
man/man3/memcached_version.3.gz
+share/aclocal/ax_libmemcached.m4
diff --git a/databases/p5-Cache-Memcached-libmemcached/Makefile b/databases/p5-Cache-Memcached-libmemcached/Makefile
index 0c0cb4de8133..d00b9770426e 100644
--- a/databases/p5-Cache-Memcached-libmemcached/Makefile
+++ b/databases/p5-Cache-Memcached-libmemcached/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Cache-Memcached-libmemcached
PORTVERSION= 0.02011
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:DMAKI
diff --git a/databases/pecl-memcached/Makefile b/databases/pecl-memcached/Makefile
index cbcc407f21e7..5c8f5dd6d5e6 100644
--- a/databases/pecl-memcached/Makefile
+++ b/databases/pecl-memcached/Makefile
@@ -3,7 +3,7 @@
PORTNAME= memcached
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/databases/pgpool-II-33/Makefile b/databases/pgpool-II-33/Makefile
index a610268b26b6..036f807a56d2 100644
--- a/databases/pgpool-II-33/Makefile
+++ b/databases/pgpool-II-33/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pgpool-II
PORTVERSION= 3.3.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.pgpool.net/mediawiki/images/ \
LOCAL/matthew/${PORTNAME}
diff --git a/databases/py-pylibmc/Makefile b/databases/py-pylibmc/Makefile
index 592cd5524db4..f4e2b95c040d 100644
--- a/databases/py-pylibmc/Makefile
+++ b/databases/py-pylibmc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pylibmc
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/rubygem-memcache/Makefile b/databases/rubygem-memcache/Makefile
index 72f7c02e3280..5da32d4ac82e 100644
--- a/databases/rubygem-memcache/Makefile
+++ b/databases/rubygem-memcache/Makefile
@@ -3,6 +3,7 @@
PORTNAME= memcache
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
diff --git a/devel/gearmand-devel/Makefile b/devel/gearmand-devel/Makefile
index 314cc7452a0b..395c0bfdebfa 100644
--- a/devel/gearmand-devel/Makefile
+++ b/devel/gearmand-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gearmand
PORTVERSION= 1.1.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://launchpad.net/gearmand/1.2/${PORTVERSION}/+download/
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 98e8c93c7270..2a7aad4f123b 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gearmand
PORTVERSION= 1.0.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= http://launchpad.net/gearmand/1.0/${PORTVERSION}/+download/
diff --git a/devel/pecl-memoize/Makefile b/devel/pecl-memoize/Makefile
index 550f210cbdfb..4c2f9690a5fc 100644
--- a/devel/pecl-memoize/Makefile
+++ b/devel/pecl-memoize/Makefile
@@ -3,6 +3,7 @@
PORTNAME= memoize
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/devel/php-memoize/Makefile b/devel/php-memoize/Makefile
index 54a819597286..187172141a84 100644
--- a/devel/php-memoize/Makefile
+++ b/devel/php-memoize/Makefile
@@ -3,7 +3,7 @@
PORTNAME= memoize
PORTVERSION= 0.2.0b1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
PKGNAMEPREFIX= php-
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index e99485b9c2ef..6c23533612b4 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -5,7 +5,7 @@ PORTNAME?= proftpd
.if !defined(DISTVERSION)
PORTVERSION?= ${PROFTPD_VERSION}
.endif
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
https://github.com/downloads/proftpd/proftpd.github.com/ \
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 75639b86eb68..450e0bcbb178 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opendkim
PORTVERSION= 2.9.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME} \
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 65f95aefe537..d6551ffe40f2 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 4.10.9
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 986f1d175794..639fda33d616 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 5.4.1
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
PKGNAMESUFFIX= 5
diff --git a/net-mgmt/nagios-check_memcached_paranoid/Makefile b/net-mgmt/nagios-check_memcached_paranoid/Makefile
index 252fb44e7fe1..7fc14ff91313 100644
--- a/net-mgmt/nagios-check_memcached_paranoid/Makefile
+++ b/net-mgmt/nagios-check_memcached_paranoid/Makefile
@@ -2,7 +2,7 @@
PORTNAME= check_memcached_paranoid
PORTVERSION= 0.20131004
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/nagiosplug/nagiosplug/1.5
DISTFILES= nagios-plugins-1.5.tar.gz
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index c5095161067a..c748c8d9b0af 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -3,6 +3,7 @@
PORTNAME= yaz
PORTVERSION= 5.7.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.indexdata.dk/pub/yaz/
diff --git a/security/razorback-dispatcher/Makefile b/security/razorback-dispatcher/Makefile
index 665e5f87c8ea..bf062c18738d 100644
--- a/security/razorback-dispatcher/Makefile
+++ b/security/razorback-dispatcher/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dispatcher
PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Dispatcher
PKGNAMEPREFIX= razorback-
diff --git a/www/mod_memcache_block/Makefile b/www/mod_memcache_block/Makefile
index 7062f5ef252a..8efe96a2111f 100644
--- a/www/mod_memcache_block/Makefile
+++ b/www/mod_memcache_block/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mod_memcache_block
PORTVERSION= 20120821
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://github.com/netik/mod_memcache_block/tarball/${GITVERSION}/
DISTNAME= mod_memcache_block-${GITVERSION}