aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-02-18 22:19:06 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-02-18 22:19:06 +0000
commitbacfa148370d53331c435a70f96058248f41a401 (patch)
treefa45dbd614a4fff760fab0d59adb03e16f0bfa27
parent283351f1dff387fa02636183c058efc5991bf2bd (diff)
LaTrine is a curses-based LAnguage TRaINEr. It takes a dictionary and
asks you for a word or a phrase, and you try to give the correct answer. You can choose in what direction LaTrine shall ask, and the selection of the words or phrases will depend on how often you don't know the correct translation for the respective phrase. This is a conventional way to drill yourself in vocabulary. In addition to this package you need an appropriate dictionary. You may write your own word list, or you can download one from the internet. The Free Dictionaries Project provides dictionaries for about 50 language combinations, which can be used with LaTrine. WWW: http://www.godisch.de/debian/latrine/ Approved by: miwi (mentor, implicit)
Notes
Notes: svn path=/head/; revision=185477
-rw-r--r--games/Makefile1
-rw-r--r--games/latrine/Makefile35
-rw-r--r--games/latrine/distinfo3
-rw-r--r--games/latrine/files/patch-Makefile.in23
-rw-r--r--games/latrine/files/patch-data.h9
-rw-r--r--games/latrine/pkg-descr12
-rw-r--r--games/latrine/pkg-plist11
7 files changed, 94 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 3952b9219b6e..c8d4ddba5cfc 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -384,6 +384,7 @@
SUBDIR += kwappen
SUBDIR += ladder
SUBDIR += lapispuzzle
+ SUBDIR += latrine
SUBDIR += lbreakout
SUBDIR += lbreakout2
SUBDIR += ldmud
diff --git a/games/latrine/Makefile b/games/latrine/Makefile
new file mode 100644
index 000000000000..752500575aa3
--- /dev/null
+++ b/games/latrine/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: latrine
+# Date created: Sun Feb 18 01:13:42 CET 2007
+# Whom: Juergen Lock <nox@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latrine
+PORTVERSION= 0.9.0
+CATEGORIES= games
+MASTER_SITES= http://www.godisch.de/debian/latrine/
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Curses-based LAnguage TRaINEr
+
+LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= "CFLAGS=-I${LOCALBASE}/include -I${WRKDIR} -D_XOPEN_SOURCE_EXTENDED" LDFLAGS=-L${LOCALBASE}/lib --mandir=${PREFIX}/man
+USE_GMAKE= yes
+USE_GETTEXT= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+MAN1= latrine.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 503000
+IGNORE= needs libcursesw which doesnt work on this OSVERSION
+.endif
+
+post-extract:
+ ${MKDIR} ${WRKDIR}/ncursesw
+ ${LN} -s ${LOCALBASE}/include/ncurses/ncurses.h ${WRKDIR}/ncursesw/ncurses.h
+
+.include <bsd.port.post.mk>
diff --git a/games/latrine/distinfo b/games/latrine/distinfo
new file mode 100644
index 000000000000..3aca762249b5
--- /dev/null
+++ b/games/latrine/distinfo
@@ -0,0 +1,3 @@
+MD5 (latrine-0.9.0.tar.gz) = 348dee815cf34ddb1335de97e47f9a83
+SHA256 (latrine-0.9.0.tar.gz) = 4c63010daf8ea00d44e7004b052f859a946ce0f90cce4e91427eca8cb44f4b06
+SIZE (latrine-0.9.0.tar.gz) = 106957
diff --git a/games/latrine/files/patch-Makefile.in b/games/latrine/files/patch-Makefile.in
new file mode 100644
index 000000000000..83cdcd7adc3e
--- /dev/null
+++ b/games/latrine/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+Index: Makefile.in
+@@ -12,7 +12,7 @@
+ CPPFLAGS = -I. -DSYSCONFFILE=\"${sysconfdir}/latrine.conf\" -DDICTDIR=\"${dictdir}\" -DLOCALEDIR=\"${localedir}\" @CPPFLAGS@
+ CFLAGS = -Wall -funroll-loops @CFLAGS@ @GLIB_CFLAGS@
+ LDFLAGS = -Wall @LDFLAGS@
+-LDLIBS = @LIBS@ @GLIB_LIBS@
++LDLIBS = @LIBS@ @GLIB_LIBS@ -lintl
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+@@ -41,10 +41,10 @@
+ ${INSTALL} -d ${DESTDIR}${localedir}/`basename $$i .mo`/LC_MESSAGES; \
+ ${INSTALL_DATA} $$i ${DESTDIR}${localedir}/`basename $$i .mo`/LC_MESSAGES/latrine.mo; \
+ done
+- ${INSTALL} -d ${DESTDIR}${dictdir}
++# ${INSTALL} -d ${DESTDIR}${dictdir}
+ # ${INSTALL_DATA} ${KEYMAPS} ${DESTDIR}${dictdir}
+ ${INSTALL} -d ${DESTDIR}${sysconfdir}
+- test -e ${DESTDIR}${sysconfdir}/latrine.conf || ${INSTALL_DATA} latrine.conf ${DESTDIR}${sysconfdir}
++ ${INSTALL_DATA} latrine.conf ${DESTDIR}${sysconfdir}/latrine.conf.sample
+
+ clean:
+ ${RM} config.status configure.scan config.status core latrine.dvi *.log *.o *~
diff --git a/games/latrine/files/patch-data.h b/games/latrine/files/patch-data.h
new file mode 100644
index 000000000000..9f1625d36d14
--- /dev/null
+++ b/games/latrine/files/patch-data.h
@@ -0,0 +1,9 @@
+Index: data.h
+@@ -19,6 +19,7 @@
+ #define _DATA_H
+
+ #include <stdlib.h>
++#include <time.h>
+
+ #define DEFAULT_RANDCOUNT 10
+ #define DEFAULT_WORDLIMIT 1000
diff --git a/games/latrine/pkg-descr b/games/latrine/pkg-descr
new file mode 100644
index 000000000000..e4605487c1e5
--- /dev/null
+++ b/games/latrine/pkg-descr
@@ -0,0 +1,12 @@
+LaTrine is a curses-based LAnguage TRaINEr. It takes a dictionary and
+asks you for a word or a phrase, and you try to give the correct answer.
+You can choose in what direction LaTrine shall ask, and the selection of
+the words or phrases will depend on how often you don't know the correct
+translation for the respective phrase. This is a conventional way to drill
+yourself in vocabulary. In addition to this package you need an
+appropriate dictionary. You may write your own word list, or you can
+download one from the internet. The Free Dictionaries Project provides
+dictionaries for about 50 language combinations, which can be used with
+LaTrine.
+
+WWW: http://www.godisch.de/debian/latrine/
diff --git a/games/latrine/pkg-plist b/games/latrine/pkg-plist
new file mode 100644
index 000000000000..8d2b88f578d0
--- /dev/null
+++ b/games/latrine/pkg-plist
@@ -0,0 +1,11 @@
+bin/latrine
+share/locale/de/LC_MESSAGES/latrine.mo
+share/locale/fr/LC_MESSAGES/latrine.mo
+share/locale/ga/LC_MESSAGES/latrine.mo
+share/locale/it/LC_MESSAGES/latrine.mo
+share/locale/nl/LC_MESSAGES/latrine.mo
+share/locale/ro/LC_MESSAGES/latrine.mo
+share/locale/sv/LC_MESSAGES/latrine.mo
+share/locale/tr/LC_MESSAGES/latrine.mo
+share/locale/vi/LC_MESSAGES/latrine.mo
+etc/latrine.conf.sample