aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-09 21:49:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-09 21:49:35 +0000
commitbad37a6cd4b811ce01dd9f0064fd020df161bc43 (patch)
tree496c722222b746ec4b7d8e984d2c9c4c053e3fbc
parent2c80774ea9e44f876b9af2e57eb6518e34b048e6 (diff)
downloadports-bad37a6cd4b811ce01dd9f0064fd020df161bc43.tar.gz
ports-bad37a6cd4b811ce01dd9f0064fd020df161bc43.zip
Notes
-rw-r--r--biology/embassy/Makefile4
-rw-r--r--biology/emboss/Makefile5
-rw-r--r--biology/ncbi-toolkit/Makefile2
-rw-r--r--cad/alliance/Makefile6
-rw-r--r--cad/dinotrace/Makefile11
-rw-r--r--cad/electric/Makefile3
-rw-r--r--cad/mars/Makefile6
-rw-r--r--cad/pcb/Makefile4
-rw-r--r--comms/twpsk/Makefile10
-rw-r--r--comms/xastir/Makefile4
10 files changed, 19 insertions, 36 deletions
diff --git a/biology/embassy/Makefile b/biology/embassy/Makefile
index b8218b976aeb..282860cda02b 100644
--- a/biology/embassy/Makefile
+++ b/biology/embassy/Makefile
@@ -16,11 +16,9 @@ LIB_DEPENDS= nucleus.6:${PORTSDIR}/biology/emboss
PREFIX?= ${LOCALBASE}/emboss
NO_MTREE= yes
USE_SUBMAKE= yes
-USES= iconv
-USE_GMAKE= yes
+USES= iconv gmake motif
GNU_CONFIGURE= yes
USE_XORG= x11
-USE_MOTIF= yes
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOMAINATRIX DOMALIGN DOMSEARCH SIGNATURE STRUCTURE \
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index 1961199591ba..d1dc391d2975 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -22,12 +22,11 @@ CONFLICTS= qmail-ldap-[0-9]* digest-[0-9]*
PREFIX?= ${LOCALBASE}/emboss
NO_MTREE= yes
+USES= gmake
USE_SUBMAKE= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USE_MOTIF= yes
SUB_FILES= pkg-message
SUB_LIST= PREFIX=${PREFIX} DATADIR=${DATADIR}
@@ -38,7 +37,7 @@ CONFIGURE_ARGS+= --with-docroot=${DOCSDIR}
.if !defined(WITHOUT_X11)
USE_XORG= x11
-USE_MOTIF= yes
+USES+= motif
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd \
png15:${PORTSDIR}/graphics/png
.else
diff --git a/biology/ncbi-toolkit/Makefile b/biology/ncbi-toolkit/Makefile
index 3c1ef4e2cf66..f829f790b278 100644
--- a/biology/ncbi-toolkit/Makefile
+++ b/biology/ncbi-toolkit/Makefile
@@ -13,7 +13,7 @@ COMMENT= NCBI development toolkit, including BLAST 2 and GenBank/Entrez support
OPTIONS_DEFINE= DOCS
-USE_MOTIF= yes
+USES= motif
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index 9d11db4774f9..09a5f216209a 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -11,7 +11,7 @@ MASTER_SITE_SUBDIR= hrs
DISTNAME= ${PORTNAME}-5.0-20090901
MAINTAINER= hrs@FreeBSD.org
-COMMENT= A complete set of CAD tools and libraries for VLSI design
+COMMENT= Complete set of CAD tools and libraries for VLSI design
NOT_FOR_ARCHS= amd64 ia64 powerpc sparc64
NOT_FOR_ARCHS_REASON= ${PKGNAME} does not build on ${ARCH}
@@ -20,9 +20,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-5.0
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-USES= bison
-USE_GMAKE= yes
-USE_MOTIF= yes
+USES= bison gmake motif
HAS_CONFIGURE= yes
CONFIGURE_ENV+= ALLIANCE_TOP=${ALLIANCE_TOP}
diff --git a/cad/dinotrace/Makefile b/cad/dinotrace/Makefile
index dbe693aa70e1..67e99d4e3dfc 100644
--- a/cad/dinotrace/Makefile
+++ b/cad/dinotrace/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dinotrace
-# Date created: July 05, 2004
-# Whom: Joachim Strombergson <watchman@ludd.ltu.se>
-#
+# Created by: Joachim Strombergson <watchman@ludd.ltu.se>
# $FreeBSD$
-#
PORTNAME= dinotrace
PORTVERSION= 9.4c
@@ -13,16 +9,15 @@ MASTER_SITES= http://www.veripool.org/ftp/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A graphical signal trace waveform viewer
+COMMENT= Graphical signal trace waveform viewer
OPTIONS_DEFINE= EMACS
OPTIONS_DEFAULT= EMACS
EMACS_DESC= Install Emacs supplimentary files
USE_XORG= x11 sm ice xmu xt
-USE_MOTIF= yes
+USES= gmake motif
USE_PERL5_BUILD= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/cad/electric/Makefile b/cad/electric/Makefile
index 01e3a8a4c25e..2e2ffb3508ce 100644
--- a/cad/electric/Makefile
+++ b/cad/electric/Makefile
@@ -18,9 +18,10 @@ OPTIONS_DEFINE= T1LIB NLS OPTIMIZED_CFLAGS
OPTIONS_DEFAULT= T1LIB
T1LIB_DESC= Use T1lib Type1 font library
+USES= motif
+
.include <bsd.port.options.mk>
-USE_MOTIF= yes
FEATURES+= MOTIF
.if ${PORT_OPTIONS:MT1LIB}
diff --git a/cad/mars/Makefile b/cad/mars/Makefile
index cc9d9947696f..b50fc2ec472a 100644
--- a/cad/mars/Makefile
+++ b/cad/mars/Makefile
@@ -1,6 +1,4 @@
-# Ports collection makefile for: MaRS
-# Date created: Mon Nov 18, 1996
-# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+# Created by: David O'Brien <obrien@cs.ucdavis.edu>
#
# $FreeBSD$
#
@@ -28,7 +26,7 @@ NO_WRKSUBDIR= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-USE_MOTIF= yes
+USES+= motif
MAKEFILE= Makefile.XMotif
.else
MAKEFILE= Makefile.NoX
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index b762bcf49c82..73a388248880 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= m4>=1.4.11:${PORTSDIR}/devel/m4 \
BUILD_DEPENDS:= ${RUN_DEPENDS}
USE_AUTOTOOLS= autoconf
-USE_GMAKE= yes
+USES= gmake
USE_TK_RUN= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
@@ -64,7 +64,7 @@ CONFIGURE_ARGS+= \
CONFIGURE_ARGS+= --without-gui
CONFIGURE_ENV+= WISH=${TRUE}
.elif ${PORT_OPTIONS:MMOTIF}
-USE_MOTIF= yes
+USES+= motif
USE_TK_RUN= yes
CONFIGURE_ARGS+= --with-gui=lesstif
CONFIGURE_ENV+= WISH=${WISH}
diff --git a/comms/twpsk/Makefile b/comms/twpsk/Makefile
index c2c042fc6945..ecf60a004830 100644
--- a/comms/twpsk/Makefile
+++ b/comms/twpsk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: twpsk
-# Date created: 2005-05-27
-# Whom: Søren Straarup <xride@x12.dk>
-#
+# Created by: Søren Straarup <xride@x12.dk>
# $FreeBSD$
-#
PORTNAME= twpsk
PORTVERSION= 2.1
@@ -12,10 +8,10 @@ CATEGORIES= comms hamradio
MASTER_SITES= http://www.ibiblio.org/pub/linux/apps/ham/
MAINTAINER= xride@FreeBSD.org
-COMMENT= A openmotif X psk31 client
+COMMENT= Openmotif X psk31 client
USE_XORG= xpm
-USE_MOTIF= yes
+USES= motif
MAN1= psk31.1
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 486761cfa522..c0445648e600 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -17,9 +17,7 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
png15:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_MOTIF= yes
-USES= gettext
+USES= gettext gmake motif
MAKE_JOBS_SAFE= yes
MAN1= xastir.1 \