aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-01-28 22:20:24 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-01-28 22:20:24 +0000
commitbc310a80f5f57d43b968f2c473fe9a9be6029c62 (patch)
treecd0257741f7f32a9de3cfc7826549efbfe50ef74
parentc063d17f65c3ad87992093308de41c582cd5e17e (diff)
Notes
-rw-r--r--mail/sqwebmail/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 5489b38c9bc6..47a710507c7f 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -54,12 +54,14 @@ CACHEOWNER?= bin
# set WITHOUT_SENTRENAME to turn off periodic renaming of the Sent folder
# set WITHOUT_IMAP if you don't use the Courier IMAP server
# set WITHOUT_GZIP for not using gzip to compress messages
+# set WITH_AUTOPURGE to something other than 7 days
+# set WITH_MAXPURGE to something other than 90 days
#
# The following settings are in bytes:
# set WITH_MAXMSGSIZE to max size of messages (including attachments)
# set WITH_MAXARGSIZE to max size of a text message (excluding attachments)
# set WITH_MAXFORMARGSIZE to max size of attachments
-#
+#
# set WITH_CHARSET=chset,chset,... to enable charsets.
# Set it to "all" will enable all unicode charset mappings.
# "iconv -l" may give you an idea of some usable character sets, although
@@ -164,6 +166,14 @@ CONFIGURE_ARGS+= --enable-unicode=${WITH_CHARSET}
.endif
.endif
+.if defined(WITH_AUTOPURGE)
+CONFIGURE_ARGS+= --enable-autopurge=${WITH_AUTOPURGE}
+.endif
+
+.if defined(WITH_MAXPURGE)
+CONFIGURE_ARGS+= --enable-maxpurge=${WITH_MAXPURGE}
+.endif
+
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAN1= maildirmake.1