aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-04-12 02:33:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-04-12 02:33:07 +0000
commitbd0c6d40cbac0bb54eade724f325e1fd12daca9e (patch)
treeaa5f5c6a2476e6dbd954eb74904ffd67c221c4da
parent7c80d0685453a132e52916e92cc844d7490d7d27 (diff)
downloadports-bd0c6d40cbac0bb54eade724f325e1fd12daca9e.tar.gz
ports-bd0c6d40cbac0bb54eade724f325e1fd12daca9e.zip
Notes
-rw-r--r--comms/Makefile1
-rw-r--r--comms/p5-SMS-Send-TW-Qma/Makefile26
-rw-r--r--comms/p5-SMS-Send-TW-Qma/distinfo2
-rw-r--r--comms/p5-SMS-Send-TW-Qma/pkg-descr4
-rw-r--r--comms/p5-SMS-Send-TW-Qma/pkg-plist9
5 files changed, 42 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index c471255f7837..c6654827c77f 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -99,6 +99,7 @@
SUBDIR += p5-SMS-Send-DeviceGsm
SUBDIR += p5-SMS-Send-TW-HiAir
SUBDIR += p5-SMS-Send-TW-PChome
+ SUBDIR += p5-SMS-Send-TW-Qma
SUBDIR += p5-SMS-Send-TW-ShareSMS
SUBDIR += p5-SMS-Send-TW-Socket2Air
SUBDIR += p5-SMS-Send-TW-chtsns
diff --git a/comms/p5-SMS-Send-TW-Qma/Makefile b/comms/p5-SMS-Send-TW-Qma/Makefile
new file mode 100644
index 000000000000..46799bb31758
--- /dev/null
+++ b/comms/p5-SMS-Send-TW-Qma/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-SMS-Send-TW-Qma
+# Date created: 2011-03-20
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SMS-Send-TW-Qma
+PORTVERSION= 0.01
+CATEGORIES= comms perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= SMS::Send driver for http://www.qma.com/
+
+RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
+ p5-Crypt-SSLeay>=0.57:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SMS::Send::TW::Qma.3
+
+.include <bsd.port.mk>
diff --git a/comms/p5-SMS-Send-TW-Qma/distinfo b/comms/p5-SMS-Send-TW-Qma/distinfo
new file mode 100644
index 000000000000..16b2c66ca8e3
--- /dev/null
+++ b/comms/p5-SMS-Send-TW-Qma/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SMS-Send-TW-Qma-0.01.tar.gz) = 371b1d12850646e973cbfc2828afc5b243d45b02db6bf57cb311d6639703b26a
+SIZE (SMS-Send-TW-Qma-0.01.tar.gz) = 3306
diff --git a/comms/p5-SMS-Send-TW-Qma/pkg-descr b/comms/p5-SMS-Send-TW-Qma/pkg-descr
new file mode 100644
index 000000000000..df3a74866f1e
--- /dev/null
+++ b/comms/p5-SMS-Send-TW-Qma/pkg-descr
@@ -0,0 +1,4 @@
+SMS::Send::TW::Qma is a SMS::Send driver
+which allows you to send messages through http://www.qma.com/.
+
+WWW: http://search.cpan.org/dist/SMS-Send-TW-Qma/
diff --git a/comms/p5-SMS-Send-TW-Qma/pkg-plist b/comms/p5-SMS-Send-TW-Qma/pkg-plist
new file mode 100644
index 000000000000..260c0df96e0e
--- /dev/null
+++ b/comms/p5-SMS-Send-TW-Qma/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/SMS/Send/TW/Qma.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS/Send/TW/Qma/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS/Send/TW/Qma
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS/Send/TW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS/Send
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SMS
+@dirrmtry %%SITE_PERL%%/SMS/Send/TW
+@dirrmtry %%SITE_PERL%%/SMS/Send
+@dirrmtry %%SITE_PERL%%/SMS