aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-12-12 10:31:36 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-12-12 10:31:36 +0000
commitc4addf954d1ac9a7929613cad6976844cda144a8 (patch)
treefc37760955cb91dc5a162b81fc509ea8d447bde8
parent33b73df602c457a53125c78602f634dcb8d8df59 (diff)
downloadports-c4addf954d1ac9a7929613cad6976844cda144a8.tar.gz
ports-c4addf954d1ac9a7929613cad6976844cda144a8.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/wmauda/Makefile35
-rw-r--r--audio/wmauda/distinfo3
-rw-r--r--audio/wmauda/pkg-descr3
4 files changed, 42 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8ed3875a75c3..f5e3dfd64e84 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -660,6 +660,7 @@
SUBDIR += wavplay
SUBDIR += whysynth
SUBDIR += wmalbum
+ SUBDIR += wmauda
SUBDIR += wmcdplay
SUBDIR += wmfmixer
SUBDIR += wmix
diff --git a/audio/wmauda/Makefile b/audio/wmauda/Makefile
new file mode 100644
index 000000000000..57d8742a98c4
--- /dev/null
+++ b/audio/wmauda/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: wmauda
+# Date created: 2007-10-30
+# Whom: Renato Botelho <garga@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmauda
+PORTVERSION= 0.4
+CATEGORIES= audio windowmaker
+MASTER_SITES= http://www.netswarm.net/misc/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= A port of wmxmms to GTK 2.x and Audacious
+
+RUN_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious
+
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gtk20
+CFLAGS= `pkg-config --cflags gtk+-2.0`
+MAKE_ENV= MANPAGE_DIR=${MAN1PREFIX}/man/man1 \
+ LIBS="`pkg-config --libs gtk+-2.0`"
+
+PLIST_FILES= bin/wmauda \
+ share/pixmaps/wmauda.xpm
+MAN1= wmauda.1
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(MANPAGE_DIR.*):=,\1\?=,; \
+ s,^(LIBS.*):=,\1\+=,' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,/usr/share/pixmaps,${PREFIX}/share/pixmaps,g' \
+ ${WRKSRC}/config.h
+
+.include <bsd.port.mk>
diff --git a/audio/wmauda/distinfo b/audio/wmauda/distinfo
new file mode 100644
index 000000000000..a823a4742b89
--- /dev/null
+++ b/audio/wmauda/distinfo
@@ -0,0 +1,3 @@
+MD5 (wmauda-0.4.tar.gz) = 2a4028cab4583ea908b2549b8dd74555
+SHA256 (wmauda-0.4.tar.gz) = dca633f22dcfa56cf6c21f04eb93524336e99c307f3bbd40d927f3741f622201
+SIZE (wmauda-0.4.tar.gz) = 18219
diff --git a/audio/wmauda/pkg-descr b/audio/wmauda/pkg-descr
new file mode 100644
index 000000000000..4ec14f679fd0
--- /dev/null
+++ b/audio/wmauda/pkg-descr
@@ -0,0 +1,3 @@
+Dockable applet for WindowMaker that controls Audacious.
+
+WWW: http://www.netswarm.net/