aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-22 23:21:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-22 23:21:02 +0000
commitc646c21ddb278fd0ccc7eae9fac364888830ea07 (patch)
tree20301ca185da413d71bad6ff1b229d64f6e56e68
parent4171d65e5ca599250fb3ba6807375287181ba940 (diff)
downloadports-c646c21ddb278fd0ccc7eae9fac364888830ea07.tar.gz
ports-c646c21ddb278fd0ccc7eae9fac364888830ea07.zip
MFH: r549625
misc/glow: Fix build on 13 Add the workaround for a bug in Glow that it uses the default C++ compiler when the supplied LLVM version is different. Reported by: fallout Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549644
-rw-r--r--misc/glow/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/misc/glow/Makefile b/misc/glow/Makefile
index 34e030e6270e..f020fb860c15 100644
--- a/misc/glow/Makefile
+++ b/misc/glow/Makefile
@@ -34,6 +34,7 @@ CMAKE_ARGS= -DFREEBSD_LLVM_VERSION:STRING=${LLVM_VER} -DGIT_SHA1:STRING="\"${GH_
CMAKE_OFF= GLOW_BUILD_EXAMPLES GLOW_BUILD_TESTS
BINARY_ALIAS= python=${PYTHON_CMD}
+BINARY_ALIAS+= c++=${LOCALBASE}/bin/clang++${LLVM_VER:S/.//} # workaround for the llvm version mixup: https://github.com/pytorch/glow/issues/4910
LLVM_VER= ${LLVM_DEFAULT:C/(.)(.)/\1.\2/}