aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-06-13 19:07:32 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-06-13 19:07:32 +0000
commitc65d9ed64d043b3bb3700cac045f29d1d1e9aeb8 (patch)
tree700796ace813c302d2eb42e5b5c62569e11c7044
parentb56038426af6131d9d3135990fb61f336eafdaa1 (diff)
- Use ${PREFIX} for markdown in patches
- While I'm here use SF macro PR: ports/124408 Submitted by: Tobias Rehbein <tobias.rehbein web.de> Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=214792
-rw-r--r--www/nanoblogger/Makefile11
-rw-r--r--www/nanoblogger/files/patch-plugins_entry_format_markdown_sh11
-rw-r--r--www/nanoblogger/files/patch-plugins_page_format_markdown_sh11
3 files changed, 29 insertions, 4 deletions
diff --git a/www/nanoblogger/Makefile b/www/nanoblogger/Makefile
index 13b10b5851b6..710c2ef4263e 100644
--- a/www/nanoblogger/Makefile
+++ b/www/nanoblogger/Makefile
@@ -8,10 +8,9 @@
PORTNAME= nanoblogger
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Small weblog engine written in Bash for the command line
@@ -24,13 +23,17 @@ SUB_FILES= pkg-message
post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/nb
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/plugins/entry/format/markdown.sh
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/plugins/page/format/markdown.sh
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nb ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/nb.conf ${PREFIX}/etc/nb.conf.sample
${MKDIR} ${DATADIR}
.for data in default lang lib moods plugins
- ${CP} -R ${WRKSRC}/${data} ${DATADIR}
+ ${MKDIR} ${DATADIR}/${data} && \
+ ( cd ${WRKSRC}/${data} && \
+ ${COPYTREE_SHARE} \* ${DATADIR}/${data} "! -name *.orig ! -name *.bak" )
.endfor
${CP} ${WRKSRC}/welcome-to-nb.txt ${DATADIR}
diff --git a/www/nanoblogger/files/patch-plugins_entry_format_markdown_sh b/www/nanoblogger/files/patch-plugins_entry_format_markdown_sh
new file mode 100644
index 000000000000..da31b0ddc2ee
--- /dev/null
+++ b/www/nanoblogger/files/patch-plugins_entry_format_markdown_sh
@@ -0,0 +1,11 @@
+--- plugins/entry/format/markdown.sh.orig 2005-11-03 08:21:22.000000000 +0100
++++ plugins/entry/format/markdown.sh 2008-06-12 11:22:45.000000000 +0200
+@@ -2,7 +2,7 @@
+ # Markdown is documented and implemented at
+ # <URL:http://daringfireball.net/projects/markdown/>
+
+-MARKDOWN="/usr/bin/markdown"
++MARKDOWN="%%PREFIX%%/bin/markdown"
+ MARKDOWN_OPTS=""
+
+ # nb_msg "$plugins_textformataction `basename $nb_plugin` ..."
diff --git a/www/nanoblogger/files/patch-plugins_page_format_markdown_sh b/www/nanoblogger/files/patch-plugins_page_format_markdown_sh
new file mode 100644
index 000000000000..443504f66cd7
--- /dev/null
+++ b/www/nanoblogger/files/patch-plugins_page_format_markdown_sh
@@ -0,0 +1,11 @@
+--- plugins/page/format/markdown.sh.orig 2005-11-09 23:45:03.000000000 +0100
++++ plugins/page/format/markdown.sh 2008-06-12 11:23:22.000000000 +0200
+@@ -2,7 +2,7 @@
+ # Markdown is documented and implemented at
+ # <URL:http://daringfireball.net/projects/markdown/>
+
+-MARKDOWN="/usr/bin/markdown"
++MARKDOWN="%%PREFIX%%/bin/markdown"
+ MARKDOWN_OPTS=""
+
+ nb_msg "$plugins_textformataction `basename $nb_plugin` ..."