aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2010-02-25 03:42:07 +0000
committerMikhail Teterin <mi@FreeBSD.org>2010-02-25 03:42:07 +0000
commitc985a88b309786f3daf03c054d5def6974e3cddf (patch)
tree23f7f49ea5e3adffbfc764beef59f76dfecee370
parenta11031480718cd08d40c1409054084ec8ab43176 (diff)
downloadports-c985a88b309786f3daf03c054d5def6974e3cddf.tar.gz
ports-c985a88b309786f3daf03c054d5def6974e3cddf.zip
Notes
-rw-r--r--www/websh/Makefile11
-rw-r--r--www/websh/files/shared-patch20
2 files changed, 0 insertions, 31 deletions
diff --git a/www/websh/Makefile b/www/websh/Makefile
index 5bd35309976b..e076868d22a1 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -17,9 +17,6 @@ COMMENT= Embeds a TCL8 interpreter in the Apache server
MAKE_JOBS_UNSAFE= yes
-OPTIONS= WSMDEBUG "memory(n) and checkmem(n) commands in web-scripts" on
-OPTIONS+= WSSTATIC "Link the objects into the module statically" off
-
TCL_DVER= ${TCL_VER:S/.//}
USE_TCL= 84+
@@ -88,14 +85,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if defined(WITH_WSMDEBUG)
-CFLAGS+= -DTCL_MEM_DEBUG
-.endif
-
-.if defined(WITHOUT_WSSTATIC)
-EXTRA_PATCHES= ${FILESDIR}/shared-patch
-.endif
-
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
.include <bsd.port.post.mk>
diff --git a/www/websh/files/shared-patch b/www/websh/files/shared-patch
deleted file mode 100644
index f4bb5365831c..000000000000
--- a/www/websh/files/shared-patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Link the module (and the executable - websh) dynamically with
--lwebsh84, instead of statically with all of the object files. This
-reduces the size of the module by a factor of 5.
-
- -mi
-
---- Makefile.in Sun Mar 5 11:58:37 2006
-+++ Makefile.in Thu Feb 8 19:37:14 2007
-@@ -256,9 +256,9 @@
-
- websh$(VERSION): tclAppInit.$(OBJEXT) $(web_OBJECTS)
-- $(CC) @LDFLAGS@ tclAppInit.$(OBJEXT) $(web_OBJECTS) \
-+ $(CC) @LDFLAGS@ tclAppInit.$(OBJEXT) $(web_LIB_FILE) \
- $(TCL_LIB_SPEC) $(TCL_LIBS) $(TCL_LD_FLAGS) -o websh$(VERSION)
-
- mod_websh$(MODULE_LIB_SUFFIX): $(web_ap_OBJECTS)
-- $(SHLIB_LD_CURRENT) -o mod_websh$(MODULE_LIB_SUFFIX) $(web_ap_OBJECTS) $(TCL_LIB_SPEC)
-+ $(SHLIB_LD_CURRENT) -o mod_websh$(MODULE_LIB_SUFFIX) $(web_OBJECTS_ap) $(web_LIB_FILE) $(TCL_LIB_SPEC)
-
- mod_websh$(UNSHARED_LIB_SUFFIX): $(web_ap_OBJECTS)