aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-09-23 02:35:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-09-23 02:35:09 +0000
commitcabd6ca96772ccac62e78775adad665544e58cdb (patch)
tree4deb42983595d7378aca5f9d20559715e1ca7b50
parentc910f2685859d8f550fca6dadeadc4712c65b1fc (diff)
downloadports-cabd6ca96772ccac62e78775adad665544e58cdb.tar.gz
ports-cabd6ca96772ccac62e78775adad665544e58cdb.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/stardict2/Makefile2
-rw-r--r--textproc/stardict3/Makefile23
-rw-r--r--textproc/stardict3/distinfo6
-rw-r--r--textproc/stardict3/files/patch-src::conf.cpp2
-rw-r--r--textproc/stardict3/files/patch-src::docklet.h11
-rw-r--r--textproc/stardict3/files/patch-src::mainwin.h29
-rw-r--r--textproc/stardict3/files/patch-src::stardict-application-server.cpp2
-rw-r--r--textproc/stardict3/pkg-plist158
9 files changed, 140 insertions, 94 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b2885af74300..b7079c3bb796 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1007,6 +1007,7 @@
SUBDIR += stardict2-dictd_mova
SUBDIR += stardict2-quick
SUBDIR += stardict2-rptts
+ SUBDIR += stardict3
SUBDIR += supercat
SUBDIR += sv-aspell
SUBDIR += svn2cl
diff --git a/textproc/stardict2/Makefile b/textproc/stardict2/Makefile
index dc29dbb1ca5e..1f8b12a39668 100644
--- a/textproc/stardict2/Makefile
+++ b/textproc/stardict2/Makefile
@@ -26,6 +26,8 @@ USE_GETTEXT= yes
OPTIONS= GNOMEUI "GNOME support" On
+CONFLICTS= stardict-3.[0-9]*
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_GNOMEUI)
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index dc29dbb1ca5e..4148088ef603 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -1,13 +1,12 @@
-# Ports collection makefile for: stardict2
-# Date created: 13 April 2003
-# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+# New ports collection makefile for: stardict3
+# Date created: 23 July 2008
+# Whom: eric
#
# $FreeBSD$
#
PORTNAME= stardict
-PORTVERSION= 2.4.8
-PORTREVISION= 7
+PORTVERSION= 3.0.1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,9 +15,15 @@ DIST_SUBDIR= stardict
MAINTAINER= delphij@FreeBSD.org
COMMENT= A cross-platform and international dictionary written in Gtk2
+LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
+ enchant.1:${PORTSDIR}/textproc/enchant
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-festival \
+ --disable-gucharmap \
+ --disable-espeak
USE_GMAKE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix
@@ -26,6 +31,8 @@ USE_GETTEXT= yes
OPTIONS= GNOMEUI "GNOME support" On
+CONFLICTS= stardict-2.[0-9]*
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_GNOMEUI)
@@ -41,12 +48,6 @@ PLIST_SUB= GNOME="@comment not installed: "
MAN1= stardict.1
-post-patch:
-# gcc 2.95 does not know std::string::clear()
- @${REINPLACE_CMD} -e 's|.clear()|.erase()|' \
- ${WRKSRC}/src/docklet.cpp ${WRKSRC}/src/floatwin.cpp \
- ${WRKSRC}/src/selection.cpp
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/textproc/stardict3/distinfo b/textproc/stardict3/distinfo
index 9f8f34c059b1..049f76e38749 100644
--- a/textproc/stardict3/distinfo
+++ b/textproc/stardict3/distinfo
@@ -1,3 +1,3 @@
-MD5 (stardict/stardict-2.4.8.tar.bz2) = 2f743d809737ca157bad71791c45ce63
-SHA256 (stardict/stardict-2.4.8.tar.bz2) = 160dd1dfe46ae0b9d44f9059a40eee71ff389be498aa4478355ff4640969680f
-SIZE (stardict/stardict-2.4.8.tar.bz2) = 1235020
+MD5 (stardict/stardict-3.0.1.tar.bz2) = 93bb2d7825bc9d52a4f9ba4c1c506d1d
+SHA256 (stardict/stardict-3.0.1.tar.bz2) = 504b3a7748933b9bd998cb85f37d4fa0a8575306643ffe6a9742450e66cd556f
+SIZE (stardict/stardict-3.0.1.tar.bz2) = 1964195
diff --git a/textproc/stardict3/files/patch-src::conf.cpp b/textproc/stardict3/files/patch-src::conf.cpp
index 1c6dd3846df6..376a3f747d7c 100644
--- a/textproc/stardict3/files/patch-src::conf.cpp
+++ b/textproc/stardict3/files/patch-src::conf.cpp
@@ -1,6 +1,6 @@
--- src/conf.cpp.orig Mon Jul 10 05:23:39 2006
+++ src/conf.cpp Mon Jul 10 05:24:36 2006
-@@ -93,7 +93,7 @@
+@@ -114,7 +114,7 @@
#ifdef _WIN32
add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("C:\\Program Files\\WyabdcRealPeopleTTS\nC:\\Program Files\\OtdRealPeopleTTS\nWyabdcRealPeopleTTS\nOtdRealPeopleTTS"));
#else
diff --git a/textproc/stardict3/files/patch-src::docklet.h b/textproc/stardict3/files/patch-src::docklet.h
deleted file mode 100644
index b2f7c9634b1b..000000000000
--- a/textproc/stardict3/files/patch-src::docklet.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/docklet.h.orig Tue Sep 23 18:19:44 2003
-+++ src/docklet.h Tue Jan 18 02:20:01 2005
-@@ -7,7 +7,7 @@
- enum DockLetIconType {
- DOCKLET_NORMAL_ICON,
- DOCKLET_SCAN_ICON,
-- DOCKLET_STOP_ICON,
-+ DOCKLET_STOP_ICON
- };
-
- class DockLet{
diff --git a/textproc/stardict3/files/patch-src::mainwin.h b/textproc/stardict3/files/patch-src::mainwin.h
deleted file mode 100644
index dd6f78474e14..000000000000
--- a/textproc/stardict3/files/patch-src::mainwin.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./src/mainwin.h.orig 2006-06-29 22:29:34.000000000 -0700
-+++ ./src/mainwin.h 2008-01-26 13:26:47.532687040 -0800
-@@ -22,7 +22,7 @@
- TEXT_WIN_PATTERN_NOT_FOUND,
- TEXT_WIN_TIPS, // when the word entry is empty,it will show tip
- TEXT_WIN_INFO,
-- TEXT_WIN_TREEDICT,
-+ TEXT_WIN_TREEDICT
- };
-
- enum ListWinListWordType {
-@@ -68,8 +68,6 @@
- static void on_main_menu_about_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
- static void on_main_menu_quit_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
-
-- static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
--
- void LoadHistory(void);
- void SaveHistory(void);
- public:
-@@ -79,6 +77,8 @@
- TopWin();
- ~TopWin();
-
-+ static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
-+
- void Create(GtkWidget *vbox);
- void Destroy(void);
- void SetText(const gchar *word, bool notify=true);
diff --git a/textproc/stardict3/files/patch-src::stardict-application-server.cpp b/textproc/stardict3/files/patch-src::stardict-application-server.cpp
index 38f2b4416b05..bc2f8507827e 100644
--- a/textproc/stardict3/files/patch-src::stardict-application-server.cpp
+++ b/textproc/stardict3/files/patch-src::stardict-application-server.cpp
@@ -1,6 +1,6 @@
--- src/stardict-application-server.cpp.orig Tue Sep 23 18:19:48 2003
+++ src/stardict-application-server.cpp Tue Jan 18 02:25:54 2005
-@@ -117,4 +117,4 @@
+@@ -119,4 +119,4 @@
StardictApplicationServer,
GNOME_Stardict_Application,
BONOBO_TYPE_OBJECT,
diff --git a/textproc/stardict3/pkg-plist b/textproc/stardict3/pkg-plist
index 85342966e0fc..f3a24cd93257 100644
--- a/textproc/stardict3/pkg-plist
+++ b/textproc/stardict3/pkg-plist
@@ -1,63 +1,73 @@
bin/stardict
%%GNOME%%libdata/bonobo/servers/GNOME_Stardict.server
share/applications/stardict.desktop
+%%GNOME%%share/gnome/help/stardict/C/legal.xml
+%%GNOME%%share/gnome/help/stardict/C/stardict.xml
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_float_window.png
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_main_window.png
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/C/legal.xml
-%%GNOME%%share/gnome/help/stardict/C/stardict.xml
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/mk/legal.xml
-%%GNOME%%share/gnome/help/stardict/mk/stardict.xml
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/nl/legal.xml
-%%GNOME%%share/gnome/help/stardict/nl/stardict.xml
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/ru/legal.xml
-%%GNOME%%share/gnome/help/stardict/ru/stardict.xml
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/uk/legal.xml
-%%GNOME%%share/gnome/help/stardict/uk/stardict.xml
+%%GNOME%%share/gnome/help/stardict/zh_CN/legal.xml
+%%GNOME%%share/gnome/help/stardict/zh_CN/stardict.xml
%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/legal.xml
-%%GNOME%%share/gnome/help/stardict/zh_CN/stardict.xml
+%%GNOME%%share/gnome/help/stardict/zh_TW/legal.xml
+%%GNOME%%share/gnome/help/stardict/zh_TW/stardict.xml
%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_float_window.png
%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_main_window.png
%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/legal.xml
-%%GNOME%%share/gnome/help/stardict/zh_TW/stardict.xml
+%%GNOME%%share/gnome/help/stardict/uk/legal.xml
+%%GNOME%%share/gnome/help/stardict/uk/stardict.xml
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/ru/legal.xml
+%%GNOME%%share/gnome/help/stardict/ru/stardict.xml
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/mk/legal.xml
+%%GNOME%%share/gnome/help/stardict/mk/stardict.xml
+%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/nl/legal.xml
+%%GNOME%%share/gnome/help/stardict/nl/stardict.xml
+%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_notification_area.png
%%GNOME%%share/idl/GNOME_Stardict.idl
%%GNOME%%share/omf/stardict/stardict-C.omf
-%%GNOME%%share/omf/stardict/stardict-mk.omf
-%%GNOME%%share/omf/stardict/stardict-nl.omf
-%%GNOME%%share/omf/stardict/stardict-ru.omf
-%%GNOME%%share/omf/stardict/stardict-uk.omf
%%GNOME%%share/omf/stardict/stardict-zh_CN.omf
%%GNOME%%share/omf/stardict/stardict-zh_TW.omf
+%%GNOME%%share/omf/stardict/stardict-uk.omf
+%%GNOME%%share/omf/stardict/stardict-ru.omf
+%%GNOME%%share/omf/stardict/stardict-mk.omf
+%%GNOME%%share/omf/stardict/stardict-nl.omf
share/pixmaps/stardict.png
share/stardict/pixmaps/docklet_normal.png
share/stardict/pixmaps/docklet_scan.png
share/stardict/pixmaps/docklet_stop.png
share/stardict/pixmaps/index_appendix.png
-share/stardict/pixmaps/index_dictlist.png
share/stardict/pixmaps/index_wazard.png
+share/stardict/pixmaps/index_dictlist.png
+share/stardict/pixmaps/index_translate.png
share/stardict/pixmaps/splash.png
-share/stardict/sounds/buttonactive.wav
share/stardict/sounds/menushow.wav
+share/stardict/sounds/buttonactive.wav
+share/stardict/data/advertisement/advertisement.txt
+share/stardict/data/advertisement/huzheng.png
+share/stardict/data/advertisement/linux_logo.jpg
+share/stardict/data/advertisement/redhat_linux_logo.gif
+share/stardict/data/advertisement/redhat_logo.jpg
+share/stardict/data/advertisement/wenjing.jpg
+share/stardict/data/advertisement/wenjing2.jpg
+share/locale/ar/LC_MESSAGES/stardict.mo
share/locale/cs/LC_MESSAGES/stardict.mo
share/locale/de/LC_MESSAGES/stardict.mo
share/locale/el/LC_MESSAGES/stardict.mo
share/locale/fr/LC_MESSAGES/stardict.mo
+share/locale/ga/LC_MESSAGES/stardict.mo
share/locale/hr/LC_MESSAGES/stardict.mo
share/locale/hu/LC_MESSAGES/stardict.mo
share/locale/ku/LC_MESSAGES/stardict.mo
@@ -65,31 +75,103 @@ share/locale/mk/LC_MESSAGES/stardict.mo
share/locale/nl/LC_MESSAGES/stardict.mo
share/locale/pt_BR/LC_MESSAGES/stardict.mo
share/locale/ru/LC_MESSAGES/stardict.mo
+share/locale/rw/LC_MESSAGES/stardict.mo
share/locale/sk/LC_MESSAGES/stardict.mo
+share/locale/sv/LC_MESSAGES/stardict.mo
+share/locale/tr/LC_MESSAGES/stardict.mo
share/locale/tt/LC_MESSAGES/stardict.mo
share/locale/uk/LC_MESSAGES/stardict.mo
share/locale/vi/LC_MESSAGES/stardict.mo
share/locale/zh_CN/LC_MESSAGES/stardict.mo
share/locale/zh_TW/LC_MESSAGES/stardict.mo
+lib/stardict/plugins/stardict_dictdotcn.so
+lib/stardict/plugins/stardict_dictdotcn.la
+lib/stardict/plugins/advertisement.so
+lib/stardict/plugins/advertisement.la
+lib/stardict/plugins/stardict_man.so
+lib/stardict/plugins/stardict_man.la
+lib/stardict/plugins/stardict_update_info.so
+lib/stardict/plugins/stardict_update_info.la
+lib/stardict/plugins/stardict_html_parsedata.so
+lib/stardict/plugins/stardict_html_parsedata.la
+lib/stardict/plugins/stardict_xdxf_parsedata.so
+lib/stardict/plugins/stardict_xdxf_parsedata.la
+lib/stardict/plugins/stardict_wordnet.so
+lib/stardict/plugins/stardict_wordnet.la
+lib/stardict/plugins/stardict_wordnet_parsedata.so
+lib/stardict/plugins/stardict_wordnet_parsedata.la
+lib/stardict/plugins/stardict_powerword_parsedata.so
+lib/stardict/plugins/stardict_powerword_parsedata.la
+lib/stardict/plugins/stardict_wiki_parsedata.so
+lib/stardict/plugins/stardict_wiki_parsedata.la
+lib/stardict/plugins/stardict_spell.so
+lib/stardict/plugins/stardict_spell.la
+lib/stardict/plugins/stardict_qqwry.so
+lib/stardict/plugins/stardict_qqwry.la
+@dirrmtry share/locale/ar/LC_MESSAGES
+@dirrmtry share/locale/ar
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/de/LC_MESSAGES
+@dirrmtry share/locale/de
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/ga/LC_MESSAGES
+@dirrmtry share/locale/ga
+@dirrmtry share/locale/hr/LC_MESSAGES
+@dirrmtry share/locale/hr
+@dirrmtry share/locale/hu/LC_MESSAGES
+@dirrmtry share/locale/hu
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/mk/LC_MESSAGES
+@dirrmtry share/locale/mk
+@dirrmtry share/locale/nl/LC_MESSAGES
+@dirrmtry share/locale/nl
+@dirrmtry share/locale/pt_BR/LC_MESSAGES
+@dirrmtry share/locale/pt_BR
+@dirrmtry share/locale/ru/LC_MESSAGES
+@dirrmtry share/locale/ru
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/sv/LC_MESSAGES
+@dirrmtry share/locale/sv
+@dirrmtry share/locale/tr/LC_MESSAGES
+@dirrmtry share/locale/tr
@dirrmtry share/locale/tt/LC_MESSAGES
@dirrmtry share/locale/tt
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/vi/LC_MESSAGES
+@dirrmtry share/locale/vi
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
@dirrm share/stardict/sounds
@dirrm share/stardict/pixmaps
+@dirrm share/stardict/treedict
+@dirrm share/stardict/data/advertisement
+@dirrmtry share/stardict/data
@dirrmtry share/stardict
%%GNOME%%@dirrm share/omf/stardict
-%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW/figures
-%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW
+%%GNOME%%@dirrm share/gnome/help/stardict/C/figures
+%%GNOME%%@dirrm share/gnome/help/stardict/C
%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN/figures
%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN
+%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW/figures
+%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW
%%GNOME%%@dirrm share/gnome/help/stardict/uk/figures
%%GNOME%%@dirrm share/gnome/help/stardict/uk
%%GNOME%%@dirrm share/gnome/help/stardict/ru/figures
%%GNOME%%@dirrm share/gnome/help/stardict/ru
-%%GNOME%%@dirrm share/gnome/help/stardict/nl/figures
-%%GNOME%%@dirrm share/gnome/help/stardict/nl
%%GNOME%%@dirrm share/gnome/help/stardict/mk/figures
%%GNOME%%@dirrm share/gnome/help/stardict/mk
-%%GNOME%%@dirrm share/gnome/help/stardict/C/figures
-%%GNOME%%@dirrm share/gnome/help/stardict/C
+%%GNOME%%@dirrm share/gnome/help/stardict/nl/figures
+%%GNOME%%@dirrm share/gnome/help/stardict/nl
%%GNOME%%@dirrm share/gnome/help/stardict
@dirrmtry share/applications