aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:29:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:29:22 +0000
commitcb82aed396f484e94eccf0d8aca9999d1447c4e0 (patch)
treef88c8368c97889b08f584578db7af4ff471831be
parentfd0a0a57ed2ccbcc4797783631e7bc3210807f41 (diff)
downloadports-cb82aed396f484e94eccf0d8aca9999d1447c4e0.tar.gz
ports-cb82aed396f484e94eccf0d8aca9999d1447c4e0.zip
Notes
-rw-r--r--www/instiki/Makefile14
-rw-r--r--www/instiki/files/instiki.in (renamed from www/instiki/files/instiki.sh)16
-rw-r--r--www/instiki/pkg-descr3
-rw-r--r--www/instiki/pkg-plist1
4 files changed, 14 insertions, 20 deletions
diff --git a/www/instiki/Makefile b/www/instiki/Makefile
index a14ca9091e33..71bd9f28c385 100644
--- a/www/instiki/Makefile
+++ b/www/instiki/Makefile
@@ -7,11 +7,11 @@
PORTNAME= instiki
PORTVERSION= 0.10.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ruby
MASTER_SITES= http://rubyforge.lauschmusik.de/instiki/ \
http://rubyforge.planetargon.com/instiki/ \
- http://rubyforge.org/frs/download.php/5350/
+ http://rubyforge.rubyuser.de/instiki/
EXTRACT_SUFX= .tgz
MAINTAINER= arsptr@optusnet.com.au
@@ -24,10 +24,8 @@ INSTIKIDIR?= instiki
PLIST_SUB= INSTIKIDIR=${INSTIKIDIR}/
-USE_RC_SUBR= yes
-SED_SCRIPT= -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
- -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%INSTIKIDIR%%,${INSTIKIDIR},g' \
+USE_RC_SUBR= ${PORTNAME}
+SED_LIST+= -e 's,%%INSTIKIDIR%%,${INSTIKIDIR},g' \
-e 's,%%INSTIKIPORT%%,${INSTIKIPORT},g' \
-e 's,%%RUBY_WITH_SUFFIX%%,${RUBY_WITH_SUFFIX},g'
@@ -38,12 +36,8 @@ INSTIKIPORT?= 2500
post-patch:
@${FIND} ${WRKSRC} -name '*.orig' -delete
-pre-install:
- @${SED} ${SED_SCRIPT} ${FILESDIR}/${PORTNAME}.sh >${WRKDIR}/${PORTNAME}.sh
-
do-install:
${CP} -pR ${WRKSRC}/ ${PREFIX}/${INSTIKIDIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/${PORTNAME}.sh
${MKDIR} ${PREFIX}/${INSTIKIDIR}/storage/${INSTIKIPORT}
${CHMOD} +x ${PREFIX}/${INSTIKIDIR}/instiki
diff --git a/www/instiki/files/instiki.sh b/www/instiki/files/instiki.in
index d4a50d41a4ee..8dd072b43ece 100644
--- a/www/instiki/files/instiki.sh
+++ b/www/instiki/files/instiki.in
@@ -3,26 +3,26 @@
# PROVIDE: instiki
# REQUIRE: DAEMON
#
-# Add the following line to /etc/rc.conf to enable instiki:
+# Add the following line to /etc/rc.conf[.local] to enable instiki:
# instiki_enable (bool): Set to "NO" by default
# Set it to "YES" to enable instiki
# instiki_flags (str): Set to "--port %%INSTIKIPORT%% --storage %%PREFIX%%/%%INSTIKIDIR%%/storage --daemon" by default.
# Extra flags passed to start command
#
+
. %%RC_SUBR%%
name="instiki"
-rcvar=`set_rcvar`
+rcvar=${name}_enable
+
+#rcvar=`set_rcvar`
command="%%PREFIX%%/%%INSTIKIDIR%%/instiki"
command_interpreter="%%RUBY_WITH_SUFFIX%%"
-[ -z "$instiki_enable" ] && instiki_enable="NO"
-[ -z "$instiki_flags" ] && instiki_flags="--port %%INSTIKIPORT%% --storage %%PREFIX%%/%%INSTIKIDIR%%/storage --daemon"
-
-load_rc_config $name
+: ${doormand_enable="NO"}
+: ${instiki_flags="--port %%INSTIKIPORT%% --storage %%PREFIX%%/%%INSTIKIDIR%%/storage --daemon"}
sig_stop=-TERM
-run_rc_command "$1"
-
+load_rc_config $name
diff --git a/www/instiki/pkg-descr b/www/instiki/pkg-descr
index ff44fb2326c0..e9a7f1907e8e 100644
--- a/www/instiki/pkg-descr
+++ b/www/instiki/pkg-descr
@@ -1,7 +1,8 @@
Instiki is a wiki clone implemented in ruby with no dependencies
other than ruby-1.8.1 or greater. Instiki was written and is
maintained by David Heinemeier Hansson. Homepage is
-WWW: http://www.instiki.org
+
+WWW: http://www.instiki.org/show/HomePage
- Kelley Reynolds
kelley@insidesystems.net
diff --git a/www/instiki/pkg-plist b/www/instiki/pkg-plist
index 84857aa1092c..3abf90eaf07c 100644
--- a/www/instiki/pkg-plist
+++ b/www/instiki/pkg-plist
@@ -1,4 +1,3 @@
-etc/rc.d/instiki.sh
%%INSTIKIDIR%%natives/osx/desktop_launcher/English.lproj/MainMenu.nib/classes.nib
%%INSTIKIDIR%%natives/osx/desktop_launcher/English.lproj/MainMenu.nib/info.nib
%%INSTIKIDIR%%natives/osx/desktop_launcher/English.lproj/MainMenu.nib/objects.nib