aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 17:15:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 17:15:06 +0000
commitce5e12238beb8358984af8827cfd7d2523130856 (patch)
tree18a9944158e2a6334becb51770000e4342c1e655
parent8cb0ace11119f34c3f5cef239bc9ea3394664d97 (diff)
downloadports-ce5e12238beb8358984af8827cfd7d2523130856.tar.gz
ports-ce5e12238beb8358984af8827cfd7d2523130856.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pfstmo/Makefile41
-rw-r--r--graphics/pfstmo/distinfo3
-rw-r--r--graphics/pfstmo/pkg-descr6
-rw-r--r--graphics/pfstmo/pkg-plist7
5 files changed, 58 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fcc822557e2c..54895ad5d298 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -526,6 +526,7 @@
SUBDIR += pecl-qrencode
SUBDIR += pecomato
SUBDIR += peps
+ SUBDIR += pfstmo
SUBDIR += pfstools
SUBDIR += pgperl
SUBDIR += pgplot
diff --git a/graphics/pfstmo/Makefile b/graphics/pfstmo/Makefile
new file mode 100644
index 000000000000..e84bf06d623e
--- /dev/null
+++ b/graphics/pfstmo/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pfstmo
+# Date created: Fri Jun 1 16:13:32 UTC 2007
+# Whom: argv[0] (Iouri V. Ivliev)
+#
+# $FreeBSD$
+
+PORTNAME= pfstmo
+PORTVERSION= 1.1
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= pfstools
+
+MAINTAINER= ii@any.com.ru
+COMMENT= Tone mapping operators
+
+LIB_DEPENDS= pfs-1.2:${PORTSDIR}/graphics/pfstools
+
+PFS_CPPFLAGS= -I${LOCALBASE}/include
+PFS_LDFLAGS= -L${LOCALBASE}/lib
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${PFS_CPPFLAGS}" \
+ LDFLAGS="${PFS_LDFLAGS}"
+USE_GMAKE= yes
+
+MAN1= pfstmo_pattanaik00.1 \
+ pfstmo_reinhard05.1 \
+ pfstmo_reinhard02.1 \
+ pfstmo_durand02.1 \
+ pfstmo_drago03.1 \
+ pfstmo_mantiuk06.1 \
+ pfstmo_fattal02.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FFTW3F)
+LIB_DEPENDS+= fftw3f.4:${PORTSDIR}/math/fftw3-float
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/pfstmo/distinfo b/graphics/pfstmo/distinfo
new file mode 100644
index 000000000000..cb4b1c0c690c
--- /dev/null
+++ b/graphics/pfstmo/distinfo
@@ -0,0 +1,3 @@
+MD5 (pfstmo-1.1.tar.gz) = 0b15be34f61a492062685f574af83bca
+SHA256 (pfstmo-1.1.tar.gz) = 68c50a67cdd9e526249742ce6c330d6cadd8290b67c33a0942f4e9f5aa6918b7
+SIZE (pfstmo-1.1.tar.gz) = 367563
diff --git a/graphics/pfstmo/pkg-descr b/graphics/pfstmo/pkg-descr
new file mode 100644
index 000000000000..986de3cade0b
--- /dev/null
+++ b/graphics/pfstmo/pkg-descr
@@ -0,0 +1,6 @@
+Pfstmo package contains the implementation of state-of-the-art tone
+mapping operators. The motivation here is to provide an implementation
+of tone mapping operators suitable for convenient processing of both
+static images and animations.
+
+WWW: http://www.mpi-inf.mpg.de/resources/tmo/
diff --git a/graphics/pfstmo/pkg-plist b/graphics/pfstmo/pkg-plist
new file mode 100644
index 000000000000..1fc052ecb0c0
--- /dev/null
+++ b/graphics/pfstmo/pkg-plist
@@ -0,0 +1,7 @@
+bin/pfstmo_pattanaik00
+bin/pfstmo_reinhard05
+bin/pfstmo_reinhard02
+bin/pfstmo_durand02
+bin/pfstmo_drago03
+bin/pfstmo_mantiuk06
+bin/pfstmo_fattal02