aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2020-09-21 15:50:30 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2020-09-21 15:50:30 +0000
commitd02295e72d1ebedd800105c831f9adda2e9f11e6 (patch)
treee52a6658c3839266e31686ea333b577243f70839
parent059b3562e7cb439f36ea4ee1087af56824362fef (diff)
downloadports-d02295e72d1ebedd800105c831f9adda2e9f11e6.tar.gz
ports-d02295e72d1ebedd800105c831f9adda2e9f11e6.zip
MFH: r549433
Fix crash when accessing physical CD/DVD PR: 248333 Reported by: mfv@bway.net Approved by: koobs (vbox) Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549453
-rw-r--r--emulators/virtualbox-ose/Makefile1
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Devices-Storage-DrvHostBase-freebsd.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index bea2b6f85bac..02c2d792d08e 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -3,6 +3,7 @@
PORTNAME= virtualbox-ose
PORTVERSION= 5.2.44
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://download.oracle.com/virtualbox/${PORTVERSION}/
DISTFILES= VirtualBox-${PORTVERSION}${EXTRACT_SUFX} ${GUESTADDITIONS}
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Storage-DrvHostBase-freebsd.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Storage-DrvHostBase-freebsd.cpp
new file mode 100644
index 000000000000..7a472483318e
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Storage-DrvHostBase-freebsd.cpp
@@ -0,0 +1,11 @@
+--- src/VBox/Devices/Storage/DrvHostBase-freebsd.cpp 2020-09-17 20:17:20 UTC
++++ src/VBox/Devices/Storage/DrvHostBase-freebsd.cpp
+@@ -149,6 +149,8 @@
+ else
+ rc = RTErrConvertFromErrno(errno);
+ }
++
++ return rc;
+ }
+
+