aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-17 23:31:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-17 23:31:28 +0000
commite2024367aa397cdffd8e1d72fededaae7e893caf (patch)
tree7e28f19ec4dbaf95df96c67fe23da4033b7c3d29
parentb78a28ab8fe8842120396964b0611a777a800ae9 (diff)
It will help you to manage wine prefixes and installed applications. General features: - Exports QT color theme into wine colors settings - Works with different wine versions at same time - Creates, deletes and manages prefixes (WINEPREFIX) - Easy controlling wine process - Autostart icons support - Easy CD image usage - Supports extraction of icons from PE files (.exe, .dll) - Easy backup and restore for managed prefixes - Winetricks support - More WWW: http://api.qt-apps.org/content/show.php?content=85751 PR: 131416 Submitted by: "Sergey V. Dyatko" <sergey dot dyatko at gmail dot com>
Notes
Notes: svn path=/head/; revision=228569
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/q4wine/Makefile34
-rw-r--r--deskutils/q4wine/distinfo3
-rw-r--r--deskutils/q4wine/pkg-descr16
-rw-r--r--deskutils/q4wine/pkg-message14
-rw-r--r--deskutils/q4wine/pkg-plist30
6 files changed, 98 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index f851bd1ab5bc..8eb26d232cdb 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -211,6 +211,7 @@
SUBDIR += py-vobject
SUBDIR += pybookreader
SUBDIR += pypanel
+ SUBDIR += q4wine
SUBDIR += qlabels
SUBDIR += qorganizer
SUBDIR += qrfcview
diff --git a/deskutils/q4wine/Makefile b/deskutils/q4wine/Makefile
new file mode 100644
index 000000000000..2370d536ec2a
--- /dev/null
+++ b/deskutils/q4wine/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: q4wine
+# Date created: 05 Feb 2009
+# Whom: Sergey V. Dyatko <sergey.dyatko@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= q4wine
+PORTVERSION= 0.111
+CATEGORIES= deskutils emulators
+MASTER_SITES= SF
+
+MAINTAINER= sergey.dyatko@mail.com
+COMMENT= QT4 front-end for WINE
+
+RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
+ icotool:${PORTSDIR}/graphics/icoutils \
+ wine:${PORTSDIR}/emulators/wine \
+ wget:${PORTSDIR}/ftp/wget \
+ cabextract:${PORTSDIR}/archivers/cabextract
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build rcc_build moc_build uic_build \
+ linguist_build corelib gui sql network
+
+ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS_REASON= depends on wine which is only available for i386
+
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
+
+post-install:
+ -update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/deskutils/q4wine/distinfo b/deskutils/q4wine/distinfo
new file mode 100644
index 000000000000..f2174ef2a2ca
--- /dev/null
+++ b/deskutils/q4wine/distinfo
@@ -0,0 +1,3 @@
+MD5 (q4wine-0.111.tar.gz) = 615282aad34bfd59bd3764c6e7fc0c39
+SHA256 (q4wine-0.111.tar.gz) = 4c76246ff732a55df50d40bde7fe1127ee63a03e3057d74ee10e204e46b6053c
+SIZE (q4wine-0.111.tar.gz) = 508675
diff --git a/deskutils/q4wine/pkg-descr b/deskutils/q4wine/pkg-descr
new file mode 100644
index 000000000000..a48f6b4d247b
--- /dev/null
+++ b/deskutils/q4wine/pkg-descr
@@ -0,0 +1,16 @@
+Q4wine is an Qt4 (http://www.qtsoftware.com/) GUI for wine (http://winehq.org/).
+It will help you to manage wine prefixes and installed applications.
+
+General features:
+ - Exports QT color theme into wine colors settings
+ - Works with different wine versions at same time
+ - Creates, deletes and manages prefixes (WINEPREFIX)
+ - Easy controlling wine process
+ - Autostart icons support
+ - Easy CD image usage
+ - Supports extraction of icons from PE files (.exe, .dll)
+ - Easy backup and restore for managed prefixes
+ - Winetricks support
+ - More
+
+WWW: http://api.qt-apps.org/content/show.php?content=85751
diff --git a/deskutils/q4wine/pkg-message b/deskutils/q4wine/pkg-message
new file mode 100644
index 000000000000..21c37cb1e1b3
--- /dev/null
+++ b/deskutils/q4wine/pkg-message
@@ -0,0 +1,14 @@
+################################################################################
+
+This programm will attempt to obtain some system information by accessing files
+in procfs. You must mount procfs filesystem for this to work correctly. This can
+be accomplished by adding the following line to your /etc/fstab file:
+
+# Device Mountpoint FStype Options Dump Pass#
+proc /proc procfs rw 0 0
+
+and then, as root, executing the command:
+
+mount /proc
+
+################################################################################
diff --git a/deskutils/q4wine/pkg-plist b/deskutils/q4wine/pkg-plist
new file mode 100644
index 000000000000..fd0f69ff2b8a
--- /dev/null
+++ b/deskutils/q4wine/pkg-plist
@@ -0,0 +1,30 @@
+bin/q4wine
+%%DATADIR%%/i18n/en_us.qm
+%%DATADIR%%/i18n/ru_ru.qm
+%%DATADIR%%/i18n/uk_ua.qm
+%%DATADIR%%/theme/nuvola/data/configure.png
+%%DATADIR%%/theme/nuvola/data/down.png
+%%DATADIR%%/theme/nuvola/data/edit.png
+%%DATADIR%%/theme/nuvola/data/exec.png
+%%DATADIR%%/theme/nuvola/data/exec_wine.png
+%%DATADIR%%/theme/nuvola/data/exit.png
+%%DATADIR%%/theme/nuvola/data/folder.png
+%%DATADIR%%/theme/nuvola/data/folder_open.png
+%%DATADIR%%/theme/nuvola/data/kill.png
+%%DATADIR%%/theme/nuvola/data/power.png
+%%DATADIR%%/theme/nuvola/data/prefix.png
+%%DATADIR%%/theme/nuvola/data/rebuild.png
+%%DATADIR%%/theme/nuvola/data/reload.png
+%%DATADIR%%/theme/nuvola/data/stop.png
+%%DATADIR%%/theme/nuvola/data/theme.info
+%%DATADIR%%/theme/nuvola/data/up.png
+%%DATADIR%%/theme/nuvola/data/wine.png
+%%DATADIR%%/theme/nuvola/data/wizard.png
+share/applications/q4wine.desktop
+share/pixmaps/q4wine.png
+@dirrmtry share/applications
+@dirrm %%DATADIR%%/theme/nuvola/data
+@dirrm %%DATADIR%%/theme/nuvola
+@dirrm %%DATADIR%%/theme
+@dirrm %%DATADIR%%/i18n
+@dirrm %%DATADIR%%