aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-11-24 05:06:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-11-24 05:06:26 +0000
commite3b0a9e8b2956f7730487ce3b2894d9ffc653170 (patch)
tree6c679a026d9081ed024ab9ed6e9b894feccbcc47
parent8ef943d6e31898c6607b560cfe3b43a2ae95d493 (diff)
downloadports-e3b0a9e8b2956f7730487ce3b2894d9ffc653170.tar.gz
ports-e3b0a9e8b2956f7730487ce3b2894d9ffc653170.zip
Notes
-rw-r--r--security/theonionbox/Makefile2
-rw-r--r--security/theonionbox/files/patch-setup.py15
-rw-r--r--security/theonionbox/files/patch-theonionbox_theonionbox.py20
3 files changed, 35 insertions, 2 deletions
diff --git a/security/theonionbox/Makefile b/security/theonionbox/Makefile
index 70ce85cf5e0f..a73753a1865a 100644
--- a/security/theonionbox/Makefile
+++ b/security/theonionbox/Makefile
@@ -2,7 +2,7 @@
PORTNAME= theonionbox
DISTVERSION= 4.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP
diff --git a/security/theonionbox/files/patch-setup.py b/security/theonionbox/files/patch-setup.py
index ba87853713a4..5dcf08528423 100644
--- a/security/theonionbox/files/patch-setup.py
+++ b/security/theonionbox/files/patch-setup.py
@@ -1,4 +1,4 @@
---- setup.py.orig 2019-05-11 04:02:35 UTC
+--- setup.py.orig 2019-05-10 21:59:01 UTC
+++ setup.py
@@ -295,19 +295,9 @@ package_data_exclude = {
}
@@ -23,3 +23,16 @@
]
# print(generate_data_files(data_files))
+@@ -381,10 +371,10 @@ setup(
+ 'requests>=2.21',
+ 'PySocks>=1.6.7',
+ 'bottle>=0.12.13',
+- 'stem>=1.5.4, <=1.6',
++ 'stem>=1.5.4',
+ 'tzlocal>=1.5',
+ 'futures>=3.2; python_version<"3.0"',
+- 'urllib3>=1.24.2, <1.25' # '<1.25' due to requests 2.21 requirement
++ 'urllib3>=1.21.1,<1.26' # copied (except the exclusions) from requests 2.22
+ ],
+ long_description_content_type='text/x-rst; charset=UTF-8',
+ classifiers=[
diff --git a/security/theonionbox/files/patch-theonionbox_theonionbox.py b/security/theonionbox/files/patch-theonionbox_theonionbox.py
new file mode 100644
index 000000000000..d515ad07478c
--- /dev/null
+++ b/security/theonionbox/files/patch-theonionbox_theonionbox.py
@@ -0,0 +1,20 @@
+--- theonionbox/theonionbox.py.orig 2019-11-09 13:37:29 UTC
++++ theonionbox/theonionbox.py
+@@ -513,7 +513,7 @@ required_modules = {
+ 'info': "Check 'https://pypi.python.org/pypi/psutil' for installation instructions."
+ },
+ 'stem': {
+- 'version': '>=1.5.4, <=1.6'
++ 'version': '>=1.5.4'
+ },
+ 'bottle': {
+ 'version': '>=0.12.13'
+@@ -539,7 +539,7 @@ required_modules = {
+ 'version': '>=3.2; python_version<"3.0"'
+ },
+ 'urllib3': {
+- 'version': '>=1.24.2, <1.25'
++ 'version': '>=1.21.1,<1.26' #copied (except the exclusions) from requests 2.22
+ }
+ }
+