aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-04-28 14:55:30 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-04-28 14:55:30 +0000
commite4272704739b4e4521abc9398295cfebb09797b0 (patch)
treee7a08240ad95ae55a0f65764924d9a135f239fea
parentf249815ddea44e3d4b38e01cadc223cf0f3c7f46 (diff)
downloadports-e4272704739b4e4521abc9398295cfebb09797b0.tar.gz
ports-e4272704739b4e4521abc9398295cfebb09797b0.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/sdl_lopan/Makefile52
-rw-r--r--games/sdl_lopan/distinfo2
-rw-r--r--games/sdl_lopan/files/patch-Makefile14
-rw-r--r--games/sdl_lopan/pkg-descr3
5 files changed, 72 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a7b2c1fa0e11..427fc2fb17b6 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -785,6 +785,7 @@
SUBDIR += sdl-ball
SUBDIR += sdlCC
SUBDIR += sdl_jewels
+ SUBDIR += sdl_lopan
SUBDIR += sdl_scavenger
SUBDIR += sdlquake2
SUBDIR += sdlroids
diff --git a/games/sdl_lopan/Makefile b/games/sdl_lopan/Makefile
new file mode 100644
index 000000000000..b6b428a04624
--- /dev/null
+++ b/games/sdl_lopan/Makefile
@@ -0,0 +1,52 @@
+# New Ports collection makefile for: SDL_Lopan
+# Date created: 2012-04-26
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_lopan
+PORTVERSION= 10
+CATEGORIES= games
+MASTER_SITES= http://www.linuxmotors.com/sdllopan/downloads/
+DISTNAME= ${PORTNAME:S/_//}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= SDL Lopan is a mahjong game remake
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/sdllopan-${PORTVERSION}
+
+USE_SDL= sdl image mixer
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/sdllopan
+
+PORTDATA= *
+PORTDOCS= Changelog README
+
+ALL_TARGET=
+
+do-install:
+# Scripts
+ @${PRINTF} "#!/bin/sh\n\ncd ${DATADIR} &&\
+ ./lopan\n" > ${WRKDIR}/sdllopan.sh
+ @${INSTALL_SCRIPT} ${WRKDIR}/sdllopan.sh ${PREFIX}/bin/sdllopan
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lopan ${DATADIR}
+# Data
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sdl_lopan/distinfo b/games/sdl_lopan/distinfo
new file mode 100644
index 000000000000..b4a76ce6b47d
--- /dev/null
+++ b/games/sdl_lopan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sdllopan-10.tgz) = 386de065bc8c3449c3b0b5e5651cb035cb1bdc242b425c865dd387c54ce708c3
+SIZE (sdllopan-10.tgz) = 380102
diff --git a/games/sdl_lopan/files/patch-Makefile b/games/sdl_lopan/files/patch-Makefile
new file mode 100644
index 000000000000..a525561deb02
--- /dev/null
+++ b/games/sdl_lopan/files/patch-Makefile
@@ -0,0 +1,14 @@
+Index: Makefile
+@@ -1,10 +1,9 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
++CFLAGS += $(shell sdl-config --cflags)
++LDFLAGS += $(shell sdl-config --libs)
+ EXE = lopan
+ OBJS = $(EXE).o gfx.o font.o
+
+ $(EXE): $(OBJS)
+- gcc -o $(EXE) $(OBJS) $(shell sdl-config --libs)
+
+ $(EXE).o: $(EXE).c gfx.h font.h
+
diff --git a/games/sdl_lopan/pkg-descr b/games/sdl_lopan/pkg-descr
new file mode 100644
index 000000000000..45666c651db6
--- /dev/null
+++ b/games/sdl_lopan/pkg-descr
@@ -0,0 +1,3 @@
+SDL Lopan is a mahjong game remake
+
+WWW: http://www.linuxmotors.com/sdllopan/