aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2009-05-16 09:55:21 +0000
committerMaho Nakata <maho@FreeBSD.org>2009-05-16 09:55:21 +0000
commited6af5c234a29e4f43c76bbd217475e595e66c4b (patch)
tree10ac2aecd84c2afd7e4f6e3a5f57c03d066d1138
parent413b00334b55320a71440364620fdeaf19dc471e (diff)
downloadports-ed6af5c234a29e4f43c76bbd217475e595e66c4b.tar.gz
ports-ed6af5c234a29e4f43c76bbd217475e595e66c4b.zip
Notes
-rw-r--r--editors/openoffice-3-devel/Makefile7
-rw-r--r--editors/openoffice-3-devel/files/patch-i8454914
-rw-r--r--editors/openoffice-3-devel/files/patch-iXXXXX11
-rw-r--r--editors/openoffice.org-3-devel/Makefile7
-rw-r--r--editors/openoffice.org-3-devel/files/patch-i8454914
-rw-r--r--editors/openoffice.org-3-devel/files/patch-iXXXXX11
6 files changed, 50 insertions, 14 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 522b9be30ec1..e4b43d136581 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -174,7 +174,13 @@ pre-everything::
@${TOUCH} ${BUILD_COOKIE}
.endif
+#issue XXXXXX not raised yet...
+CRLFFILES=curl/curl*patch neon/neon*patch
+
post-extract:
+ for i in ${CRLFFILES}; do \
+ cd ${WRKSRC} ; ${REINPLACE_CMD} -e 's# ##g' $$i ; \
+ done
@${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
.if defined(WITH_CWS)
cd ${WRKSRC} ; ${TAR} xvfz ${DISTDIR}/${DIST_SUBDIR}/${CWSARCHIVE}
@@ -187,6 +193,7 @@ post-extract:
.if !defined(WITHOUT_MOZILLA)
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${MOZILLA_SOURCE} ${WRKSRC}/moz/download
.endif
+
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
diff --git a/editors/openoffice-3-devel/files/patch-i84549 b/editors/openoffice-3-devel/files/patch-i84549
index 95ec361dcdb1..1d7f6517953b 100644
--- a/editors/openoffice-3-devel/files/patch-i84549
+++ b/editors/openoffice-3-devel/files/patch-i84549
@@ -6,11 +6,11 @@ diff -u -r1.25 neon.patch
--- neon/neon.patch 22 Jul 2008 17:17:06 -0000 1.25
+++ neon/neon.patch 10 Aug 2008 04:20:27 -0000
@@ -266,7 +266,7 @@
- +#define HAVE_SYS_TYPES_H 1
- +
- +/* Define if the timezone global is available */
--+#ifndef MACOSX
+ +#define HAVE_SYS_TYPES_H 1
+ +
+ +/* Define if the timezone global is available */
+-+#ifndef MACOSX
++#if !defined(MACOSX) && !defined(FREEBSD)
- +#define HAVE_TIMEZONE 1
- +#endif
- +
+ +#define HAVE_TIMEZONE 1
+ +#endif
+ +
diff --git a/editors/openoffice-3-devel/files/patch-iXXXXX b/editors/openoffice-3-devel/files/patch-iXXXXX
new file mode 100644
index 000000000000..2e89167f154c
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-iXXXXX
@@ -0,0 +1,11 @@
+--- openssl/makefile.mk~ 2009-04-11 18:07:56.000000000 +0900
++++ openssl/makefile.mk 2009-05-16 15:41:13.000000000 +0900
+@@ -65,7 +65,7 @@
+ OUT2LIB += libcrypto.*
+ OUT2INC += include/openssl/*
+
+-.IF "$(OS)" == "LINUX"
++.IF "$(OS)" == "LINUX" || "$(OS)" == "FREEBSD"
+ PATCH_FILES=openssllnx.patch
+ ADDITIONAL_FILES:= \
+ libcrypto_OOo_0_9_8k.map \
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 522b9be30ec1..e4b43d136581 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -174,7 +174,13 @@ pre-everything::
@${TOUCH} ${BUILD_COOKIE}
.endif
+#issue XXXXXX not raised yet...
+CRLFFILES=curl/curl*patch neon/neon*patch
+
post-extract:
+ for i in ${CRLFFILES}; do \
+ cd ${WRKSRC} ; ${REINPLACE_CMD} -e 's# ##g' $$i ; \
+ done
@${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
.if defined(WITH_CWS)
cd ${WRKSRC} ; ${TAR} xvfz ${DISTDIR}/${DIST_SUBDIR}/${CWSARCHIVE}
@@ -187,6 +193,7 @@ post-extract:
.if !defined(WITHOUT_MOZILLA)
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${MOZILLA_SOURCE} ${WRKSRC}/moz/download
.endif
+
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
diff --git a/editors/openoffice.org-3-devel/files/patch-i84549 b/editors/openoffice.org-3-devel/files/patch-i84549
index 95ec361dcdb1..1d7f6517953b 100644
--- a/editors/openoffice.org-3-devel/files/patch-i84549
+++ b/editors/openoffice.org-3-devel/files/patch-i84549
@@ -6,11 +6,11 @@ diff -u -r1.25 neon.patch
--- neon/neon.patch 22 Jul 2008 17:17:06 -0000 1.25
+++ neon/neon.patch 10 Aug 2008 04:20:27 -0000
@@ -266,7 +266,7 @@
- +#define HAVE_SYS_TYPES_H 1
- +
- +/* Define if the timezone global is available */
--+#ifndef MACOSX
+ +#define HAVE_SYS_TYPES_H 1
+ +
+ +/* Define if the timezone global is available */
+-+#ifndef MACOSX
++#if !defined(MACOSX) && !defined(FREEBSD)
- +#define HAVE_TIMEZONE 1
- +#endif
- +
+ +#define HAVE_TIMEZONE 1
+ +#endif
+ +
diff --git a/editors/openoffice.org-3-devel/files/patch-iXXXXX b/editors/openoffice.org-3-devel/files/patch-iXXXXX
new file mode 100644
index 000000000000..2e89167f154c
--- /dev/null
+++ b/editors/openoffice.org-3-devel/files/patch-iXXXXX
@@ -0,0 +1,11 @@
+--- openssl/makefile.mk~ 2009-04-11 18:07:56.000000000 +0900
++++ openssl/makefile.mk 2009-05-16 15:41:13.000000000 +0900
+@@ -65,7 +65,7 @@
+ OUT2LIB += libcrypto.*
+ OUT2INC += include/openssl/*
+
+-.IF "$(OS)" == "LINUX"
++.IF "$(OS)" == "LINUX" || "$(OS)" == "FREEBSD"
+ PATCH_FILES=openssllnx.patch
+ ADDITIONAL_FILES:= \
+ libcrypto_OOo_0_9_8k.map \