aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-04-21 22:29:06 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-04-21 22:29:06 +0000
commiteff583830e781325c8d59d99d4edd388e30875db (patch)
treee9e38b22c7fb04568da494410ecc809227f4f853
parent37418955d580a0d353b93857e6b8ddd0405d528e (diff)
downloadports-eff583830e781325c8d59d99d4edd388e30875db.tar.gz
ports-eff583830e781325c8d59d99d4edd388e30875db.zip
Notes
-rw-r--r--net-mgmt/nagios-plugins/Makefile7
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl15
2 files changed, 14 insertions, 8 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 4e789a825779..7bd8eae59998 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: nagios-plugins
-# Date created: 14 Jul 2002
-# Whom: Blaz Zupan <blaz@si.FreeBSD.org>
-#
+# Created by: Blaz Zupan <blaz@si.FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= nagios-plugins
PORTVERSION= 1.4.16
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/nagiosplug/nagiosplug/${PORTVERSION}
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
index fcddc805ddd0..2efbf4867f9c 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
@@ -1,6 +1,6 @@
---- plugins-scripts/check_ircd.pl.orig Tue May 7 15:05:49 2002
-+++ plugins-scripts/check_ircd.pl Fri May 12 23:40:44 2006
-@@ -67,6 +67,7 @@
+--- plugins-scripts/check_ircd.pl.orig 2012-06-27 12:32:47.000000000 -0500
++++ plugins-scripts/check_ircd.pl 2012-11-14 20:58:01.479745211 -0600
+@@ -66,6 +66,7 @@
$ENV{PATH} = "";
$ENV{ENV} = "";
$ENV{BASH_ENV} = "";
@@ -8,3 +8,12 @@
# -----------------------------------------------------------------[ Global ]--
+@@ -153,7 +154,7 @@
+ print "IRCD UNKNOWN: Could not start socket ($!)\n";
+ exit $ERRORS{"UNKNOWN"};
+ }
+- $sockaddr = 'S n a4 x8';
++ $sockaddr = 'x C n a4 x8';
+ $that = pack($sockaddr, AF_INET, $in_remoteport, $thataddr);
+ if (!connect(ClientSocket, $that)) {
+ print "IRCD UNKNOWN: Could not connect socket ($!)\n";