aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-02-03 22:05:25 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-02-03 22:05:25 +0000
commitf0173c9ed6f3a0c082f7fc887b8337bb68138ddd (patch)
treeacabd01cd7383d667d212d41f450da0d56e13762
parentf64515e7a9d56e8f4e7c4bf33eaa90cbb7cb857f (diff)
downloadports-f0173c9ed6f3a0c082f7fc887b8337bb68138ddd.tar.gz
ports-f0173c9ed6f3a0c082f7fc887b8337bb68138ddd.zip
Notes
-rw-r--r--net/java-beepcore/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/net/java-beepcore/Makefile b/net/java-beepcore/Makefile
index d2e8b77e4353..0ca470932e97 100644
--- a/net/java-beepcore/Makefile
+++ b/net/java-beepcore/Makefile
@@ -17,28 +17,30 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An implementation of BEEP core and BEEP mapping for TCP in Java
-RUN_DEPENDS= ${LOCALBASE}/share/java/classes/xercesImpl.jar:${PORTSDIR}/textproc/xerces-j
+RUN_DEPENDS= ${JAVALIBDIR}/xercesImpl.jar:${PORTSDIR}/textproc/xerces-j
-USE_JAVA= 1.3+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
NO_BUILD= yes
-NO_BUILD_DEPENDS_JAVA= yes
-
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/beep*.jar ${JAVAJARDIR}
- ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/example \
+ && ${FIND} -s . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
${INSTALL_DATA} ${WRKSRC}/lib/example.jar ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/example/* ${EXAMPLESDIR}
post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${WRKSRC}/*.htm ${DOCSDIR}
.if !defined(NOPORTDOCS)
- ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ cd ${WRKSRC}/doc \
+ && ${FIND} -s . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.endif
.include <bsd.port.mk>