aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-05 20:02:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-05 20:02:34 +0000
commitf05ef254855f0cb42d36c5029540f165599dd95d (patch)
tree189b501d8ccb8e47faa9267cea079d243f56dfdd
parent8fc7e408f02718b5af41d01a9983b49887ee0d2e (diff)
downloadports-f05ef254855f0cb42d36c5029540f165599dd95d.tar.gz
ports-f05ef254855f0cb42d36c5029540f165599dd95d.zip
Notes
-rw-r--r--astro/kstars/Makefile5
-rw-r--r--astro/p5-Astro-FITS-CFITSIO/Makefile1
-rw-r--r--astro/wcslib/Makefile1
-rw-r--r--graphics/gdal/Makefile2
-rw-r--r--graphics/ufraw/Makefile11
-rw-r--r--math/octave-forge-fits/Makefile4
-rw-r--r--science/kst2/Makefile2
7 files changed, 15 insertions, 11 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 7596b0c993e2..046509e7ec31 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kstars
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= astro kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -10,8 +11,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 desktop planetarium
-LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
- wcs:${PORTSDIR}/astro/wcslib
+LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio \
+ libwcs.so:${PORTSDIR}/astro/wcslib
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
xplanet:${PORTSDIR}/astro/xplanet
diff --git a/astro/p5-Astro-FITS-CFITSIO/Makefile b/astro/p5-Astro-FITS-CFITSIO/Makefile
index 7b4810e82db4..67f5aa76874e 100644
--- a/astro/p5-Astro-FITS-CFITSIO/Makefile
+++ b/astro/p5-Astro-FITS-CFITSIO/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Astro-FITS-CFITSIO
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= astro perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index c0ad010f371d..f632a4887c7f 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wcslib
PORTVERSION= 4.13.4
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index b724f084d179..9dddc59963c3 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdal
PORTVERSION= 1.10.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/${PORTVERSION}/ \
ftp://ftp.remotesensing.org/pub/gdal/${PORTVERSION}/ \
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 3e69c751207b..14c20ddb0235 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ufraw
PORTVERSION= 0.19.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -47,25 +48,25 @@ CONFIGURE_ARGS+= --enable-dst-correction
.endif
.if ${PORT_OPTIONS:MEXIV2}
-LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
+LIB_DEPENDS+= libexiv2.so:${PORTSDIR}/graphics/exiv2
.else
PC_FALSE+= exiv2
.endif
.if ${PORT_OPTIONS:MLENSFUN}
-LIB_DEPENDS+= lensfun:${PORTSDIR}/graphics/lensfun
+LIB_DEPENDS+= liblensfun.so:${PORTSDIR}/graphics/lensfun
.else
PC_FALSE+= lensfun
.endif
.if ${PORT_OPTIONS:MFITS}
-LIB_DEPENDS+= cfitsio:${PORTSDIR}/astro/cfitsio
+LIB_DEPENDS+= libcfitsio.so:${PORTSDIR}/astro/cfitsio
.else
PC_FALSE+= cfitsio
.endif
.if ${PORT_OPTIONS:MGIMP}
-LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp-app
+LIB_DEPENDS+= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
PLIST_SUB+= GIMP=""
.else
CONFIGURE_ARGS+=--without-gimp
@@ -74,7 +75,7 @@ PLIST_SUB+= GIMP="@comment "
.endif
.if ${PORT_OPTIONS:MGTK2}
-LIB_DEPENDS+= gtkimageview:${PORTSDIR}/x11-toolkits/gtkimageview
+LIB_DEPENDS+= libgtkimageview.so:${PORTSDIR}/x11-toolkits/gtkimageview
PLIST_SUB+= MGTK2=""
.else
PLIST_SUB+= MGTK2="@comment "
diff --git a/math/octave-forge-fits/Makefile b/math/octave-forge-fits/Makefile
index 39076986307e..5bec076f46b4 100644
--- a/math/octave-forge-fits/Makefile
+++ b/math/octave-forge-fits/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge-fits
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
@@ -17,7 +17,7 @@ OCTSRC= ${OCTAVE_PKGNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
-LIB_DEPENDS+= cfitsio:${PORTSDIR}/astro/cfitsio
+LIB_DEPENDS+= libcfitsio.so:${PORTSDIR}/astro/cfitsio
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 76abe3a168c3..dced0b903699 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kst
DISTVERSION= 2.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/