aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-24 22:15:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-24 22:15:28 +0000
commitf3a6b7e8ca2b67295c4d93cc4119c4f5d13d8d41 (patch)
treec39b9523c24e7db22a45c5da082318b3c41f33d4
parent3bc9b74974c5efc26b11f87dff9aa9561e39a31b (diff)
downloadports-f3a6b7e8ca2b67295c4d93cc4119c4f5d13d8d41.tar.gz
ports-f3a6b7e8ca2b67295c4d93cc4119c4f5d13d8d41.zip
MFH: r549953
misc/vxl: Fix build on i386 On i386 architectures projects that need SSE2 have to explicitly enable it using -msse2. Also fix WWW. Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=549966
-rw-r--r--misc/vxl/Makefile7
-rw-r--r--misc/vxl/pkg-descr2
2 files changed, 7 insertions, 2 deletions
diff --git a/misc/vxl/Makefile b/misc/vxl/Makefile
index 1b70a16eaa6d..d8a4cd0c54e7 100644
--- a/misc/vxl/Makefile
+++ b/misc/vxl/Makefile
@@ -29,7 +29,12 @@ do-test:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "i386"
+.if ${ARCH} == "amd64"
+PLIST_SUB+= X86=""
+CMAKE_ON+= VIL_CONFIG_ENABLE_SSE2_ROUNDING # the automatic SSE2 test fails on i386: Performing Try-Run Test VXL_HAS_SSE2_HARDWARE_SUPPORT - Test Compilation Failed
+.elif ${ARCH} == "i386"
+CFLAGS+= -msse2 # sse2 is not enabled on i386 by default as it is enabled on amd64, see https://github.com/vxl/vxl/issues/795
+CXXFLAGS+= -msse2
PLIST_SUB+= X86=""
CMAKE_ON+= VIL_CONFIG_ENABLE_SSE2_ROUNDING # the automatic SSE2 test fails on i386: Performing Try-Run Test VXL_HAS_SSE2_HARDWARE_SUPPORT - Test Compilation Failed
.else
diff --git a/misc/vxl/pkg-descr b/misc/vxl/pkg-descr
index f3c46b5bcd7e..b23ecb190863 100644
--- a/misc/vxl/pkg-descr
+++ b/misc/vxl/pkg-descr
@@ -3,4 +3,4 @@ for computer vision research and implementation. It was created from TargetJr
and the IUE with the aim of making a light, fast and consistent system. VXL is
written in ANSI/ISO C++ and is designed to be portable over many platforms.
-WWW: https://github.com/vxl/vxl
+WWW: https://vxl.github.io/