aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-27 19:02:49 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-27 19:02:49 +0000
commitf85d2ab0d4170d296fb025c2e25ece573454b02f (patch)
treef13ec6a09182727be385f63afc7dc868d4281476
parent586daa75a99d1a09d7821ef7bd2c742488480153 (diff)
downloadports-f85d2ab0d4170d296fb025c2e25ece573454b02f.tar.gz
ports-f85d2ab0d4170d296fb025c2e25ece573454b02f.zip
Notes
-rw-r--r--mail/postfix-current/Makefile149
-rw-r--r--mail/postfix-current/distinfo6
-rw-r--r--mail/postfix-current/files/patch-conf::main.cf17
3 files changed, 89 insertions, 83 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index b5cc1384ee40..e265f3fdc1ff 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-DISTVERSION= 2.3-20060315
+DISTVERSION= 2.3-20060325
PORTEPOCH= 2
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
@@ -255,54 +255,51 @@ READMEDIR=${PREFIX}/share/doc/postfix
SUB_LIST+= REQUIRE="${_REQUIRE}"
pre-patch:
-. if defined(POSTFIX_OPTIONS)
- @${ECHO_MSG}
- @${ECHO_MSG}
- @${ECHO_MSG}
- @${ECHO_MSG} "***** ALERT *****"
- @${ECHO_MSG} "POSTFIX_OPTIONS don't work anymore, now"
- @${ECHO_MSG} "${PORTNAME} use OPTIONS, consider use:"
- @${ECHO_MSG} "# make config"
- @${ECHO_MSG}
- @${ECHO_MSG}
- @${ECHO_MSG}
- @sleep 10
-. endif
-
-. if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-. endif
-. if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
- @if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
- ${ECHO_MSG}; \
- ${ECHO_MSG} "Your SASL2 library it's compiled with MYSQL"; \
- ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
- ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
- ${ECHO_MSG} "# make clean config"; \
- ${ECHO_MSG}; \
- sleep 5; \
- fi
-. endif
+.if defined(POSTFIX_OPTIONS)
+ @${ECHO_MSG}
+ @${ECHO_MSG}
+ @${ECHO_MSG}
+ @${ECHO_MSG} "***** ALERT *****"
+ @${ECHO_MSG} "POSTFIX_OPTIONS don't work anymore, now"
+ @${ECHO_MSG} "${PORTNAME} use OPTIONS, consider use:"
+ @${ECHO_MSG} "# make config"
+ @${ECHO_MSG}
+ @${ECHO_MSG}
+ @${ECHO_MSG}
+ @sleep 10
+.endif
+
+.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
+ @if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
+ ${ECHO_MSG}; \
+ ${ECHO_MSG} "Your SASL library it's compiled with MYSQL"; \
+ ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
+ ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
+ ${ECHO_MSG} "# make clean config"; \
+ ${ECHO_MSG}; \
+ sleep 5; \
+ fi
+.endif
+.if defined(WITH_SASL2) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl2.a)
+ @if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | ${GREP} -wq "mysql_init"; then \
+ ${ECHO_MSG}; \
+ ${ECHO_MSG} "Your SASL2 library it's compiled with MYSQL"; \
+ ${ECHO_MSG} "If you use MYSQL in ${PORTNAME} consider CTRL+C and"; \
+ ${ECHO_MSG} "select MYSQL OPTION in config menu."; \
+ ${ECHO_MSG} "# make clean config"; \
+ ${ECHO_MSG}; \
+ sleep 5; \
+ fi
+.endif
@${ECHO} "<HTML><BODY>See <A HREF="header_checks.5.html">header_checks.5.html</A></BODY></HTML>" \
> ${WRKSRC}/html/body_checks.5.html
- @for f in `${FIND} -P ${WRKSRC}/man -type f`; do \
- ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
- done
- @for f in `${FIND} -P ${WRKSRC}/README_FILES -type f`; do \
- ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
- done
- @for f in `${FIND} -P ${WRKSRC}/conf -type f`; do \
- ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
- done
+ @${FIND} -P ${WRKSRC}/man -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g"
+ @${FIND} -P ${WRKSRC}/README_FILES -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g"
+ @${FIND} -P ${WRKSRC}/conf -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g"
post-patch:
# All files modified with ${FILESDIR}/patch-* to use !!PREFIX!! need REINPLACE. Put below.
@@ -320,38 +317,38 @@ pre-install:
do-install:
cd ${WRKSRC}; ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
- config_directory=${PREFIX}/etc/postfix \
- daemon_directory=${PREFIX}/libexec/postfix \
- command_directory=${PREFIX}/sbin \
- queue_directory=/var/spool/postfix \
- sendmail_path=${PREFIX}/sbin/sendmail \
- newaliases_path=${PREFIX}/bin/newaliases \
- mailq_path=${PREFIX}/bin/mailq \
- mail_owner=postfix \
- setgid_group=maildrop \
- manpage_directory=${MANPREFIX}/man \
- sample_directory=${PREFIX}/etc/postfix \
- readme_directory=${READMEDIR}
-
- @${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/rmail/rmail ${PREFIX}/bin/rmail
-
-. for f in ${BINTEST}
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${PREFIX}/sbin
-. endfor
-. for f in ${MANTEST}
- @${INSTALL_MAN} ${WRKSRC}/man/man1/${f} ${MANPREFIX}/man/man1
-. endfor
+ config_directory=${PREFIX}/etc/postfix \
+ daemon_directory=${PREFIX}/libexec/postfix \
+ command_directory=${PREFIX}/sbin \
+ queue_directory=/var/spool/postfix \
+ sendmail_path=${PREFIX}/sbin/sendmail \
+ newaliases_path=${PREFIX}/bin/newaliases \
+ mailq_path=${PREFIX}/bin/mailq \
+ mail_owner=postfix \
+ setgid_group=maildrop \
+ manpage_directory=${MANPREFIX}/man \
+ sample_directory=${PREFIX}/etc/postfix \
+ readme_directory=${READMEDIR}
+
+ ${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/rmail/rmail ${PREFIX}/bin/rmail
+
+.for f in ${BINTEST}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${PREFIX}/sbin
+.endfor
+.for f in ${MANTEST}
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${f} ${MANPREFIX}/man/man1
+.endfor
@${MKDIR} ${PREFIX}/etc/postfix/dist
-. for f in ${CONF1}
- ${INSTALL_DATA} ${WRKSRC}/conf/${f} ${PREFIX}/etc/postfix/dist
-. endfor
-
-. if !defined(NOPORTDOCS)
- @${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} -m 555 ${DOCSDIR}
- @cd ${WRKSRC}/html && ${INSTALL_DATA} *.html *.jpg *.png ${DOCSDIR} && \
- ${ECHO_MSG} "Installed HTML documentation in ${DOCSDIR}"
-. endif
+.for f in ${CONF1}
+ ${INSTALL_DATA} ${WRKSRC}/conf/${f} ${PREFIX}/etc/postfix/dist
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} -m 555 ${DOCSDIR}
+ @cd ${WRKSRC}/html && ${INSTALL_DATA} *.html *.jpg *.png ${DOCSDIR} && \
+ ${ECHO_MSG} "Installed HTML documentation in ${DOCSDIR}"
+.endif
post-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 9b0f6fc34255..eb7e9abfbf16 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,3 +1,3 @@
-MD5 (postfix/postfix-2.3-20060315.tar.gz) = 8dff770ef22447c8d4f6291d729bec72
-SHA256 (postfix/postfix-2.3-20060315.tar.gz) = 603c4b2da6e8281b3c6d3b742c4bd30ea9609b224aa080583e4f422bc41c909c
-SIZE (postfix/postfix-2.3-20060315.tar.gz) = 2595530
+MD5 (postfix/postfix-2.3-20060325.tar.gz) = 731b8b08ecb1370638366baf1ac0b4c7
+SHA256 (postfix/postfix-2.3-20060325.tar.gz) = cf0120dabc7e2d33b2fa5dd3759a6e546ba35ac26bc6538a8b32a54d0b1bde18
+SIZE (postfix/postfix-2.3-20060325.tar.gz) = 2597951
diff --git a/mail/postfix-current/files/patch-conf::main.cf b/mail/postfix-current/files/patch-conf::main.cf
index 67e356de21dd..a9cb3c360058 100644
--- a/mail/postfix-current/files/patch-conf::main.cf
+++ b/mail/postfix-current/files/patch-conf::main.cf
@@ -1,6 +1,6 @@
---- conf/main.cf.orig Sat Mar 5 11:53:42 2005
-+++ conf/main.cf Sat Mar 5 11:53:42 2005
-@@ -32,13 +32,13 @@
+--- conf/main.cf.orig Mon Mar 27 15:58:38 2006
++++ conf/main.cf Mon Mar 27 15:59:02 2006
+@@ -33,13 +33,13 @@
# The command_directory parameter specifies the location of all
# postXXX commands.
#
@@ -16,7 +16,16 @@
# QUEUE AND PROCESS OWNERSHIP
#
-@@ -608,37 +608,37 @@
+@@ -238,7 +238,7 @@
+ #
+ #mynetworks_style = class
+ #mynetworks_style = subnet
+-#mynetworks_style = host
++mynetworks_style = host
+
+ # Alternatively, you can specify the mynetworks list by hand, in
+ # which case Postfix ignores the mynetworks_style setting.
+@@ -609,37 +609,37 @@
# sendmail_path: The full pathname of the Postfix sendmail command.
# This is the Sendmail-compatible mail posting interface.
#