aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-04-11 00:27:27 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-04-11 00:27:27 +0000
commitfa9ee9fb771ff35e9dfc6807fb6000c1885146e7 (patch)
tree93122ec10a924dde0b9d3919bf4eda92a02276d0
parentff7bbc16454736a15422e5cfaeba703816d8b335 (diff)
downloadports-fa9ee9fb771ff35e9dfc6807fb6000c1885146e7.tar.gz
ports-fa9ee9fb771ff35e9dfc6807fb6000c1885146e7.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/sdpa-gmp/Makefile44
-rw-r--r--math/sdpa-gmp/distinfo6
-rw-r--r--math/sdpa-gmp/pkg-descr10
-rw-r--r--math/sdpa-gmp/pkg-plist5
5 files changed, 66 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a53b1735f536..f9737b4626e2 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -352,6 +352,7 @@
SUBDIR += scilab-toolbox-sivp
SUBDIR += scilab-toolbox-swt
SUBDIR += sdpa
+ SUBDIR += sdpa-gmp
SUBDIR += sdpara
SUBDIR += ses
SUBDIR += simd-viterbi
diff --git a/math/sdpa-gmp/Makefile b/math/sdpa-gmp/Makefile
new file mode 100644
index 000000000000..296d5332dba5
--- /dev/null
+++ b/math/sdpa-gmp/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: sdpa-gmp
+# Date created: 2008/4/11
+# Whom: NAKATA, Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdpa-gmp
+PORTVERSION= 7.1.0
+CATEGORIES= math
+MASTER_SITES= http://sdpa.indsys.chuo-u.ac.jp/sdpa/files/
+DISTFILES= ${SRCFILE} ${MANUALFILE}
+DIST_SUBDIR= sdpa
+EXTRACT_ONLY= ${SRCFILE}
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Multi pricision arithmetic version of math/sdpa
+
+.include <bsd.port.pre.mk>
+
+SRCDATE= 20080410
+MANDATE= 20080410
+SRCFILE= ${PORTNAME}.${PORTVERSION}.src.${SRCDATE}.tar.gz
+MANUALFILE= sdpa.${PORTVERSION}.manual.${MANDATE}.pdf
+GNU_CONFIGURE= yes
+LIB_DEPENDS+= spooles:${PORTSDIR}/math/spooles \
+ gmp.7:${PORTSDIR}/math/libgmp4 \
+ mpfr.2:${PORTSDIR}/math/mpfr
+
+CONFIGURE_ARGS+= --with-system-spooles
+CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB+= MANUALFILE=${MANUALFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sdpa_gmp ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/param.sdpa ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${MANUALFILE} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/sdpa-gmp/distinfo b/math/sdpa-gmp/distinfo
new file mode 100644
index 000000000000..dfd055306009
--- /dev/null
+++ b/math/sdpa-gmp/distinfo
@@ -0,0 +1,6 @@
+MD5 (sdpa/sdpa-gmp.7.1.0.src.20080410.tar.gz) = 8748921328e13ab9f9fcb058ba4e080c
+SHA256 (sdpa/sdpa-gmp.7.1.0.src.20080410.tar.gz) = 127a3b6063bd092a58c7c109f722b7575871c41d80560bc98a28b1c2b278ce1c
+SIZE (sdpa/sdpa-gmp.7.1.0.src.20080410.tar.gz) = 4720640
+MD5 (sdpa/sdpa.7.1.0.manual.20080410.pdf) = 3a1f6f406cc5a4f76a0a5548d768bedf
+SHA256 (sdpa/sdpa.7.1.0.manual.20080410.pdf) = 67d7ced4bee1942137ac43e0d99f700ccc508fa53aeda0cff41e1d25c2aa1942
+SIZE (sdpa/sdpa.7.1.0.manual.20080410.pdf) = 261970
diff --git a/math/sdpa-gmp/pkg-descr b/math/sdpa-gmp/pkg-descr
new file mode 100644
index 000000000000..ce6ed45a1b14
--- /dev/null
+++ b/math/sdpa-gmp/pkg-descr
@@ -0,0 +1,10 @@
+The SDPA-GMP (The GMP version of SemiDefinite Programming Algorithm)
+is a software package for solving semidefinite program (SDP), intended
+for very hard to solve SDPs and SDPs requires ultra high accuracy.
+It is based on a Mehrotra-type predictor-corrector infeasible
+primal-dual interior-point method. The SDPA-GMP shares the same
+features as the SDPA, excpt for calculations will be done
+with multiple precision arithmetics via the GMP
+(the GNU Multiple Precision Arithmetic Library).
+
+WWW: http://sdpa.indsys.chuo-u.ac.jp/sdpa/index.html
diff --git a/math/sdpa-gmp/pkg-plist b/math/sdpa-gmp/pkg-plist
new file mode 100644
index 000000000000..7400e5de37be
--- /dev/null
+++ b/math/sdpa-gmp/pkg-plist
@@ -0,0 +1,5 @@
+bin/sdpa_gmp
+share/sdpa-gmp/param.sdpa
+@dirrm share/sdpa-gmp
+%%PORTDOCS%%%%DOCSDIR%%/%%MANUALFILE%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%