aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-03-07 15:24:50 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-03-07 15:24:50 +0000
commitfd34ff3032e6654c03067cbbb2a2d10d1b4b4f47 (patch)
treee208e5491c2448c2053d836646e5a002d3edc3cd
parentb9bafb8b33710abd5145750a612f250dd0e19709 (diff)
downloadports-fd34ff3032e6654c03067cbbb2a2d10d1b4b4f47.tar.gz
ports-fd34ff3032e6654c03067cbbb2a2d10d1b4b4f47.zip
Notes
-rw-r--r--devel/g-wrap/Makefile10
-rw-r--r--devel/g-wrap/files/patch-configure2
-rw-r--r--devel/g-wrap/files/patch-libffi_configure12
3 files changed, 13 insertions, 11 deletions
diff --git a/devel/g-wrap/Makefile b/devel/g-wrap/Makefile
index 605ce9df4880..445969291ea6 100644
--- a/devel/g-wrap/Makefile
+++ b/devel/g-wrap/Makefile
@@ -28,14 +28,8 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= --build=x86_64-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH:S/amd64/x86_64/}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC"
-.else
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|"glib"|"glib-2.0"|g ; \
@@ -54,4 +48,4 @@ post-install:
${PREFIX}/include/g-wrap/ffi
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/g-wrap/files/patch-configure b/devel/g-wrap/files/patch-configure
index 533ef97a9c06..f182f78a641f 100644
--- a/devel/g-wrap/files/patch-configure
+++ b/devel/g-wrap/files/patch-configure
@@ -25,7 +25,7 @@
+ LD="${LD-ld} -m elf_s390"
+ ;;
+ sparc64-*freebsd*)
-+ LD="${LD-ld} -m elf32_sparc"
++ LD="${LD-ld} -m elf_sparc"
+ ;;
+ esac
+ ;;
diff --git a/devel/g-wrap/files/patch-libffi_configure b/devel/g-wrap/files/patch-libffi_configure
index 2121d0c04a00..e9d1e4119a26 100644
--- a/devel/g-wrap/files/patch-libffi_configure
+++ b/devel/g-wrap/files/patch-libffi_configure
@@ -1,5 +1,5 @@
---- libffi/configure.orig Tue Sep 12 17:01:51 2006
-+++ libffi/configure Tue Sep 12 17:02:19 2006
+--- libffi/configure.orig Wed Mar 7 10:16:39 2007
++++ libffi/configure Wed Mar 7 10:20:54 2007
@@ -3285,7 +3285,7 @@
;;
esac
@@ -9,3 +9,11 @@
fi;
# Check whether --enable-static or --disable-static was given.
+@@ -19911,6 +19911,7 @@
+ frv-*-*) TARGET=FRV; TARGETDIR=frv;;
+ sparc-sun-4*) TARGET=SPARC; TARGETDIR=sparc;;
+ sparc*-sun-*) TARGET=SPARC; TARGETDIR=sparc;;
++sparc*-freebsd*) TARGET=SPARC; TARGETDIR=sparc;;
+ sparc-*-linux* | sparc-*-netbsdelf* | sparc-*-knetbsd*-gnu) TARGET=SPARC; TARGETDIR=sparc;;
+ sparc64-*-linux* | sparc64-*-netbsd* | sparc64-*-knetbsd*-gnu) TARGET=SPARC; TARGETDIR=sparc;;
+ alpha*-*-linux* | alpha*-*-osf* | alpha*-*-freebsd* | alpha*-*-kfreebsd*-gnu | alpha*-*-netbsd* | alpha*-*-knetbsd*-gnu) TARGET=ALPHA; TARGETDIR=alpha;;