aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-09-04 03:05:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-09-04 03:05:23 +0000
commit07192a24edc994bcc30e3658b0262c06b10a183c (patch)
tree8db48774b6758a80fd4e62077728277c3efd9d53
parent28e3778d591330a283000fb5bd00552b0ca710a9 (diff)
downloadports-07192a24edc994bcc30e3658b0262c06b10a183c.tar.gz
ports-07192a24edc994bcc30e3658b0262c06b10a183c.zip
Notes
-rw-r--r--databases/py-sqlite3/Makefile4
-rw-r--r--devel/gobject-introspection/Makefile8
-rw-r--r--devel/icu/Makefile4
-rw-r--r--devel/nspr/Makefile4
-rw-r--r--devel/qt4-moc/Makefile8
-rw-r--r--devel/qt4-rcc/Makefile8
-rw-r--r--devel/qt4-uic/Makefile8
-rw-r--r--graphics/cairo/Makefile4
-rw-r--r--mail/dovecot/Makefile4
-rw-r--r--mail/dovecot2/Makefile4
-rw-r--r--net-p2p/rtorrent/Makefile4
-rw-r--r--net/vnc/Makefile4
12 files changed, 60 insertions, 4 deletions
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index 827d722b45e4..2857802f39a2 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -30,6 +30,10 @@ PYDISTUTILS_NOEGGINFO= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not install on arm
+.endif
+
post-extract:
.if ${PYTHON_REL} < 300
@${CP} ${FILESDIR}/setup.py ${WRKSRC}
diff --git a/devel/gobject-introspection/Makefile b/devel/gobject-introspection/Makefile
index 8a1f69855389..5013e9d0724c 100644
--- a/devel/gobject-introspection/Makefile
+++ b/devel/gobject-introspection/Makefile
@@ -42,4 +42,10 @@ post-patch:
@${REINPLACE_CMD} -e "s|'cc'|'${CC:Q:C/[[:space:]]+/', '/g}'|g" \
${WRKSRC}/giscanner/sourcescanner.py
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
index 4ad6fec7262f..0aa540984fc6 100644
--- a/devel/icu/Makefile
+++ b/devel/icu/Makefile
@@ -64,6 +64,10 @@ PLIST_SUB+= ICUMAJOR=${ICUMAJOR} ICUMINOR=${ICUMINOR} ICUVER=${PORTVERSION}
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
.if defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-threads=no
.else
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index c85791a4feb2..d2e54bd1dea6 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -31,6 +31,10 @@ LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g ; s,echo aout,echo elf,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/devel/qt4-moc/Makefile b/devel/qt4-moc/Makefile
index 0cd7c464a805..087dcbeb38ad 100644
--- a/devel/qt4-moc/Makefile
+++ b/devel/qt4-moc/Makefile
@@ -54,4 +54,10 @@ pre-configure:
pre-build:
cd ${BUILD_WRKSRC}/../bootstrap && ${MAKE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/qt4-rcc/Makefile b/devel/qt4-rcc/Makefile
index 7615cf9cb4eb..595c43667391 100644
--- a/devel/qt4-rcc/Makefile
+++ b/devel/qt4-rcc/Makefile
@@ -53,4 +53,10 @@ pre-configure:
pre-build:
cd ${BUILD_WRKSRC}/../bootstrap && ${MAKE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/qt4-uic/Makefile b/devel/qt4-uic/Makefile
index 231bad5105d4..cc2732c96cb1 100644
--- a/devel/qt4-uic/Makefile
+++ b/devel/qt4-uic/Makefile
@@ -54,4 +54,10 @@ pre-configure:
pre-build:
cd ${BUILD_WRKSRC}/../bootstrap && ${MAKE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 4ded27affaba..b33f5e023339 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -49,6 +49,10 @@ OPTIONS+= GL "Enable OpenGL Support" Off \
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
.if defined(WITH_GL)
USE_GL= gl
CONFIGURE_ARGS+= --enable-gl
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index f42a7d1d79ac..10f877c37cbe 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -70,6 +70,10 @@ OPTIONS= KQUEUE "kqueue(2) support" on \
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not build on arm
+.endif
+
# Default requirement for dovecot rc script
_REQUIRE= LOGIN
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 38892d8e1f71..de2a82d0e92e 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -58,6 +58,10 @@ SOLR_DESC= Solr FTS support
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not build on arm
+.endif
+
# sed script for dovecot.conf
REINPLACE= s!%%PROTOCOLS%%!${PROTOCOLS}!g;\
s!/usr/!${PREFIX}/!g;\
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index f02df262a832..943623bba532 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -37,6 +37,10 @@ OPTIONS= XMLRPC "Compile with xmlrpc-c support" on \
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
.if !defined(WITHOUT_XMLRPC)
CONFIGURE_ARGS+= --with-xmlrpc-c
LIB_DEPENDS+= xmlrpc.3:${PORTSDIR}/net/xmlrpc-c-devel
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index 47ae216f20b0..ddc02df26f78 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -44,6 +44,10 @@ PREFIX=${REALVNC_BASE}
.include <bsd.port.pre.mk>
+.if ${ARCH} == "arm"
+BROKEN= Does not compile on arm
+.endif
+
.if !defined(WITHOUT_SERVER)
MASTER_SITES+= ${MASTER_SITE_XORG:S/$/:x/}
MASTER_SITE_SUBDIR+= 4.3.0/:x