aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-12-16 21:38:27 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-12-16 21:38:27 +0000
commit0bd9d59870d4e843dcbaa8e833ccb30d6f41302a (patch)
tree76b9964364b6cc1e63a0d141c8248758212e7e74
parent59e2465e151046cae9d8db77da41acf38a110f5b (diff)
downloadports-0bd9d59870d4e843dcbaa8e833ccb30d6f41302a.tar.gz
ports-0bd9d59870d4e843dcbaa8e833ccb30d6f41302a.zip
MFH: r556981 r558241 r558242
Notes
Notes: svn path=/branches/2020Q4/; revision=558243
-rw-r--r--dns/bind911/Makefile2
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind911/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind916/files/patch-configure8
7 files changed, 26 insertions, 26 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index 4a51a89a058b..258e3c46668b 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= cpe libedit pkgconfig
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.25
+ISCVERSION= 9.11.26
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index 00d01ebe6f4f..a1130d1ce391 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1606573875
-SHA256 (bind-9.11.25.tar.gz) = 8491c24e5a3da68f421d0fcb946602c8d0ff963012fdd176b8026c8890f3a117
-SIZE (bind-9.11.25.tar.gz) = 8284943
+TIMESTAMP = 1608153444
+SHA256 (bind-9.11.26.tar.gz) = c93a7be0ff76027ab799f030aafe8b4eede8bd2fa2c40a83858c2c43c5bee8b3
+SIZE (bind-9.11.26.tar.gz) = 8286586
diff --git a/dns/bind911/files/extrapatch-bind-min-override-ttl b/dns/bind911/files/extrapatch-bind-min-override-ttl
index 815ee5d1f108..2b11ce61b331 100644
--- a/dns/bind911/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind911/files/extrapatch-bind-min-override-ttl
@@ -1,7 +1,7 @@
- Add the min-cache-ttl config knob.
- Add the override-cache-ttl config knob.
---- bin/named/config.c.orig 2020-10-13 11:00:08 UTC
+--- bin/named/config.c.orig 2020-12-08 08:36:42 UTC
+++ bin/named/config.c
@@ -182,6 +182,8 @@ options {\n\
" max-acache-size 16M;\n\
@@ -12,7 +12,7 @@
max-clients-per-query 100;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
max-recursion-depth 7;\n\
---- bin/named/server.c.orig 2020-10-13 11:00:08 UTC
+--- bin/named/server.c.orig 2020-12-08 08:36:42 UTC
+++ bin/named/server.c
@@ -3720,6 +3720,16 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -31,7 +31,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2020-10-13 11:00:08 UTC
+--- lib/dns/include/dns/view.h.orig 2020-12-08 08:36:42 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,8 @@ struct dns_view {
bool requestnsid;
@@ -42,9 +42,9 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2020-10-13 11:00:08 UTC
+--- lib/dns/resolver.c.orig 2020-12-08 08:36:42 UTC
+++ lib/dns/resolver.c
-@@ -5572,6 +5572,18 @@ cache_name(fetchctx_t *fctx, dns_message_t *rmessage,
+@@ -5579,6 +5579,18 @@ cache_name(fetchctx_t *fctx, dns_message_t *rmessage,
}
/*
@@ -63,7 +63,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-10-13 11:00:08 UTC
+--- lib/isccfg/namedconf.c.orig 2020-12-08 08:36:42 UTC
+++ lib/isccfg/namedconf.c
@@ -1773,6 +1773,8 @@ view_clauses[] = {
#endif
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 54e5d80bc0bb..df23e3f6ec2e 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -41,7 +41,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.9
+ISCVERSION= 9.16.10
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index fafaaf70ab0a..f64217da211a 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1606573953
-SHA256 (bind-9.16.9.tar.xz) = bcb292c4d738a46e3cbcb8afaa25ecf54f77652fa575135da9a2a1d525304a5a
-SIZE (bind-9.16.9.tar.xz) = 3260964
+TIMESTAMP = 1608153504
+SHA256 (bind-9.16.10.tar.xz) = bc47fc019c6205e6a6bfb839c544a1472321df0537ba905b846a4cbffe3362b3
+SIZE (bind-9.16.10.tar.xz) = 3269696
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index ac8dcacc3f71..c64d9c1ffd12 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-11-16 14:44:37 UTC
+--- bin/named/config.c.orig 2020-12-07 08:16:53 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-11-16 14:44:37 UTC
+--- bin/named/server.c.orig 2020-12-07 08:16:53 UTC
+++ bin/named/server.c
-@@ -4344,6 +4344,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4345,6 +4345,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-11-16 14:44:37 UTC
+--- lib/dns/include/dns/view.h.orig 2020-12-07 08:16:53 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-11-16 14:44:37 UTC
+--- lib/dns/resolver.c.orig 2020-12-07 08:16:53 UTC
+++ lib/dns/resolver.c
-@@ -6274,6 +6274,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -6281,6 +6281,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-11-16 14:44:37 UTC
+--- lib/isccfg/namedconf.c.orig 2020-12-07 08:16:53 UTC
+++ lib/isccfg/namedconf.c
-@@ -1990,6 +1990,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2023,6 +2023,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index b07f9c49095b..5671b13eae28 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-11-16 14:44:37 UTC
+--- configure.orig 2020-12-07 08:16:53 UTC
+++ configure
-@@ -17698,27 +17698,9 @@ done
+@@ -17696,27 +17696,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17761,47 +17743,7 @@ $as_echo "no" >&6; } ;;
+@@ -17759,47 +17741,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23220,7 +23162,7 @@ $as_echo "" >&6; }
+@@ -23215,7 +23157,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).