aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-20 11:57:29 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-20 11:57:29 +0000
commit1231964f981e5ede95b7d8f4dc05a529cef2ce3a (patch)
tree71e11351327a508a1fccf74f14d07c0f144f2e20
parent07541af26ef4d5c23db5f97c49be965febb31fb4 (diff)
downloadports-1231964f981e5ede95b7d8f4dc05a529cef2ce3a.tar.gz
ports-1231964f981e5ede95b7d8f4dc05a529cef2ce3a.zip
Notes
-rw-r--r--games/openclonk/Makefile1
-rw-r--r--games/openclonk/files/patch-CMakeLists.txt14
2 files changed, 12 insertions, 3 deletions
diff --git a/games/openclonk/Makefile b/games/openclonk/Makefile
index 06a4f1b09f73..165aa62033bb 100644
--- a/games/openclonk/Makefile
+++ b/games/openclonk/Makefile
@@ -33,6 +33,7 @@ USE_SDL= sdl2
USE_XORG= x11 xpm
INSTALLS_ICONS= yes
CMAKE_ARGS= -DAudio_TK:STRING="OpenAL"
+LLD_UNSAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's|DESTINATION games|DESTINATION bin|' \
diff --git a/games/openclonk/files/patch-CMakeLists.txt b/games/openclonk/files/patch-CMakeLists.txt
index e30285fee150..24afcb82ee29 100644
--- a/games/openclonk/files/patch-CMakeLists.txt
+++ b/games/openclonk/files/patch-CMakeLists.txt
@@ -1,6 +1,14 @@
---- CMakeLists.txt.orig 2018-02-08 07:27:37 UTC
+--- CMakeLists.txt.orig 2018-03-16 17:25:33 UTC
+++ CMakeLists.txt
-@@ -320,8 +320,6 @@ if(READLINE_FOUND)
+@@ -91,7 +91,6 @@ function(add_linker_flags)
+ endforeach()
+ endfunction()
+
+-CHECK_CXX_COMPILER_FLAG("-flto" USE_GCC_STYLE_LTCG)
+ if(USE_GCC_STYLE_LTCG)
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -flto")
+ set(CMAKE_CXX_FLAGS_MINSIZEREL "${CMAKE_CXX_FLAGS_MINSIZEREL} -flto")
+@@ -337,8 +336,6 @@ if(READLINE_FOUND)
endif()
SET(HAVE_LIBREADLINE ${READLINE_FOUND} CACHE INTERNAL "libreadline available")
@@ -9,7 +17,7 @@
# Select an audio library
find_package("Audio")
if(Audio_FOUND)
-@@ -339,8 +337,6 @@ set(HAVE_SDL ${SDL2_FOUND})
+@@ -356,8 +353,6 @@ set(HAVE_SDL ${SDL2_FOUND})
include_directories(SYSTEM ${SDL2_INCLUDE_DIRS})
# Qt5 for editor