aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-24 01:44:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-24 01:44:32 +0000
commit14f8697cff14c2cad0e4ecb194e7cc2385beaa52 (patch)
tree4f79f3cf7226c73caaf8507b354b7ba5137f55b1
parent036d6c9b3b0e56eed1aeafaa1309908e6971ece4 (diff)
downloadports-14f8697cff14c2cad0e4ecb194e7cc2385beaa52.tar.gz
ports-14f8697cff14c2cad0e4ecb194e7cc2385beaa52.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Kwiki-RecentChanges/Makefile31
-rw-r--r--www/p5-Kwiki-RecentChanges/distinfo2
-rw-r--r--www/p5-Kwiki-RecentChanges/pkg-descr6
-rw-r--r--www/p5-Kwiki-RecentChanges/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e2aea77d3be2..c4a57450b8c8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -469,6 +469,7 @@
SUBDIR += p5-HTTPD-Tools
SUBDIR += p5-IMDB-Movie
SUBDIR += p5-Kwiki
+ SUBDIR += p5-Kwiki-RecentChanges
SUBDIR += p5-Kwiki-Revisions
SUBDIR += p5-Kwiki-Search
SUBDIR += p5-Kwiki-UserPreferences
diff --git a/www/p5-Kwiki-RecentChanges/Makefile b/www/p5-Kwiki-RecentChanges/Makefile
new file mode 100644
index 000000000000..d779ee55ecbd
--- /dev/null
+++ b/www/p5-Kwiki-RecentChanges/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Kwiki-RecentChanges
+# Date created: Jul 24 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-RecentChanges
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Kwiki Recent Changes Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::RecentChanges.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-RecentChanges/distinfo b/www/p5-Kwiki-RecentChanges/distinfo
new file mode 100644
index 000000000000..7b62a5b57528
--- /dev/null
+++ b/www/p5-Kwiki-RecentChanges/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-RecentChanges-0.11.tar.gz) = ad7673146fb0b23f34107c36ce29ddeb
+SIZE (Kwiki-RecentChanges-0.11.tar.gz) = 8542
diff --git a/www/p5-Kwiki-RecentChanges/pkg-descr b/www/p5-Kwiki-RecentChanges/pkg-descr
new file mode 100644
index 000000000000..81c5b63858f3
--- /dev/null
+++ b/www/p5-Kwiki-RecentChanges/pkg-descr
@@ -0,0 +1,6 @@
+Kwiki::RecentChanges - Kwiki Recent Changes Plugin
+
+shows recently changed files on your Kwiki.
+
+WWW: http://search.cpan.org/dist/Kwiki-RecentChanges/
+Author: Brian Ingerson <INGY at cpan.org>
diff --git a/www/p5-Kwiki-RecentChanges/pkg-plist b/www/p5-Kwiki-RecentChanges/pkg-plist
new file mode 100644
index 000000000000..4fce6793326a
--- /dev/null
+++ b/www/p5-Kwiki-RecentChanges/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Kwiki/RecentChanges.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/RecentChanges/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/RecentChanges
+@unexec rmdir %D/%%SITE_PERL%%/Kwiki 2>/dev/null || true