aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-12-17 15:51:16 +0000
committerClement Laforet <clement@FreeBSD.org>2005-12-17 15:51:16 +0000
commit16c8614c5494036a2ecff931cd8179bdb19208c2 (patch)
tree976be04dd7af9a33ebead42098c351ad0edbaf45
parenta1072b7f96238990274a59f8464551ba5330f37e (diff)
downloadports-16c8614c5494036a2ecff931cd8179bdb19208c2.tar.gz
ports-16c8614c5494036a2ecff931cd8179bdb19208c2.zip
Notes
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/Makefile.modules25
2 files changed, 13 insertions, 14 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 21cce3a88005..a499ad03b254 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/clement/}:powerlogo \
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index 16a007ed7bad..f2f9814e1bf8 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -101,22 +101,16 @@ CFLAGS+= -I${LOCALBASE}/include/mysql ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib/mysql ${PTHREAD_LIBS}
CONFIGURE_ENV+= LIBS="${LIBS}"
WITH_THREADS= YES
-AUTHN_MODULES= authn_dbd
-MISC_MODULES= dbd
.endif
.if defined(WITH_PGSQL)
USE_PGSQL= YES
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
-AUTHN_MODULES= authn_dbd
-MISC_MODULES= dbd
.endif
.if defined(WITH_SQLITE)
USE_SQLITE= YES
CONFIGURE_ARGS+= --with-sqlite3=${LOCALBASE}
-AUTHN_MODULES= authn_dbd
-MISC_MODULES= dbd
.endif
.if defined(WITH_THREADS)
@@ -137,21 +131,26 @@ WITH_SSL_MODULES= yes
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
-AUTH_MODULES+= auth_basic auth_digest
-AUTHN_MODULES+= authn_file authn_dbm authn_anon authn_default
+.if !defined(WITH_THREADS)
+WITHOUT_MODULES+= mem_cache
+.endif
+
+.if !defined(WITH_MYSQL) && !defined(WITH_PGSQL) && !defined(WITH_SQLITE)
+WITHOUT_MODULES+= authn_dbd dbd
+.endif
+
+AUTH_MODULES= auth_basic auth_digest
+AUTHN_MODULES= authn_file authn_dbd authn_dbm authn_anon authn_default
AUTHZ_MODULES= authz_host authz_groupfile authz_user authz_dbm \
authz_owner authz_default
-CACHE_MODULES= cache disk_cache file_cache
-.if defined(WITH_THREADS)
-CACHE_MODULES+= mem_cache
-.endif
+CACHE_MODULES= cache disk_cache file_cache mem_cache
DAV_MODULES= dav dav_fs
EXPERIMENTAL_MODULES= bucketeer case_filter case_filter_in ext_filter charset_lite \
log_forensic optional_hook_export optional_hook_import \
optional_fn_import optional_fn_export
LDAP_MODULES= ldap authnz_ldap
MISC_MODULES+= actions alias asis autoindex cern_meta \
- cgi charset_lite deflate dir env expires \
+ cgi charset_lite dbd deflate dir env expires \
headers imagemap include info log_config logio mime \
mime_magic negotiation rewrite setenvif speling status \
unique_id userdir usertrack vhost_alias filter