aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-12-04 14:29:36 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-12-04 14:29:36 +0000
commit247215aa79a808f813d648e9b1f8ad28655e195c (patch)
treed25810a4c5c76bcec3cebbb0238873b7af75b84f
parent9bb6ea7f340ee40ce4dfd4d9d650f4b81064f27a (diff)
downloadports-247215aa79a808f813d648e9b1f8ad28655e195c.tar.gz
ports-247215aa79a808f813d648e9b1f8ad28655e195c.zip
MFH: r556984
comms/owfs: update to 3.2p4 owfs 3.2p4 have been released, which among other things fixes a FreeBSD build bug. * Update 3.2p3 -> 3.2p4 * Change from USE_GITHUB to MASTER_SITES * Remove OWFS Python bindings, as python2.7 is no longer supported in FreeBSD and owfs python binding does not build with anything else. It is deprecated in favour for pyownet or similar (see https://github.com/owfs/owfs/issues/75 for more details) * Remove owtraffic as it is now builtin. * Add uthash build dependency (header-only) PR: 248868 Approved by: maintainer
Notes
Notes: svn path=/branches/2020Q4/; revision=556985
-rw-r--r--comms/owfs/Makefile34
-rw-r--r--comms/owfs/Makefile.options4
-rw-r--r--comms/owfs/distinfo6
-rw-r--r--comms/owfs/pkg-plist25
4 files changed, 17 insertions, 52 deletions
diff --git a/comms/owfs/Makefile b/comms/owfs/Makefile
index ae22487f94b7..bb8fa3737796 100644
--- a/comms/owfs/Makefile
+++ b/comms/owfs/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= owfs
-PORTVERSION= 3.2p3
-DISTVERSIONPREFIX= v
+PORTVERSION= 3.2p4
PORTREVISION= 1
CATEGORIES= comms
+MASTER_SITES= https://github.com/owfs/owfs/releases/download/v${PORTVERSION}/
MAINTAINER= johan@stromnet.se
COMMENT= 1-wire file system implementation
LICENSE= GPLv2
-USES= autoreconf gmake libtool pkgconfig
+BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash
+
+USES= gmake libtool pkgconfig
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-USE_GITHUB= yes
-
.include "Makefile.options"
OPTIONS_SUB=yes
@@ -50,7 +50,6 @@ OWTAP_CONFIGURE_ENABLE= owtap
OWTAP_USES= tk:wrapper
OWMALLOC_CONFIGURE_ENABLE= owmalloc
-OWTRAFFIC_CONFIGURE_ENABLE= owtraffic
OWMON_CONFIGURE_ENABLE= owmon
OWMON_USES= tk:wrapper
@@ -65,9 +64,6 @@ OWPERL_USE= perl5=build,run
# Broken/untested
OWPHP_CONFIGURE_ENABLE= owphp
-OWPYTHON_CONFIGURE_ENABLE= owpython
-OWPYTHON_USES= python:2.7
-
# Additional CONFIGURE_ARGS is done below
OWTCL_CONFIGURE_ENABLE= owtcl
OWTCL_USES= tcl
@@ -100,15 +96,8 @@ PLIST_SUB+= OWNETPERL=""
PLIST_SUB+= OWNETPERL="@comment "
.endif
-# If OW Network and Python is requested, we get ownet python files
-.if ${PORT_OPTIONS:MOWPYTHON} && ${PORT_OPTIONS:MOWNET}
-PLIST_SUB+= OWNETPYTHON=""
-.else
-PLIST_SUB+= OWNETPYTHON="@comment "
-.endif
-
-# If Perl, Python or PHP is requested, enable SWIG
-.if ${PORT_OPTIONS:MOWPERL} || ${PORT_OPTIONS:MOWPYTHON} || ${PORT_OPTIONS:MOWPHP}
+# If Perl or PHP is requested, enable SWIG
+.if ${PORT_OPTIONS:MOWPERL} || ${PORT_OPTIONS:MOWPHP}
BUILD_DEPENDS+= swig:devel/swig
CONFIGURE_ARGS+= --enable-swig SWIG=${LOCALBASE}/bin/swig
.else
@@ -132,15 +121,6 @@ pre-configure:
@echo "Preparing build using autotools..."
# Workarounds for different problems
-post-install-OWPYTHON-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/python2.7/site-packages/ow/_OW.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so.*
- (cd ${STAGEDIR}${PREFIX} \
- && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
- -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
- (cd ${STAGEDIR}${PREFIX} \
- && ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
- -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
post-install-OWPERL-on:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/OW/OW.so
diff --git a/comms/owfs/Makefile.options b/comms/owfs/Makefile.options
index fa64c64136e7..05e0315ef538 100644
--- a/comms/owfs/Makefile.options
+++ b/comms/owfs/Makefile.options
@@ -13,13 +13,11 @@ OPTIONS_DEFINE = \
OWSERVER \
OWTAP \
OWMALLOC \
- OWTRAFFIC \
OWMON \
OWCAPI \
OWEXTERNAL \
OWPERL \
OWPHP \
- OWPYTHON \
OWTCL \
PROFILING \
OWFS \
@@ -41,14 +39,12 @@ OWHTTPD_DESC= Enable owhttpd HTTP server
OWFTPD_DESC= Enable owftpd FTP server
OWSERVER_DESC= Enable owserver
OWMALLOC_DESC= Enable malloc checking
-OWTRAFFIC_DESC= Enable debug bus traffic reports
OWTAP_DESC= Enable owtap module (X11)
OWMON_DESC= Enable owmon module (X11)
OWCAPI_DESC= Enable C API
OWEXTERNAL_DESC= Enable owexternal
OWPERL_DESC= Enable Perl binding (BROKEN)
OWPHP_DESC= Enable PHP binding (BROKEN)
-OWPYTHON_DESC= Enable Python binding
OWTCL_DESC= Enable TCL binding
PROFILING_DESC= Enable profiling (BROKEN)
OWFS_DESC= Enable FUSE support
diff --git a/comms/owfs/distinfo b/comms/owfs/distinfo
index d6d1ae359ba3..78a8ffb3dc88 100644
--- a/comms/owfs/distinfo
+++ b/comms/owfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540998714
-SHA256 (owfs-owfs-v3.2p3_GH0.tar.gz) = 680385e4db007a951e9678a48989dca7d43868b754299c8368010c80d0c2de4a
-SIZE (owfs-owfs-v3.2p3_GH0.tar.gz) = 1322466
+TIMESTAMP = 1599553594
+SHA256 (owfs-3.2p4.tar.gz) = af0a5035f3f3df876ca15aea13486bfed6b3ef5409dee016db0be67755c35fcc
+SIZE (owfs-3.2p4.tar.gz) = 1614528
diff --git a/comms/owfs/pkg-plist b/comms/owfs/pkg-plist
index 99066dd39af3..4e66de0b5609 100644
--- a/comms/owfs/pkg-plist
+++ b/comms/owfs/pkg-plist
@@ -1,6 +1,6 @@
%%OWCAPI%%include/owcapi.h
-%%OWCAPI%%lib/libowcapi-3.2.so.3
-%%OWCAPI%%lib/libowcapi-3.2.so.3.0.0
+%%OWCAPI%%lib/libowcapi-3.2.so.4
+%%OWCAPI%%lib/libowcapi-3.2.so.4.0.0
%%OWCAPI%%lib/libowcapi.so
%%OWCAPI%%libdata/pkgconfig/owcapi.pc
%%OWEXTERNAL%%bin/owexternal
@@ -9,25 +9,13 @@
%%OWHTTPD%%bin/owhttpd
%%OWMON%%bin/owmon
%%OWNETLIB%%include/ownetapi.h
-%%OWNETLIB%%lib/libownet-3.2.so.3
-%%OWNETLIB%%lib/libownet-3.2.so.3.0.0
+%%OWNETLIB%%lib/libownet-3.2.so.4
+%%OWNETLIB%%lib/libownet-3.2.so.4.0.0
%%OWNETLIB%%lib/libownet.so
%%OWNETPERL%%%%PERL5_MAN3%%/OWNet.3.gz
%%OWNETPERL%%%%SITE_PERL%%/OWNet.pm
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet-0.3-py2.7.egg-info
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/__init__.py
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/__init__.pyc
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/__init__.pyo
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/connection.py
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/connection.pyc
-%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/connection.pyo
%%OWPERL%%%%SITE_ARCH%%/OW.pm
%%OWPERL%%%%SITE_ARCH%%/auto/OW/OW.so
-%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow-3.2p3-py%%PYTHON_VER%%.egg-info
-%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/_OW.so
-%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.py
-%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.pyc
-%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.pyo
%%OWSERVER%%bin/owserver
%%OWSHELL%%bin/owdir
%%OWSHELL%%bin/owexist
@@ -42,8 +30,8 @@
%%OWTCL%%lib/owtcl-1.0/ow.tcl
%%OWTCL%%lib/owtcl-1.0/pkgIndex.tcl
include/owfs_config.h
-lib/libow-3.2.so.3
-lib/libow-3.2.so.3.0.0
+lib/libow-3.2.so.4
+lib/libow-3.2.so.4.0.0
lib/libow.so
man/man1/libowcapi.1.gz
man/man1/libownet.1.gz
@@ -167,3 +155,4 @@ man/man5/owfs.5.gz
man/man5/owfs.conf.5.gz
man/mann/ow.n.gz
man/mann/owtcl.n.gz
+man/man3/InfernoEmbedded.3.gz