aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-05-27 15:01:32 +0000
committerChris Rees <crees@FreeBSD.org>2012-05-27 15:01:32 +0000
commit27af55266fdfb5fdf72ec9374fb979193a6f2bff (patch)
tree7e6425ad8390cd5a15320f5fee93cc5434455867
parentabe33bd8da86d2ff3f2845bf95de870df2573232 (diff)
downloadports-27af55266fdfb5fdf72ec9374fb979193a6f2bff.tar.gz
ports-27af55266fdfb5fdf72ec9374fb979193a6f2bff.zip
Notes
-rw-r--r--misc/Makefile1
-rw-r--r--misc/freeswitch-scripts-devel/Makefile49
-rw-r--r--misc/freeswitch-scripts-devel/distinfo2
-rw-r--r--misc/freeswitch-scripts-devel/pkg-descr1
4 files changed, 53 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 60c2b9a1dca3..6fb26286a400 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -124,6 +124,7 @@
SUBDIR += freeswitch-pizzademo
SUBDIR += freeswitch-pizzademo-devel
SUBDIR += freeswitch-scripts
+ SUBDIR += freeswitch-scripts-devel
SUBDIR += ftdi-eeprom
SUBDIR += fxload
SUBDIR += gcstar
diff --git a/misc/freeswitch-scripts-devel/Makefile b/misc/freeswitch-scripts-devel/Makefile
new file mode 100644
index 000000000000..c01c6c76e011
--- /dev/null
+++ b/misc/freeswitch-scripts-devel/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: freeswitch scripts
+# Date created: september , 2009
+# Whom: Richard Neese <r.neese@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeswitch
+DISTVERSION= 1.2.rc2
+CATEGORIES= misc
+MASTER_SITES= http://files.freeswitch.org/
+PKGNAMESUFFIX= -scripts-devel
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= FreeSwitch Scripts
+
+RUN_DEPENDS= freeswitch:${PORTSDIR}/net/freeswitch-core-devel
+
+CONFLICTS= freeswitch-scripts-[0-9]*
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+FREESWITCH_USER= freeswitch
+FREESWITCH_GROUP= ${FREESWITCH_USER}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}/scripts/
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+PORTEXAMPLES= *
+
+pre-su-install:
+ @${RM} ${WRKSRC}/javascript/ps_pizza.js
+ @${RM} ${WRKSRC}/javascript/pizza.js
+ @${RM} -rf ${WRKSRC}/javascript/js_modules
+ @${MKDIR} ${EXAMPLESDIR}/scripts
+ @${CHOWN} ${FREESWITCH_USER}:${FREESWITCH_GROUP} ${EXAMPLESDIR}/scripts
+ @${TOUCH} ${EXAMPLESDIR}/scripts/.freeswitch-scripts
+ @${CHOWN} ${FREESWITCH_USER}:${FREESWITCH_GROUP} ${EXAMPLESDIR}/scripts/.freeswitch-scripts
+
+do-install:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . \
+ ${EXAMPLESDIR}/scripts/)
+
+ @${CHOWN} -R ${FREESWITCH_USER}:${FREESWITCH_GROUP} \
+ ${EXAMPLESDIR}/scripts/
+
+.include <bsd.port.mk>
diff --git a/misc/freeswitch-scripts-devel/distinfo b/misc/freeswitch-scripts-devel/distinfo
new file mode 100644
index 000000000000..8227fb3a529d
--- /dev/null
+++ b/misc/freeswitch-scripts-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (freeswitch/freeswitch-1.2.rc2.tar.bz2) = bbf9b3f6e7a7569b9594b5852d1b8a95266ef3276df222776ac84667adb6cc08
+SIZE (freeswitch/freeswitch-1.2.rc2.tar.bz2) = 38075354
diff --git a/misc/freeswitch-scripts-devel/pkg-descr b/misc/freeswitch-scripts-devel/pkg-descr
new file mode 100644
index 000000000000..bee8cf8fc976
--- /dev/null
+++ b/misc/freeswitch-scripts-devel/pkg-descr
@@ -0,0 +1 @@
+Port for Various Freeswitch scripts.